Homey Pro 2023 not able to hard reset

I’m not able to hard reset my homey pro 2023 with the pin hole for 30 seconds.
What I’ve tried:
Restart from app
Pushed pin and held for more than 30sec, able to hear the button being pushed

Also worth mentioning is I’m trying to connect my first zigbee device, but I keep getting the message “zigbee is starting up, please try again in 1min”.
I’ve tried restarting multiple times and waiting for a day, but it’s not starting up, hence the hard reset.

And then what? Nothing?

Nothing, just kept showing rainbow colors

Are you sure that you’re pushing the button? The page explaining the procedure is showing a typical SIM-card push pin which isn’t long enough for Homey Pro, you need one that’s longer.

The setup page is showing the right one, which doesn’t work. The left one does:

I used a pin that was even longer, I’ve tried multiple times and I can hear and feel the button being pushed.

In that case, it sounds like a hardware issue and you need to contact Athom.

I am more curious where you read to restart Homey before pressing the button, the support page says, just press the button.

To reset Homey Pro (Early 2023) to factory settings, place and hold a long pin inside the bottom of Homey Pro’s pinhole for 30 seconds.

When Homey Pro’s LED Ring starts circling red, all data is being deleted. Shortly after, Homey Pro’s LED Ring will circle white, indicating that Homey Pro is restarting.

perhaps the button read out isn’t done when Homey Pro is still booting.

1 Like

It’s being read out the moment you power up Homey, that’s also how you put it in setup mode.

Perhaps this works:

  • remove the power cable from Homey
  • press the button (and keep pressing it)
  • plug the cable back in
  • keep the button pressed for at least 30 seconds

Exactly, for setup mode, as that is done on a lower level then resetting your Homey Pro to factory defaults, the factory default signal is probably (most likely) handled by the OS on the pi module, which needs time to boot.
The old Homey Pro’s couldn’t be held upside down for the first 10/15 seconds either when it was just restarting, or it will end up in their “Athom only” boot mode.

A factory reset being handled by the OS doesn’t really make sense. It also doesn’t make sense to have two different factory reset methods: the one entered from setup mode, and one that is handled by the OS.

So a hardware issue is more likely then a pi module not being fully booted up? makes lots of sense.
You know Athom does lots of things differently, then how you would have done it.

Fair enough (I guess that Athom has a special handler for GPIO40 during the time the OS runs, and is able to put the CM4 in USB-MSD mode programmatically instead of all the other implementations that require the pin to be pulled low when the board is powered up).

@Robbaren since you can’t do a factory reset the prescribed way, you can also factory reset your Homey from setup mode, as documented here. It does require a PC or Mac.

1 Like