Error when trying to reset Zigbee Network


When I was trying to add Zigbee devices to my Homey I ran in to some problems with Ikea Trådfri lamps and 5-Button remote. I got stuck with adding the remote as It couldnt be added as a generic zigbee device. Instructions in the Homey-community says it should be possible. After number of trying to add and remove the remote I decided to do a reset of the zigbee network on my Homey. Then I get this error message. See screenshot.

Ive also tried to do a factory reset of the Homey, but still the same error message when trying to reset Zigbee network after doing the factory reset.

Could it be a hardware issue and if so, should I return my Homey to the dealer?

Please help.

Kind regards



As far as I know, Homey doesn’t have support for this device. It’s also not mentioned on the app page as being supported.

After a factory reset:

  • take Homey off power for at least 10 minutes or so before powering it up again
  • after it has been powered up, wait at least 20 to 30 minutes

Yes, that’s exactly what happened to me as well after I first tested my Homey I had the exact same message. This should be reassuring for you @Musicchef; And I did exactly what is recommended here by @robertklep, it worked… My zigbee network became functional :grin:, also I stopped sweating :sweat_smile:. Let’s :crossed_fingers:for you.

Thanks for your quick responses @robertklep and @Arvlux. I´ve tried your suggested solution but with no success. I´ve now done the factory reset procedure twice. With the 10 min power off after factory reset, then power on +30 mins waiting until trying to reset Zigbee. Same error message. Is it worth another try do you think? It´s rather time-consuming to do these reset sequences, but maybe it´s the only way?

I would assume that if you do a factory reset, the Zigbee-part is also reset as part of the procedure. So you shouldn’t have to do a specific Zigbee reset after a factory reset. Perhaps that’s what’s causing the issue?

And what information do you get from ?
If you managed at first to get the zigbee network functional and if you ran into that issue only trying to setup additional Ikea devices, I guess it is most likely a software not an hardware issue. Or I misunderstood something from you …

That may be the issue, but I´m little bit concerned about what the error message means. Is there anyone here who knows what “EBADF: bad file descriptor, close EBADF: bad file descriptor, close” can stand for?

If there is a problem with the Zigbee network I want to sort it out before I´ll be adding 20+ Zigbee devices to my Homey.

I’ve seen people get this error message before, and I don’t think it means that’s something wrong with your hardware. Why specifically you’re getting this error message is something that only Athom can answer (#famouslastwords), but it looks like a relatively harmless bug to me provided that you’re able to get the system up and running again.

I can´t see any error messages in the developer view, but I´m not sure what to look for there. Maybe it´s software related after all and nothing to care about. I´ve also e-mailed Athom Support and will see what they answer. Anyway, I´ll give it a try now to add some Zigbee devices and see how it goes. :crossed_fingers:

Ok it is good, in my case there was no zigbee network but an error message before I applied the factory reset plus new setup; If you see some devices and their routes, it seems to work. Did you detect on what device you get the issue ? is it on the 5 button remote ? Just trying to explore in case it would be device specific …

I googled the error message and found this on (not Homey-related): Bad file descriptor" is a very generic low level error that basically means you are calling an operation on a file descriptor that is no longer in the correct state to handle that operation (like reading a closed file, opening a file that has been deleted, etc).

Yes, that’s why Athom should be the one answering the question on why it happens, because we (as community) don’t have enough access to Homey to debug these kinds of issues.

I see this in the State-view. I´ve not added any devices yet, so these “items” are Homey built in Zigbee devices?
Skärmavbild 2020-04-11 kl. 19.49.30

It was when I tried to add the 5 button remote that the pairing process was starting to act sluggish and after that I couldn´t add Zigbee devices at all (lamps). After that I tried to reset the Zigbee network and got the error message…

Well, the network seems to work then and I would skip the 5 buttons device if I were you, just implementing the rest of the devices; I read in this forum somewhere that this particular device wouldn’t work … For sure it is frustrating not being able to use a device you want, but you probably have tons of other options to replace it …

1 Like

What might an issue is bad batteries /almost empty batteries. I’ve had a problem with I believe Ikea Zigbee components that started shouting in such a case. Just guessing, but have you replaced the batteries of the 5 button remote with fresh ones?