Homey offline, shows rainbow and doesn’t work

I noticed that the lights didn’t go on, my homey was showing a rainbow on its led (while I have the weather as screensaver). I pulled the plug. After 10 minutes it seemed to work again. It showed the weather screensaver. I could access it in the app but apps were loading.
After a while an orange led was showing and then back to the rainbow.
I repeated the proces and I saw that the xiaomi app was crashed.
When I accessed the homey again, I disabled the xiaomi app.
It took a while and the ring turned red. And back to that annoying rainbow.

What the hell is going on?

Try another usb power adapter of at least 2A, sounds like the famous power adapter failure.

How is that possible after weeks of running just fine?

And why is Anthon so ‘cheap’ tongue this thing?

Did you try and did it work?

1 Like

I need to buy it first, right? There are not so many adapters that serve 2A as output.
So no… but I am still curious about that question.

Tested it, but…

Another solution? :wink:

For €7 you can buy a decent adapter from IKEA (max 2.4A per port). Or perhaps you have an unused iPad/phone charger that can put out 2A+.

You mean why it would fail after running fine for weeks? I don’t know the specific reason why the Athom adapter is failing, but my guess would be bad capacitors (which can degrade after some time).

Thanks, I though those Ikea adapters weren’t powerful enough. Switching to all other devices (iPads, iPhones, etc) charging them was very slow with this one so I never use it.

I’ve found an old iPad mini charger with 5V and 2.4A so trying that now… but the original Athom charger is 5V 2A. I though that Athom wasn’t supplying enough power, but it is more of a problem of degrading then?

Is there a way of investigating why the Homey was crashing? I am curious if the Xiami app was causing it or that this app was crashing because the Homey was. And does the Homey set write a log about crashing which I can look into?

Not being able to supply enough power, “unclean” power, not being able to handle power peaks, all symptoms of degradation.

In short: Homey is a black box. You won’t be able to find the specific reason why it’s crashing. The Xiaomi, or any app, shouldn’t be able to crash Homey (although it may cause a crash indirectly if the app causes an increase of power demand, and the adapter is unable to provide it because it’s failing).

Most tablet or (I)phone power adapters give 2A. A little more is even better. So, curious if it works now with your iPad adapter?

So far, so good :slight_smile:

You can contact Athom to receive a new one.
It is an issue that occurs after months/years to lots of users, probably due to degradation of the original adapter. A lot is written about it already on this forum.

Good to hear that it seems to work. You’re welcome :wink:

I don’t need a new adapter. If this iPad mini adapter (which is years old) still works I won’t risk that an Athom one dies again within 7 months. Although it’s were that they ship such a cheap thing if this problem is so common.
Thanks! I hope it keeps working now.

I have the same rainbow problem with my homeys. Let me explain

I used the old homey for several years and had to replace the powersupply when the original one failed.
About 2 weeks ago when i wake up i realized that old homey was showing a rainbow.
Resetting did not work (with or without restoring backup or factorysettings)
Anyway i was planning to upgrade to Homeypro and it arrived the next day but…
My new Homeypro was the same rainbow as the old homey after installing.

What’s the problem with showing a Rainbow, normally this is default and showing that Homey is running.
In Settings / LEDRing you can set a Screensaver (Spectrum = Rainbow)

In Dutch, sorry.

Well, normally my homeys ledring is off.
The homeys are also unresponse.
I might add another thing.
When i restore a homey (upside down etc.) it connects to my wifi just fine and ask to restore a backup or use factory defaults (I tried both).
That seems to work but i get a brief notice on my android homey app after a bit that there was an error.

Er ging iets fout. Probeer het later opnieuw.

They the rainbowring appears and the homey is unresponsive again.
In short, there is no homey to be found in the homey app ( both android and pc browser)

I have the weather screensaver, so showing a rainbow isn’t normal.
Same goes for restore mode, no wifi connectivity and a few hours later homey is working as if nothing happened.