Homey off-line shortly

Hi guys,

I have a problem in Developer.

When I go into developer (https://tools.developer.homey.app/) and when I then go to Zigbee, Z-Wave, Setting or whatever, I get the errors like in the screenshots.

At that moment Homey is actually off-line. After a minute or two it’s back on-line.

I have the Pro 2019 with firmware 7.3.0., running 24 apps.

Anyone know what is causing this?

Thanks in advance!






I have short offline times when Homey consumes too much memory. Then Homey is getting really slow and it seems he’s offline. But I’m sure he’s only too busy to answer.

Please check the memory consumption in the settinge. If the memory is full, restart Homey and keep an eye on the memory if the offline situation appears again.

Another cause could be the router.
I had problems in the past with Asus Lyra mesh. Homey tried to connect to another AP and got lost because it was too far away.

Where can I find memory consumption? If I select any of the Tools selections, I get the off-line error.
After waiting a while I try again it immediately the error pops up again.

In the Mobile App under settings - but only if you can con ect to Homey.
If that’s not possible, you could restart (PTP) and check the insights. There is a chart for the system momory usage.

I added it all up and it comes to 524 mb. It has a gig on memory. So you think a wifi problem? It is 4m from a Netgear Orbi 53 router.

Maybe this is of any help

That’s the Netgear mesh, right? I had some Asus Lyra as mesh router. Well, it was a first step to a mesh, but not very stable. I switched to Unifi and it’s much more stable.

WiFi could be one problem. Some ideas…
From my experiences with Asus Lyra:

  • Check if Homey is jumoing between the APs. Check in the routers client list if Homey is connected to an access point far away when he is not reachable.
  • The Lyras sometimes disconnected from the main Lyra router. (I used a Wifi mesh) This way clients connected to it were connected to its WiFi, but without internet or LAN access.

General things to check:

  • use a fixed WiFi channel (1, 6 or 11).
  • deactivate step by step some Wifi optimizations like band steering, fast roaming or similar things.
  • check if you can assign Homey to a fixed access point, so Netgear doesn’t use roaming for it.

So far some ideas. Good luck with your tests. It’s all about try&error.

1 Like

I started with the simpelest step first. I replaced the power adapter with 2,4A one. That solved the off-line thing.
Now I only keep getting the ‘Object’ error. Everything functions normal, as far as can see.
Any thoughts?
Object 2022-05-16 102449

Where exactly in Developer view?

It happens with any of the items under ‘Tools’.
Oh, and the off-line error is back again. Half a minute later or so, it’s back on-line.
The one below is comming up again too but I cannot find anything not working.

And when I try Discover under BleuTooth I get the error below.


A longshot, but a factory reset and a “full software download” might help.
Start Homey in recovery mode and follow directions.

If Homey is offline, every command in developer view will result in an error. Reloading rhis page will bring the offline message.

So you don’t need to check this. Just check with the mobile app if Homey is online.

Have you already checked tbe wifi settings?
And like Peter saud, if you have not added devices, a factory reset would be a chance, too.

I will check the wifi settings, though I have not changed anything recently.
I didn’t add any devices recently so I will do the factory reset I think. I have the daily back-up thing from Athom. Does that mean I will not have to add all devices and flows? Will they all be installed again automatically?

I made a little mistake, you don’t have to do a factory reset prior to a full software download.
That shouldn’t affect anything of your devices, flows etc.

If that doesn’t help, you need to restore a backup when you’re going to perform a factory reset.
Almost everything is getting restored, apart from community store apps, apps you installed via CLI, and probably apps which aren’t available in the app store any longer.

Athom told me that this is a bug with Homey connected to Netgear Orbi routers. They are looking into this.
Thanks for the advise everyone!

This problem seems to remain unaddressed. I have tried most of the very reasonable suggestions above (permanent ip, separated 2.4/5ghz and alternative power adapter). The latter especially fixed a lot of stability issues so thanks for stressing this across posts in the forums, but it did not fix the issue discussed in this thread. This bug particularly seems to appear when I enter the z-wave network under developer tools and switch over to zigbee and quickly interchange between the two. May it be related to how homey deals (or not deals) with sleeping battery-based z-wave units? My zigbee net is large, but stable, and the z-wave one is rather small and consists of mainly router units (Fibaro plugs), but also three Fibaro battery-based sensors which regularly ‘sleep’. Hope Athom could prioritize this as it will also carry over to the new homey if left unattended. I do not have a Netgear router, but a Linksys 1900 ACS.

The same problem here still…so Athom have not resolved it yet, after nearly a year. :roll_eyes:

I wonder if it can be OS related? I’m using an old MacBook Pro running on High Sierra and Firefox. Safari 13 is now unsupported by the forum so it looks really old school. :smile:

What are you guys using?

Maybe it’s time for me to buy a new laptop… :thinking:

I have an HP laptop with Windows 10 connected to the Orbi RBK753

1 Like

I use two Asus routers in a mesh configuration.

To me this is a Athom issue…not a user hardware issue.