Homey Insights - No Data Available

Hi All,

I have a few devices visable in the Homey Insights page, however all of them show “No data available”
Should Homey collect the values out of the box or do i have to take any action to collect the values?



1 Like


Same here. I reported the problem over a month ago, but still no solution. Please report the issue at https://support.athom.com, I hope that when more people report this problem they will give it a higher priority.

Tia, cheers,

1 Like


You can use this app to export all insights data to see if there is data at all, or that the problem is in rendering a graphic from the data.

1 Like


Thank you both for your answer.

I installed the app and saw that there was no data from the sensor.
There were some on / off data from other sensors.

I have registered the problem with Athom Support


1 Like

Just for the record: what devices (brand, type etc) are you talking about? Some devices do not report anything (f.i. simple on/of switches) and others may have a setting that prevents reporting something at all.
Afaik, there is a difference between reporting something pro-active and pulling the current value via a device card.

Hi Peter,

Multiple devices:
Philips Motion Detector: Battery Level, Lux and temp
Philips Hue Switch: Battery level
Fibaro Smoke detector V2: Battery level and temp
Also some weather information (is this Homey default?)

This devices and sensors that i mention above are visable on the insights page and all show “No data available”. Should this work “out of the box” ? (this was my assumption)



Alas you didn’t snip the whole page, it would be good to see what is mentioned in the right side pane. On opening the insight page it should show “select a log from the sidebar to get started”.

Also, in your pic there is not value selected. What happens if you click on the device name (toggle ALL available values on) or on one of the values alone? That should show a graph on the right side.

Hi @PetervdK

Thanks for your response.

Please find below snip, in this example i selected 3, all other (not selected) show the same result “No data available”


Hmm, that is indeed weird. Worth reporting to Athom because this isn’t normal.

The solution Athom suggested was to do a factory reset. Which is no problem of course, since there are many great tools to just backup and restore all your devices, flows and variables :unamused:
And worst of all, it didn’t solve the problem :triumph:

Now my device is sitting there idle again; I can add everything again, but who know if another factory reset is necessary…

My Insights problem is solved.

It was my own network setup that caused the problems.
NOTE: I’m verry sure i checked the following explanation on beforehand, i always check this if there are problems.

One day the clock was far behind.
I checked my firewall log to verify NTP was working/passing trough.
However i noticed Homey was doing DNS queries to the Google DNS servers ( /
By default i do not allow DNS to the public internet and force DNS queries to PiHole (getting the PiHole DNS adress by DHCP) Looking at PiHole i noticed also DNS queries from Homey. (All other internet related stuff was working) So it seems like not all DNS is passing via de DNS server(s) it gets from DHCP but also fixed config(s) to the Google DNS.

I opened up the DNS in the firewall.
NTP started working and also the Insights.

I know this case might be a special one, but might be useful for others.

That’s strange, given that Athom always states that they want Homey to be a very secure and privacy-minded platform.

Thanks Jeroen!

My FW denies all acces to all device to the two Google ‘DNS’ servers. I guess this was the reason their advice to do a factory reset didn’t work out for me.

Wierd thing; at first I disabled the deny rule for and, not nothing changed. So I did a PTP reset, still no dice. Only until I did another factory reset it began working.

Did some more testing, and disallowed connections to the DNS servers again, and everything is still working. Even after clearing als NAT translations, and ARP tables, and even after giving Homey another PTP reset.

So kudos to Jeroen, I would never have linked the Insights problem to Homey not being allowed to use Google’s DNS servers.

And indeed, weird Athom decides to not honor the DNS settings our DHCP servers pushes.

Have a nice day,


I also noticed that my Homey wants to talk with the Google DNS servers (noticed some denies on my IoT FW rule on the EdgeRouter). Is there any solution to fix this? I dont want to allow Google Public DNS to any of my devices. :slight_smile:

I guess Athom has configured the use of Google DNS fixed in the firmware as some fallback as we have seen many issues with incorrect configured DNS servers and /or incorrect NTP settings on customer side resulting in questions from noobs.

There are no options in Homey to configure network settings so if you configured your DHCP settings correct and it still uses Google DNS you could try to ask Athom support for a statement on this.
Pls let us know their answer!

1 Like

I’m same. No data from Homey Insight.
I see DNS request on my pi hole with no blocking.
Any ideas ?

Hi Freeman,

Do you run any firewall on your network? If so, check for any drops/blocks that are sourced from your Homey IP.
Homey is using the Google DNS servers ( and also the DNS servers provided by DHCP. (in my case redirected via Pi Hole)


I have a firewall but without filtering. I set DNS server (PiHole) over DHCP.
Where are store data of Insight ? on Homey Box or to cloud ? Does insights need to talk directly to Homey ( upnp, open port ?)

I have a homey pro version 3.1 and haven’t had insights for a while. Now i had the time to start searching for answers and found this thread. I opened up everything from my homey to internet and my firewall doesn’t block anything now to it. But can’t get any insights… Did even try to add a new devices aeotec multisensor 6 and that doesn’t get any insights either. I really don’t want to do a factory reset. About 50 flows and many devices… Any ideas?

EDIT: Scratch that. the firewall was blocking udp so now it is working…

1 Like

Maybe I’m on the wrong thread here, but my devices have no perceived problems regarding insights. But my variables are all blocked out. “There’s no data yet” is the message I get. Any ideas regarding this?