Homey flows via Google Assistant not working

As Homey will deactivate the speech function, I already started testing the starting of flows via Google Assistant. This works fine for my (main) account. The flow is set as favorite in Homey, I made a reference in routines in Google, works!

But… My wife also has her account on the Homey, and her own account on Google Assistant/Home.
When she says “Hey Google, {name of the flow}”, Google says it can’t connect to Homey. The flow is in her favorites, and a routine is correctly made in her Google Home. When she asks Google to turn on a light connected to Homey (so without triggering a flow), it turns on. And even more strange: When she says “Hey Google, ask Homey {name of the flow}”, it also starts. I’ve also tried to let her say “Synchronise all devices” to Google Home. For me that works fine. For her, Google Home says only the one that made the connections is able to sync (indeed, I’ve set up all connections). Does anyone have any idea or suggestion? Thanks already!

See also here:

It simply isn’t possible in the current configuration.

The only workaround is to have your wife disconnect her google account from the Smart Speaker such that the smart speaker doesn’t recognize her voice and it automatically uses your routines

OK, so I don’t have to search any further for any misconfiguration. Thanks a lot for your reply!

Have you tried to reconnect homey with Google assistant in the add devices section in the home app? This sometimes works for me since the auto sync isn’t always reliable.
The steps I have to follow before my wife can start a flow via assistant is:

  1. Create the flow
  2. Mark as favorite
  3. Reconnect homey with assistant
  4. Put the flow in a room (I made a virtual “flows” room in assistant
  5. Create routine in google account of my wife
  6. Sometimes again reconnecting homey with assistant

No, this isn’t the problem in this case. The flows are visible for the main account, but as soon as Google recognises the voice of another family member, it switches accounts and has no access to routines and flows, just the devices (those you can share between family members)

I have another problem, but it seems related. Maybe you can help!

After integrating Homey in Google Home me and my wife can both see the devices that are connected to Homey. We can also start our favorite flows, although that the synchronisation doesn’t always work, but the older flows are already synced. So they work, the newer flows have to be synchronised. May reconnecting Homey to Google Home as @Jeroen_Zillig suggested works.

So flow seems to work: but I can’t get the devices working. Google Assistent keeps telling me it can’t reach Homey. And in Google Home I can push the icons, but nothing happens. What is going wrong? Any ideas?

Since we don’t have a google smart speaker (yet), we use the assistant on our phones.

Is sync to Google in the Homey settings enabled?
And does this problem exist with every device connected through Homey like tv/receiver but also with light bulbs etc.?

using a speaker or only the assistant app on the phone doesn’t really matter in the execution. Since the commands placed on assistant are send to the cloud, from the google cloud to the cloud id of Homey.

Thanks for your reply!
The sync to google option is enabled and the assistant is able to sync the devices. So far so good.

This evening I tested all my devices via Google Home. Most devices are lightbulbs and dont work. The devices are a mix of Fibaro Dimmers or Klik Aan Klik Uit. I also have a few smart plugs: one for the freezer and one for a light bulb.

Google Home shows all the devices, but doesn’t get the status of most light bulbs right. The strange thing is that one light bulb (fibaro dimmer) and two smart plugs work. All other devices don’t. Any ideas how to fix this?

Sorry for the late reaction.
Going to check if I can replicate the problem here tomorrow.

Did some testing in my home with various devices from Kaku and fibaro.
Noticed that the state of Kaku devices is often not correct in Google home. That is because Kaku only works one way (no state feedback) so if a device is switched off with a wall switch, the state showed in homey and home is not up to date.
In order to switch the device in home from an outdated state it requires 2 switch commands; one to update the state and another to actually switch the device on or off.
Fibaro is a different ball game, they use z-wave and actually do send a state report back to homey.
However, for z-wave devices it is important to have set the correct associations so that it sends the state report to the correct controller.
Could you check that you set association in group 1 to “1”?

No further problems here in my set up with devices that are not switchable at all. Only the problems as I mention in this post.

Found a workaround for the flows that are not responding. Not a solution however…
If you add a virtual device in homey that starts the flow, your wife can switch the virtual device to start the flow.

Best is to set it to start the flow on switch ON and to start the flow on swich OFF. Otherwise your wife has the set the switch back to off everytime.

Still can’t figure out why Google assistant can’t start the flows from a family members account.
Have the same set up here with a homey account for my wife and she can start flows from her Google account without problems.

What kind of account does your wife have in homey? user or admin?

Perhaps the following discussion can show some more light on the problems discussed here.
Homey end of speech and Google integration

Thanks for the testing!

I can imagine that the status of the KAKU devices is not shown correctly. After all it is one way traffic! My problem is, that the status of the devices (KAKU or Z-wave) shows correctly in Homey, but not in Google Home. So it somehow doesn’t sync properly.

I also checked the group associations, but they are all correct. So that doesn’t seem to be the problem. And as I mentioned, the status of the devices shows correctly in Homey.

The Google Home/assistant reports back (in most cases) that Homey is unreachable or offline. When I use speech to switch a light it even says: 'Light switched on/off" followed directly by: “Can’t reach Homey”. The light did actually switched on/off, so that one works, but the feedback from Google Home/Assistant is ‘strange’.

So I decided to (again) reconnect Homey to Google Home. After removing my Homey-account the devices in Home weren’t removed. This was because my partner also had her Homey-account linked to Google Home. Next step was also to remove her account. Then all devices were removed.

After reconnecting my account, the Google Home-Homey connection finally came to live and I can control all devices! I also reconnected the Homey-account of my partner to ‘her Google Home/Assistant’, and it still works.

So 1 Homey is now linked with 2 accounts to 1 Google Home and ‘2 Google Assistants’. I don’t really know the advantage of the 2 accounts yet. Anybody found out yet?
She can’t sync the devices to Google Home (that’s only for the account that added Homey, so that’s me). And it also doesn’t seem to be in personal favorite flows or something like that.

On second tought: last step I wanted to see what happened if I would disconnect the Homey-account of my partner, but her Google Home app doesn’t show Homey as a connected service. So maybe her account isn’t connected in the first place, because that Homey was already connected to Google Home? Anyone has experience with this?

But I can control my lights and flows again (with my voice) via Google Home, so that seems to be worked out (for now). Thanks for all the help!

1 Like

Strange situation but glad it finally works.
Sounds to me like Homey was never connected correctly to Google assistant in the first place. The reason for that is something we can only guess at but I would go for a Google issue.

Homey isn’t shown as a connected device for the same reason that only the account that initially connected a service is able to sync devices.
Also don’t try to add homey as a device to the second account, I once did that with Kaku, but it gave nothing but problems.

We have 2 Google accounts connected to assistant and 2 accounts in Homey. This works really well in my case, both of us can can send personal commands to homey that execute (by speech recognition and the routines set to that account) the correct personal flow.
Don’t know why it works here because in most cases the flows are not correctly executed.

I would say, if it doesnt work, let it be and use one account, set flows to virtual switches and follow that route.
If it does work, don’t try to figure out why it works, you might break it :wink:

Again, I’m glad it now works, nothing is more annoying (and bad for the WAF) than a partially working home automation system

I’ve tried to program a workaround using virtual devices today. And successfully…
I created a flow (name the flow as you want - not that important) with a virtual device in the IF field. The name of the virtual device is named with the sentence I want to use in Google Home (for example “the surveillance”).
So, WHEN the virtual device “the surveillance” is pushed or has changed AND this virtual device is ON, THEN start flow one, ELSE start flow two.
So when I say “turn the surveillance on”, flow 1 is activated. When I say “turn the surveillance off”, flow 2 is activated.
Runs perfectly from Google Home, for everyone in my household.

1 Like