Homey don't find zigbee units after last updated to version 10.0.6(09.02.2024)

Well, sorry to say, but it did not work! After a weekend with several Homey & App restarts, I am back at square one. Most of my Zigbee units does not respond, but I have noticed, that some devices, where I only read values, like my Frient smart cables & Frient Meter reader, and some Sonoff thermometers, work!
I cannot control any plugs, relays or bulbs. I could do a Zigbee reset, but would really like to avoid that.
In the developer tools I can see one zigbee device with a question mark instead of a number, and maybe this is the one causing all the troubles?

1 Like

I just got the exact same answer from support :frowning:
I guees that I will be busy the next couple of days…
Not extremely happy!

I have now restarted the Zigbee network and added all devices to the new ones. (42 units)

It seems promising so far.

So when you first HAVE to do this it is a good opportunity to clean up the Zigbee network a bit.

Some hints.

  • Is recommended too started by adding routing units (230v) The first 15 places should be routing units if possible. Something I did wrong when I first added Zigbee devices to Homey.

  • It is important to plan which units and the order in which you enter them. Then it is quite quick to connect it to Homey

  • I also use the Ikea-Hub to relieve the Zigbee-network in Homey and on that occasion I have moved several smart bulbs over to the Ikea hub

Anyone else have any hints?

I did the Zigbee reset, and re-enabled all Zigbee devices aftewards, and it looked very nice.
But it only laste about one day! Then devices stared to become unreachable.
It was not my wifi that had a problem. Wifi is running on channel 2, and Zigbee was moved to channel 21 as part of the reset.
I then did an update with experimental software 10.0.7-rc.2 and it maybe helped, or maybe it was the reboot after updating, I do not know.
I have noticed that software 10.0.6 should solve a problem with Aquara devices, but I have not been able to enable a water sensor, nor my contact, both from Aquara, and I have a feeling that the zigbee network became unstable after trying to enable the devices, so I had to do another reboot!
In the release notes for software 10.0.7-rc.2, it is actually stated that it should solve some Zigbee related issues, so I am crossing my fingers.


Same issue.

I moved to 10.0.7 rc2 and it seemed slightly better. Then it just lost connection to all Zigbee devices again while via developer tools I could still query.

Also, went through it all: full software, unplugged all devices and repowered in an orderly fashion, all of it. Changing wifi channels. Tried changing zigbee channel - but is yet another thing just not working in dev tools, timeout in 5000ms

I have once done a zigbee network reset long ago, but will not do it again. I have no hard switches in my house and this will be hell. Besides, there is no logic to it.

After a reboot, with 10.0.7 rc2 it will work for hours. So I have set up an auto reboot every night (Which is ridiculous to begin with, but alas). If there is an actual problem in the zigbee network ITSELF, it makes no sense for it to work for a while. Also, it working fine before 10.0.6 for everyone, is a clue something broke.

So, it is the weak implementation by Athom that is to blame. It would be great if finally they can do some serious testing and improvement. It is NOT NORMAL to advertise a product as easy home automation in a box and deliver hobby project quality at best.

There has not been a week in the past 18 months that I have been able to enjoy without tinkering with the thing. I would have gone HA for a fraction of the price if I wanted that.

Not to mention the series of broken promises, dropped roadmaps and half-assed app management where unmaintained ‘approved’ but no longer functioning apps stay while new working apps are not brought in ‘because there already is an approved app’.

Homey hasn’t even gotten the basics right, after all these years. They could have conquered the world of home automation but simply failed to bring sufficient professionalism to move beyond hobby quality - still at premium price.

It’s really frustrating when things don’t work as expected but is it really only homey in your case and some others (maybe you have a defective unit). I’ve been running all the homeys since the kickstarter model and never had such a resilient and stable zigbee network as with hp23 especially since the latest few updates and i have a few different brands mixed with over 100 devices. Did you contact athom and tried to get to the problem with them already?

As said before, this topic is about HP201x.

Also, this problem being reported in so many topics right after 10.6.x rollout should sound all alarm bells at Athom - but they prefer to just have everyone jump through the same hoops as if suddenly everyone has a random issue only with their unit.

1 Like

Aah missed that, it’s not in the topic name and i was not aware that the firmware versions of the “old” and new homey were different. But still did you contacted athom yourself? It could be a specific situation where your problems are coming from.

A note about this annoying time-out:
The page times out, the running process doesn’t.
Your channel should have changed in the meantime.

About your remarks about quality levels: this is just a user forum. No one can do something about your complaints
And it’s very annoying. We all know Homey is not perfect, but the reliability is very dependent from (all) the radio signals, used devices AND the PEBKAC.

Send your frustrations to Athom please: Support | Homey
Thank you.

The page times out - AND the channel never changes. That’s right.

Indeed it is a user forum. Athom is more than aware of my opinion of them - but it would be good if more people considering their products are getting honest perspectives.

Had I read my own experiences before purchase, I would have gone HA.

I’ll repeat. Topics start spawning left and right after release of 10.0.6.x. Don’t pretend - like Athom seems to do - that coincidentally at the same time everyone with some more zigbee focused home has issues not related to that Homey update.

I don’t care. I think it’s useless, again, to write such statements here.

After owning Homey for some time, I started with HA out of curiosity, and it’s same shit different platform.
I love the teaming of both systems though!
The perfect system does not exist yet.

I don’t care you don’t care. You don’t decide my opinion nor how I write about the zigbee issues and how I see them caused.

Cry harder.

1 Like


There are thousands of people using homey and just a few complaints here on the forum so obviously not everyone has this issue, just contact athom! (it’s just a community forum and we try our best to solve “basic” rtfm issues). I also run HA and i think its a greater nightmare to run than homey because i have to run my nas for the zigbee stick that got ff up by a synology update, HA had an update with breaking changes that ff up my dashboard and a lot of other minor annoying breaks, and i can continue a lot like this. Homey is not perfect but surprisingly (not) other platforms have the same issues, the great thing with homey is that it’s all in one box and i don’t need a few different usb sticks and devices running and update separately to do the same. Yeah support should maybe kick it up a notch with being some more proactive after a complaint, but when i needed them (and spammed them some with the complaint/issue) they always followed true and resolved it in the end.

Many weeks go by where I don’t need to tinker with my Home Assistant installation, it just runs. And my Zigbee network is rock solid.

1 Like

Don’t rub it in :sweat_smile:

Since I bought homey 18 months ago, I saw HA make huge improvements all around. If it comes to it that I can’t keep using homey without complete zigbee reset, I’m gonna look into those new premade HA boxes.


For information from my side. I have completed a full reset of the Zigbee network on Homey and added all devices again. In addition I made sure that I have “cleanup” and routing units entered first (first 15 places). This solved problem with Zigbee network. Has worked great since I did this. 1 week since this was done. Looks good


As I have an unusable situation anyway, next to ordering a HA box I decided to just start anew to test the Homey.

  • Full software restore of 10.0.7 rc2
  • Moved Wifi channels as far away as possible
  • reset Homey zigbee, new channel as far away as possible from wifi
  • added routers across the house slowly (~ 15)
  • added end devices in the place of use

Within 2 days: it all falls apart again.

And to remind some of you: this same setup worked a few homey versions ago. Not the most stable and fast situation, but it worked.

So narrowing everything down, this is just a failed update from Athom. And before it goes into ‘it’s just you’ again, look at the increase in zigbee network problem topics here. And that’s while many heavy users already went to a separate zigbee network and many not having more than a few zigbee devices.

1 Like

My zigbee chip died slowly after a update couple of weeks ago. Homey have access to it and said it’s dead. No warranty after one year. Sadly :confused:

MAny zigbee problems here as well, dont know exactly wich software as homey updated few times last days and i was not at home all the time.

Ff nuisance :rage:

1 Like