Unable to add ZigBee devices after power failure

Hi there,

I have trouble with the Zigbee. I had a bunch of devices, Hue, Dimmers etc which has been working fine for 2-3 yrs. The other day one phase went out in our home, and almost on the same day there was a firmware update to 10.0.4 on the homey ( I have Homey Pro early 2018-19. Homey went nuts. All Zigbee devices stopped responding. Well, I tried to restart Homey - did not work. I had a hell to reinstall full firmware, was not wasy to make Homey connect with my Wifi suddenly. After 2 days of trying, I succeded to install full firmware update. And I also disabled experimental updates. Then it updated to Firmware 10.0.3, I restarted, but still cannot add any ZigBee devices. I also made a full reset of the Zigbee network - no success. Here is the Zigbee network from Dev Tools:

Does anyone has any idea or suggestion what to do next? After reset, the Zigbee changed the channel to 14, before it was 11. But still no possibility to add any devices. My power supply is also replaced so there should not be any electrical issues. Or, is there a chance that something broke down in the Homey Zigbee component even though all other stuff is working fine. Just not Zigbee.


Well, after this update, my zigbee issues got wors… I basically cannot pair devices for last 6 months, Athom is of no help (if they actually decide to communicate). And after this update, zigbee is like slowed down - what took 0.5s takes 1-15s or does not respond at all (e.g. lights to dimmer switches). Kind of feeling like planned obsolence for 2019 homey…

Only if the same would happen for all other 2019 Homey users, which it doesn’t. I assume you’ve already done all the known fixes for Zigbee issues on the older Homey’s?

As I said, trying to resolve this with support for 6 months. Done everything there is, except for hard reset, as no one can guarantee me I’ll be able to add devices again and honestly, without homey I can’t even turn on some lights…
Honestly thinking, Athom is forgetting how an important device they are selling… and support seriously lacks, as sometimes it’s litereally months waiting for response.
Funny is the last time, I got to the point that I’d have to buy a new one and asked if they could give me some discount due to this “support”, yes, it’s possible… if I send them old out of warranty devices first to investigate. So being without lights for at least 2-3 weeks… :smiley: really, such important device should have another level of support. Currently looking for some alternative, but seems the market of devices that would support zigbee, RTS and was that user friendly (advanced workflows, etc) is almost non-existent :confused:

The idea of a “Does Everything” device sounds appealing to a lot of people, until one part (or more) of that “Everything” starts to fail. At that point, you have an expensive device that requires workarounds which cost even more money (and there are quite a lot of users out there that are using workarounds for bad IR, bad RF, bad Zigbee).

The alternative is to build your home automation around specialised projects, like zigbee2mqtt for Zigbee. This does one thing: Zigbee. And it does so (very) well.

Going very much offtopic here, but I’ve also fallen into the “Does Everything” trap with my home server, which is running Unraid. It’s an OS that basically allows you to build an extensible NAS server with support for containers, virtual machines, mixing harddisks and SSD’s, and all made very easy. Until I ran into an issue that causes it to hang. And apparently, nobody is able to fix the cause of the hangs (it’s not a hardware issue, it’s an issue with the “special sauce” that Unraid uses that makes it able to do what it does) and I’m stuck with a “Does Everything” OS that’s unstable. So I’m planning on migrating my server to a “simple” OS that I know is rock solid. It might not have all the bells and whistles, but I don’t really need them anyway.

Take from that story what you like :wink:

I get you… and yeah, this approach came to my mind as well, to go with HomeAssistant, build something on raspi… But honestly, “got no time for that”.
If I’m selling “does eveyrthing” (and not cheap), it should work. And if it does not work, I should have support in place who will deal with this swiftly. None of that is the case right now with Homey…
I have half-functioning device, and support takes week+ to respond (and I know, it’s Christmas, but it’s like that for ~6 months I’m dealing with that one ticket).

I also don’t got time to migrate my server, but OTOH, I also don’t have time to have to deal with an unstable one that crashes every couple of days. So now I bit the bullet and planned a migration that might take me a couple of days around Christmas, but the end result will hopefully be a stable server that just does it job without requiring any time.

I don’t expect this to change any time soon.

Zigbee issue resolved. 1) Did a full reset of all my Zigbee-devices to factory defaults. 2) Full reset of Zigbee-network - 3) restarted Homey (normal restart) Zigbee channel changed to 21, and VOILA! Now it works like a charm. Channel can be changed if you reset the Zigbee-network, or it will be “choosen” when you start adding devices.

Only issue left is that I can not re-add my crappy Phlips Hue. I have both BT ones and the older ones, also have the Phlips remote but not the bridge, but you should be able to reset the bulbs with the remote (doesn’t work of course), but after reset the Zigbee-network none of them are able to be added anymore. Don’t know why…all others Ikea, Schneider and some plugs, works fine. But not Philips, I have never been really happy with them. They are crap and expensive.

Quick question - guess you had to readd all your zigbee devices and fix all your flows, right?
Or does backup restore that?


Anyways, have another update… done PTP on my whole household… basically turned off the main switch for 10 minutes so it restarted zigbee devices. Seems it worked… at least device control works, still can’t pair anything…
In following days, will probably dig into home assistant, as shelling out €400 for another homey, which is so closed I cannot do anything and support is of no help and you don’t know how long the company will exist… well, nope.