Homey don't find zigbee units after last updated to version 10.0.6(09.02.2024)

I just replied to an email I received about 1 hour ago. Where they needed access. Looks like the same thing
“Development colleague would like to run some scripts on your Homey Pro to re-flash the Zigbee chip”
Then something happens, which is very good

1 Like

I have the same problems especially after the latest update, but the problem has been there since I got the H23. Support (that already has access to my Homey) claimed it was the power supply. I had already changed that a couple of months back, and did it again now. The problem got worse. I believe Homey has som serious issues with Zigbee units.

Hi Erik,

This topic is about firmware update v10.0.6 - zigbee issues of the Pro 201x

1 Like

Hi Espen. Has there been a solution for you?

No, not yet :frowning:

tir. 13. feb. 2024 kl. 20:48 skrev Håkon Hansen via Homey Community Forum <notifications@athom.discoursemail.com>:

Having the same zigbee problem. However not with the Aqara devices, but my Phillips Hue lights and Ikea Vindstyrka.

This seems to be a common problem… Homey team wasn’t able to help me solving it, I’ve moved all my Zigbee devices to Home Assistant.

Sorry to say this, because I know Homey is a lot more user friendly than HA, but I feel we’re being forced to update to a new Homey Pro HW Version… sorry but not at that price and not because what worked before doesn’t work anymore after some SW updates.

I got the same issue on my HP 2019 Pro. I updated to 10.0.6, and a couple of hours later my Ikea, Nous & Sonoff zigbe devices stopped working.
I have tried to restart homey, restored a backup with 10.0.5 Sw, but it does nok help. It looks like I have some luck after re-installing the Ikea app, but no change om Nous and Sonoff.
This is very similar to what happend after 10.0.5 upgrade. At that time I had to clear everything and start all over again.
I have used this Homey since 2020, and it has always worked, but now I feel al little betrayed !

It’s not possible to revert back to a previous firmware with cloud backups, you always get the latest stable version.

You are right! I was able to choos 10.0.5 when I restored, but I can see that I am running on 10.0.6…

Did you get a response from Support?

Looks like it’s working with this, several people have been contacted where they ask for access to Homey, and looks like the Zigbee has been updated. Looks like that fixes this up against every single one for now. Hopefully there will be an overall fix

Have not tried support yet, hoped I could solve this on my own, but cant, so I will contact support soon

Contacted support, got a reply in less than an hour!
Told me to do a “Download full software update”.
And, everything works :slight_smile: But I have asked the ticket to be open for 24 hours, as the errors often come after some hours.

1 Like

This is the answer to the solution Look below (What exactly does a backup to Homey???)
What’s the reason we can’t use backup, thought this was one of the reasons for backup.

Answer from Athom support
The last couple of days our development team has looked in to the issue you’re currently experiencing with Zigbee on your Homey Pro.

In most cases the issue can still be resolved by a full software download on your Homey. After the download, the Zigbee chip starts correctly again and all devices can be reached. This procedure normally works fine when Zigbee could not start correctly after a restart of Homey Pro, and in most cases it still fixes this issue.

For a small group users we cannot fix the issue and keep the current Zigbee network. A full reset of the Zigbee network is needed, and all devices need to be paired again. We know this can be quite some work, but unfortunately there’s no fix available. Restoring a backup afterwards is not possible, unfortunately.

Cloud backups contain which apps are installed, any data belonging to those apps, and other assorted data (like Insights).

When restoring a backup, Homey will basically reinstall all apps to their latest (stable) version and it will restore the data. It will not restore the apps or the Homey firmware to the version that was installed at the time the backup was made.

Does it differ from what is written here? Or am I misunderstanding?

Backup contents
All your devices, Flows, Insights, variables, alarms, settings, Z-Wave and Zigbee network, etc., are being backed up. Only apps that have been installed from the developer tools will not be backed up.

That last line is simply a lie. It’s not just apps that have been installed from the developer tools that will not be backed up, the actual apps themselves aren’t backed up either, only a reference to which apps were installed. Cloud backups also don’t contain the Homey firmware.

Which, like I said, means that restoring a backup will not restore apps to the version from the time the backup was made, nor the firmware. So you cannot make a backup, install a new stable firmware, decide that the firmware isn’t working, and restore a backup to go back to the previous firmware.


Thanks for the answers

I’ll try it out: ““A full reset of the Zigbee network is needed, and all devices need to be paired again””"

Have never done this before. Where do I do this is it, is it under the Zigbee network in developer? Will all devices disappear or do I have to delete them one by one first and then add them back in?

First please try this, like Support proposed;
it is sufficient most of the time:

Please note a Zigbee reset is a last resort fix attempt.
To answer your questions about that:

It is - looking there right away was quicker than posting a question here :crazy_face::wink:
It’s also @ mobile app, …More > Settings > Zigbee

Yes, all devices dissapear right away;
Then, you have to pair all of them again.

All flows involved will break, but there’s a great script to repair them → https://community.homey.app/t/how-to-pro-cloud-tool-to-fix-advanced-flows-after-removing-and-re-adding-devices/65018

  1. rename all of your zigbee devices by adding a 1 or such, like, my device1
  2. write down, or copy paste all zigbee device names
  3. Perform zigbee reset
  4. Pair all devices again, and name them like the ‘old’ devices again
  5. Now use the script to replace the old device name (like my device1) with the new device name (my device)
    Your flows should be fixed now.
1 Like