Homey app not working

After two years of operating a Homey without big problems, I encountered very strang behaviour. At the moment I am simply wondering whether anyone has seen this before.

  • The Homey app became very slow. I have to wait several seconds before I can see all my devices. Even more annoying: I changed a flow, openen it again and nothing had changed. I repeated it several times without effect. After a restart of the Homey, the flow was changed. Another example: I tried to add a Z-wave device three times in vain (meaning nothing happened within 1 minute). After a restart I had 3 devices with the same name.
  • Start situation: light is on, app shows on. Switch off in app: light is off, Homey shows off and immediately on again. End situation: whatever I do in the app, light stays off, Homey shows on. The symbol in the app only briefly changes to off an then back to on. Repeatable for both Z-wave and KaKU devices.
  • Flows still seem to work. At least some of them.

Possible causes?

  • Installed Plugwise Smile (latest version) and app the day before
  • problems with three times adding the same Z-wave device (Fibaro wall plug)


  • Homey 4.2.0
  • App (Android, 2 devices with same behaviour)

Remedies tried:

  • restart apps
  • restart Homey
  • pull the plug and waited for over an hour
  • remove Plugwise app (which was the latest addition)

Not tried yet: complete reset of Homey to factory settings. I do have the paid backup, but this is probably still a lot of work.

1 Like

How long since you’ve had these issues? If they started happening somewhere in the last 12 hours or so, they may have to do with backend issues at Athom’s cloud servers that are still ongoing.


I have the same issue with device go on of or are slow

Thanks, Robert. I missed that information.
But where can I find information about those cloud servers issues?

The official status website is https://status.homey.app/, but that’s showing that everything is running as normal, which it clearly isn’t. That site has to be updated manually by Athom, and they’re not awake yet.


I see. But strange that this site, Homey support nor a Google search returns any information about problems at Athom.

Why would it be strange? Clearly there are problems (and you’re not the only one having them), it’s just that Athom hasn’t responded to them yet.

If Homey Status - High error rates on Homey Connect is correct, the issue should be resolved. At a first glance, my app seems to funtion again without any restart or ptp.
Still wondering how you knew there was a problem at Athom, Robert.

If he tells u he have to kill u. :joy:

1 Like

Because problem solving is one of my jobs, and that starts by being able to recognize problems. It’s a bit frightening that I recognize these kinds of issues hours before Athom does, though…

(and now…I have to kill you…:person_fencing::wink:)


Anyway, it helped to know the problem was not on my Homey’s side. Thanks.