Home Pro 2023 is ... not the perfect device I hoped it would be

This thing started to have the same problem that others are reporting. It goes offline often. First, it typically happened few days after restart. Now it’s only few hours after restart.
Do these guys test this thing?
It was a mistake to buy it. I still have my old Fibaro 2 and it is super stable. Haven’t finished migration to Homey Pro yet. And probably never will.

1 Like

I see. My message is not very positive and constructive, is it? It is not the first problem with Homey and I’m losing hope completely. I hope you could understand and forgive me …

1 Like

Well I am quite happy with my homey pro 2023. True there are few things that do need improvement but to call it crap?
Guess you use WiFi. Did you try with different settings? How about using LAN?
After ruling out any other reasons you might also contact Athom to ask for a replacement. It could be faulty hardware.


This a forum for users, Athom does not read posts very often. Do contact support.


This is normally one of two things, either an unstable Wi-Fi connection or an issue with the Power Supply unit, some early models had an issue but the latest PSU is fine. I suggest you log a ticket with Homey Pro support so they can help you as they do not monitor the forum. It is new and there is still deveopment ongoing to you may have it be patient but overall it is a fantastic product, expecially when you start using advanced flow.

I had some stability issues intially and after connecting direct to router with CAT 5 cable (leave both wired and wirelss enabled ) the unit became very stable. As a further enhancement, I have added small UPS to ensure the power to my network and Homey Pro was filterered and clean (they are not too expensive and added benefit will keep your system running for a while during a power cut).

This is mine from this morning, 22 days up since last restart and no issues!!



Mine is working for 35 days, so since last stable update I guess.
Here is the screenshot from developer tools (value in seconds):
But it’s not something uncommon. Having it for half year, it was always working stable. I’m using LAN.

Hi, I do not trust support, they ignored my last issue (they answered several times and then stopped and solved nothing and their answers took weeks). I just needed to share my frustration, sorry guys.

I have ethernet. I’ve tried to change the power adapter (although others report that it didn’t help for them) and uninstalled the last app I had there. Now it’s stable for 24 hours … so improvement. I have a theory that this behaviour might be related to using the unfortunate technology … node.js. This is a fragile thing, if one app crashes, the whole thing crashes. Will let you know later if these two steps helped.

1 Like

What’s wrong with it? What kind if WiFi do you have? is there anything related to your disconnects in the logs on your router/access point?



Each app is run in a separate container, so don’t affect each other. When I am developing an app it crashes a lot (I should be more careful :sweat_smile:), but it never stops Homey or other apps from working.


You don’t know what you’re talking about.


I have no issues at all with uptime on my 2023 pro. I would check where you placed the homey or as others have said log a support ticket in case you have a faulty device.

My homey pro did run for several months without stability issues. Then about few weeks ago, it started disconnecting from the network (as I said, I have an ethernet card, I do not use wifi). It was worse and worse. Recently, I installed an app for integration with Elgato Stream Deck. I tried changing the power adapter and uninstalled the app. Now it runs for the second day without a crash. So it seems one of these things is an issue. But I’ll see and will let you know.

Thanks for the explanation about the containers. I do think node.js is an unfortunate thing, but containers make sense. But … it was stable until I installed a new app. I uninstalled it and also changed the power adapter two days ago. Now it seems to be stable. After some time, when it runs ok, I’ll try to install this new app again and will see if it crashes / disconnects again or not.

Very happy with homey for years now, connecting to ethernet makes it alot faster to. Some apps could need some development but nothing bad on homey itself so far.

Are you using the original Homey 2023 Ethernet adapter? With the short (fixed) cable towards the power outlet and the long (exchangeable) cable toward the Homey 2023?


There seem to be big clues in most of your posts….

It worked… I did this and then it broke
Uninstalled and it worked again.

Please focus on such timelines as they are the best indicators of what went wrong. Your OT title is just insulting and unfounded.

Ouch - you sure know how to engage help !

Don’t just lash out at core software technologies, products or developers that are well regarded because you feel you have found issues… which you haven’t. These are generally solid, especially software, otherwise manufacturers wouldn’t use them.

Individual code (apps) from private contributors by its very nature is more variable in quality

Athom, despite much unfounded criticism mainly regarding response times now have a very capable team of developers. Yes, they are resource stretched but I firmly (now) believe are on a solid path forward


You are right, xAPPO. It is not the first issue I had with Homey Pro, I wrote to support some time ago, waited weeks for an answer, they promised to fix the problem which was clearly on their side, but they never did and stopped answering. Probably I shouldn’t write such posts, but I had big expectations, based on this Steve-Jobs-like presentation of Homey Pro (for which I waited almost half year after payment) and then … suboptimal functionality. Now I have a better mood and still believe it can be a good device. Just the excitement is away forever. As I said, I have Fibaro 2 which is still surprisingly better in some areas.

What UPS are you using?

I have been up over a month… no problems here. But Im also running on direct lan connection