Homey Community Forum

Google assistant:It looks like Homey is unavailable now

Annoying problem!
Sometimes Google assistant is telling me: “Homey is unavailable right now.” Homey is available, and the command is carried out without problems, but still Google tells me this. Does anyone have a fix? I’ve tried rebooting Homey and it seems to be random from all the Google devices so…

1 Like

In de homey app under google home is it enabled?

Edit, nevermind i was to fast with the reading.

I have the same problem since i connected Google Home with Homey. I hear this sentence a lot: ‘Homey is unavailable right now’ or ‘there was a problem with x lights’ although it was still able to turn them off.
Example to reproduce:
When 1 light is turned off in the living room by a flow and I speak to google ‘turn off all lights in the living room’ it will give me this error message.
I get this error so often (once a day or once in 2 days) that I’m already used to it, but it’s strange I don’t see other people in this forum with this problem. On the office we have a Homey too and it has exactly the same problem.

1 Like

Same here

1 Like

Here also the same problem

1 Like

yeah i get this too, other devices controlled by google work ok, so its the Homey part of the link thats the issue
i have two lights in a google room, and i say turn off lights, the non homey one (a crappy lenovo bulb) works every time, the ones via homey something work, sometimes take 10 seconds or so… or just dont.
if i use the homey app they work fine. so its not the homey to local device connection either.

2 Likes

Same, google can always turn anything on or off but keeps “complaining” :stuck_out_tongue:

1 Like

This is known to Athom, apparently homey doest not respond fast enough to Google. Regardless we all need to send this issue to athom over support@athom.com so they are aware this is wide spread. When I was in contact with them I didn’t get the feeling they will do anything about it. So we need to be boring and to overload the support mailbox. :joy::joy::joy::joy:

3 Likes

I also got this problem a lot.
It is gone when I solved this problem : How to disable Google Home suggestion to add a flow card to say something back

Note that I solved it by just adding a flowcard to say something with an emtpy txt string.
image

I have the same problem.

Now the voice control via Homey will stop, I was looking into the Google Assistant integration. But the only respons I get: ‘Homey is unavailable’.

Restarting Homey didn’t work, reconnecting the google assistant didn’t work…I’ve been trying to turn off my lamp all evening, but with no succes :frowning:
And Alex makes it look so easy in the video…

Still the same annoying problem.

I was able to fix my problems!

In the meantime Homey also updated to v5, so i don’t know if that’s part of the solution…

I disconnected my Homey-account from Google Home, I also disconnected/removed the Homey-account of my partner of her assistant/home. That removed all the devices off Homey in Google Home.

After reconnecting my account to Google Home/Assistant I was able to control the devices via Google Home.

dont forget you can ask google to re sync all devices as well, this has helped once

I also have this exact same problem for a long time. I hear the “Homey is unavailable” message a lot from the Google assistent. After the Homey update to 7.2 I gave it another try, but it still does not work in fact it’s got worse. I removed the Homey account from the Google Home app and disabled the sync in the Homey app. Then I restarted the Homey app and the Google app, and rebooted Homey too through the menu. Then I linked the Homey account in the Google Home app with success. Then I tried to re-enable synchronisation to Google in the Homey app, but now that app constantly tells me I have to link the Homey account from within the Google Home app first. But that had already been done. Even after hours it keeps telling me this.

I am a Homey owner since the first version and it seems that the more updates were done the less works. It will not take much longer before I will throw the Homey out and get something that works the way I want it to.

2 Likes

I have to reconnect via Google home at least once per week. Not sure if this is Google or Homeys fault.

Is there a solution for this meanwhile? And is Athom aware of this problem? I found myself with the same problem and it is pretty annoying. I get the message about 50% of the times. Sometimes the command isn’t executed at all, other times it is done correctly but the message remains.

1 Like

I find that if the first Hey Google results in “Homey not available” then making the same request again then it frequently works.

Not if you don’t report it.
mailto:support@homey.app

https://support.athom.com/hc/en-us/requests/new

1 Like

Yes Athom is aware. I’ve reported this since my last post in this thread and their answer in short was, it’s a problem in the nest mini. The problem, according to Athom, is that Google’s device demands a too tight response time from the devices. I replied to Athom that I think that is a bit easy to say because all my other devices in my smarthome environment are working seamlessly with the mini. It sounds a bit more to a design problem which can’t be fixed anymore due to the build of homey.

1 Like

Of course it is, it’s deplorable that Google doesn’t take into account the slowness of Homey /s