In changelog:

Added more devices - Thx “matrover” for providing the pulls.
GL-B-001Z, GL-B-008Z, GL-S-003Z, GL-S-007Z
There are still issues with controlling white, this is waiting for the zigbee rewrite by Athom in HomeyCore OS.”

Does this mean that GL-C-006 DC12-24V WW/CW can’t control warm and cold colors properly?


Hi kai,

It means that the colors all work but the shadeds of white dont work. The whole white leds arent turned on

Dear all,

will this ever be resolved?

i just ordered them for my complete home…

I dont want to have red lights on 24/7.

Nope, still waiting on the zigbee rewrite from athom. Which is under construction but no eta’s

Ugh, that is harsh…

i might need to replace all Gu10 LEDS in my house for something else for now then…

I’m following these update on latest firmware but no one seems to communicate

Hi! Could you please add support for Gledopto RGB+CCT zigbee controller model GL-MC-001?
It’s currently recognized only as basic Zigbee device with on/off only (green color dafault). Device details attached. Thanks in advance!


I try to add the WW/CW GL-C-006, but Homey just keeps adding it as a basic zigbee device, because it can’t find an app to pair it with. Thing is that I am installing it with the Gledopto app. Tried resetting my zigbee network, tried it as a different Gledopto device. Doesn’t seem to work. I don’t have a Hue bridge.

Someone any idee how to fix it? Now I only have the on/off option.


Same problem for me :frowning:

Okay I solved it by myself instead… First time I done something like this so I hope it will work for others to :sweat_smile:

You have to install it with CLI and you can download the app from here

To add WW/CW just chose “Gledopto WW+CW GL–C-006”

Unfortunately it’s still a problem to change the temperature and saturation. Guess it will be fixed when Athom update Zigbee

After a lot of time trying to fix problem with the temperature I finely got HUE bridge to add it instead. And it works perfect there so i recommend to use Gledopto with Hue instead.

when I restart homey, the gledopto will turn on. Is it possible to set it so that the last selected state (e.g. off) is retained in case of a restart?
Thanks and best regards

With this solution, is it possible to dim? You mention problems with temperature and saturation, but brightness can be controlled? I already have a plain white led-strip (just 1 color) and only need on/off and dimming. Would be nice if I could use the WW/CW GL-C-006.

Any chance we can have GL-S-005Z added to the drivers? I bought a few of these without checking the drivers and can’t do anything with them.

last change on this app was more than a year ago, so I’m afraid nothing will be added anymore…

Hi Guys (@Julian_Isaacson & @Joost_van_Kempen) , i’ve had the same issue, but i just added the drivers myself and made an pull request (that was actually the last update).
its super easy no coding required:

  1. Add the new devices to homey
  2. login to, and search for the device in the devices tab
  3. write down the following: deviceId, profileId and id
  4. fork the repo of the app on github
  5. in the app.json file copy the code of an existing device (e.g. line 208 till 309) and replace the values of the copy’ed device with the ones you had collected on the developer website in step 3 (for reference the old line (so before copy) numbers where 210, 212, 213, 279, 280, 281)
    5a. replace the path to the images of the device (old line numbers 273, 274)
  6. in the drives folder copy a existing device (e.g. gledopto_gl-s-003z) folder and rename it to you device type name (e.g. geldopto_gl-s-005z) i would suggest copying a devices that looks like your device (so existing light strip for an new ligth strip, and existing GU10 for an new GU10, etc.)
  7. in that (new) folder edit the device.js file on lines 6 and 9 to match you device
  8. in the same folder there’s an assets folder with an images folder replace the large.jpg and small.jpg (exact same dimentions) with clear pictures of your devices.
  9. test the app via the CLI install method. (re)pair your devices and see if its working
  10. if working correctly, make an pull request on github (and use you own version till it is accepted, when updating to the appstore one again, the devices will remain (no need for repairing))

This all may sounds harder than it seems, even i could do it, so it isnt :stuck_out_tongue_winking_eye:
The white leds will sometimes not work, this has to wait till the zigbee rewrite.

Good luck!

1 Like

@matrover thank you so much. I’m afraid the last time I did any programming was in 1982 so this JSPN lark is all beyond me.

I managed to download the other stuff from Github so I’m sure I can manage this and it might even be my gateway to a little Modern-era programming…

Thanks @matrover, I think I can manage these steps! It would be nicer when the pull requests would be merged. I even thought about forking and adding my forked and merged app to the app-store, but don’t think have enough time (and knowledge) to be an app-owner :wink:

Hi @Joost_van_Kempen thats the whole idea of een pull request right? The developer of this app is an active homey user/developer if your pull request is done just send him an message (i did the same)

I’ve started on this little project. Forked the code, made the changes. CLI install works, all green on the checks. After successful install the app keeps crashing. Crash details state 'cannot find module ‘homey-log’. Anyone ring a bell?

solved on Slack, apparently for using CLI you need to have Git command line installed…