Gledopto GL-C-006P with reset button - issues with paring and controlling the device

I have couple of zigbee LED controllers from Gledopto and they all work really well. I now got a new one: GL-C-006p with a reset button. First, I had a lot of issues paring it with Homey. I would get to the screen saying something like “adding device” but then I would get a message that adding failed because the device is no longer responding. I then finally managed to pair it with Homey but I cannot control it. I cannot turn it on/off, dim etc. I have two other GL-C-006P units without the reset button that I bought earlier and those work without any issues. Any ideas on what could be causing the issues? Maybe I am just unlucky and received a faulty unit.

Try the ‘interview’ button at

I think that I have the same problem as Krzyslek. I bought 2 GL-C-009p controllers. The issue occurs with both controllers. The controllers are added without any problem in Homey. But when I perform an action (dim, power off/on) there is no response and after quite some time I get in a red box the error message ‘the request took to long’ (in Dutch ‘Het verzoek duurde te lang’). I have tried both the community version of the app as the official app.

@Peter_Kawa: interview button gives a json result. How could that help me to find a solution?

Thank you for any help!

@Peter_Kawa I will give it a try tonight - currently that LED controller is not powered on. I tested it remotely with another controller, GL-C-008P and got a bit strange results. I can see in the developer tools that it is not online and I get a timeout message when interviewing but at the same time I can still turn the LEDs on and off. How can this be? I connected this controller for the first time yesterday and I have to say that it is misbehaving a bit. When I was changing the brightness or color temperature very quickly, I was sometimes getting a timeout error message - this never happened with any of my other zigbee devices. I would suspect some range issues but I have another zigbee controller just next to it and that one is working perfectly fine.
I also tested it with 2 of my other GL-C-006P controllers, those show up as online and I can interview them.

@hankdroid do you have a GL-C-009P with the reset button or without it? The issues I am having are only with the controllers I purchased a bit more recently and both of them have the reset buttons. Maybe there are some small differences and they are not fully supported yet?

@Krzysiek there is a button on it which serves as a on/of switch (short press) and as a reset button (long press). I bought both together a few weeks ago.

Ok, then it is the same as on the new controllers I have. It would be nice if it would be just some compatibility issues because hopefully those can be resolved soon.

I tested it a bit more now but both controllers are behaving in a really strange way.

GL-C-006P with the reset button - this time I had no issues adding it to Homey. I interviewed it just after, then after 5 min and after 10 min with LED strip connected to it. Every time the interview is successful. The online status is “?”. It is not reacting to any commands. The LED strip is on but I cannot dim/turn on or off/change color temperature.

GL-C-008P with the reset button - this has been connected since yesterday. Every time I interview it, I get error message saying that the interview timed out. I can control the LED strip connected to it dim/turn on and off/change color temperature but sometimes it does not respond immediately. Also, every time I change any setting for it, as in for example dim, it reacts but Homey app says that “The request has timed out”. The online status is “x”.
(edit: After 10-15 tries I now managed to interview this one but only once. I tried 5 times soon after and every single attempt timed out. It also has a lot of “UNSUP_GENERAL_COMMAND” entries but I can at least control the LED strip connected to it.)

The other two GL-C-006P without the reset buttons react to commands, interview is successful and the online status is on.

Any ideas? What should I look for in the interview log? The log for the GL-C-006P with the reset button that is not responding to any commands but is interviewable has a lot of “UNSUP_GENERAL_COMMAND” entries for example.

It’s not about the resulting JSON.

It is an unknown ‘feature’, which can sometimes ‘activate’ missing device capabilities.
Like, for a lightbulb, which doesn’t have a color capabilty at first as Homey device, but the color capability appears after interviewing it.

Do you know what the issues with interviewing could be related to? Why could one device almost always fail to be interviewed due to time out but controlling it would work while the other one can be interviewed but cannot be controller? Just incompatibility issues and the developer needs to update the app or could it be something else?

That’s beyond my knowledge, I suggest asking that to one of the zigbee developers. You can find contact info at the bottom of the app store pages like this one:

Thank you. The thing with the Gledopto’s Homey app contact link is that you get transfer to their main page contact form and they never reply. At least not to my questions :slight_smile: I already explained the issue and offered to test things for them and share logs.
Btw @hankdroid yesterday I added a GL-C-009P controller but without the reset button and this one works perfectly which to me confirms that the ones with the reset button are not fully supported yet.

Did you try the community app? Worth a shot: Gledopto and Tint lights and LED Controllers (ZigBee) App for Homey | Homey

@Krzysiek : Thank you for the update. I guess removing the reset button will not be an option :laughing:
If there is any progress, please keep me updated. I’ll do the same.
@Peter_Kawa : I already tried that. With the same result. On the website this app is marked as only for pro version, although I can install it. May be that is the problem? I own a regular (not pro) version of 2019.

Well Athom stated at the introduction of Homey cloud, that it would be called ‘Homey’, and all white ball Homey’s are called Homey Pro.
Very confusing, while now we have the ‘old’ and ‘new’ Pro as well :laughing:.

So if it says ‘only for Pro version’, you can install it just fine on your 2019 (non)Pro!

1 Like