Gledopto controller GL-C-009

I tried to pair the Gledopto GL-c-009 in the app on the homey. It doesn’t recognize the device and add not as an unknown device. I can switch it on and off, but it isn’t dimmable.
Is the re a possibility within any Homey app to use this device?

As you can see in the app store, this device isn’t supported by the Gledopto app v1.1.4.
With the Gledepto test v2.0.3 the controller is supported, but therefore you need Homey FW v5.x.
The Homey FW v5.x has still beta status. If you want to update the Homey FW to v5.x I strongly recommend to inform yourself first! Because the current FW is still buggy.

Thanks for your quick answer.
Is it known how log the beta status will last?
Is there a place where I can find which area’s in Homey V5 are buggy.
I don’t have a very complicates environment. Just starting with klikaanuit and Fibaro devices. This Gledopto is my first Zigbee based device.

No. At least Athom knows, but they don’t give a official date.

Not really. There are several threads, e.g. this one, and also in different languages. Problems may occur with one user, but not with others. Some problems are also only in combination with some apps, mostly apps for Zigbee devices. The main reason for the v5.x firmware is the rewrite of Zigbee.

The Fibaro app runs stable for me. I can’t say anything about Klikanklikout and Gelepo.

Homey runs stable for me in the meantime. In between, however, I had massive memory problems.

Thank you for your help sofar. I don’t have many devices connected yet , or complex flows. I have made a connection to apple-homekit and want to find out if that is an option for central control.
In the mean time I will replace the GL-C-009 by a controller with RF, so I can switch the leds via klikaanklikuit and (if necessary) dim them with the RF.

I have a weird issue with the Gledopto GL-C-009P
I have an Homey Pro (Early 2023) and I am able to add the device or with the official app or with the community version. I had one app installed at the time. But in both cases the device is uncontrollable, it does not respond to on/off or dim. I am however able to interview or ping the device from developers section.

Now the weird part. When I have no Gledopto app installed, the device is added as unknown/generic zigbee device and the controller works fine, I am able to use on/off and dim the led strips (single color 2700K) attached to the controller. :man_shrugging:t3:
I made a Gledopto support ticket to be sure, although it works fine without the app.

Iam experiencing the same problem with the same dimmer.

Just use generic zigbee device (no app installed). Do you also experience that only the right side is dimmable? The V+/V- on the input side is only on/off not dimmable.

Just removed both apps. But also as a generic zigbee device it is not working. Strange is, Homey is making the dommer flash. Telling me it’s being installed and after some time the response ‘the device is not responding’.

dommer = dimmer

The right side are both inputs for supply voltage. So the round connector and right hand side V+/V- are connected together on the inside of the dimmer. Measured this.

1 Like

Weird, it’s working fine on my side :man_shrugging:t3: HP23

Restarted Homey after the removeal of the 2 Gledopto app’s. Gave it another try and now i was able to get it working as a generic zigbee device!!!
Still i am not happy with the not working app’s. But happy these devices are working because this is device number 45 in the zigbee list and that can become a problem. Too many zigbee devices for Homey.

1 Like

Is your experience that the Gledopto app needs to be uninstalled? I have couple of Gledopto zigbee controllers without the reset button that work fine.
I have a problem with the GL-C-008P (RGB + CCT) with a reset button. I had it added to Homey and I could control the led strip without any issues when I tested it around 2 weeks ago. Recently I noticed that I cannot control the device anymore. I tried the repair process but after showing the device is being added message, it goes back to the screen that tells me to reset the device. I tried removing the device, resetting it and adding it again but that does not work either. I get a message saying that it failed or it goes back to the same screen telling me to reset the device. I have the same issue when using the Gledopto app and when adding the device as a generic zigbee device.

I also have a problem with the GL-C-006P controller with the reset button. I managed to added it to Homey couple of times but I never managed to control it. It always times out.
I am using Homey pro 2023.

Yep, I uninstalled the app and as a generic zigbee device it does the job for me. But I have a Gledopto GL-C-009P

Hi again,

I am now having issues both with the GL-C-008P as well as GL-C-008P mini controllers.
I am able to add both of those to Homey (often with issues) using either the Gledopto official app or using the generic zigbee option. I can control my LED strips for couple of days and then after some time I cannot do that anymore. I get no error messages like “your device has left the zigbee network” or similar. I just try to control the LED strip and realize that it is no longer possible. It keeps on timing out no matter how many times I try.

When I try to repair the connection, the device leaves the network due to a reset and often I cannot add it anymore. I then try a couple of times, power cycle it, reset it and then in the end I manage to add it to Homey. Then couple of days later the same thing happens.

Has anyone experienced anything similar? I have several other Gledopto zigbee controllers but those work perfectly. It is only the GL-C-008P and 008P mini ones that keep on causing problems.

I have an issue with my GL-C-002P 5in1 mini controller. It is possible to add it. But as soon as it has been added all the commands just give me a timed out message.
I have tried to add it as another RGB+CCT device in the list of available devices with the same issue.
It always shows up as a GL-C-008P when I have a look in the advanced settings.

If I add it in RGB mode it works, but then of course only with RGB colors, no white options. Then the model shows as GL-C-003P.

Any idea what might be wrong?

@Krzysiek and @KungWaz, first of all it’s important to provide as much information as possible, e.g.:
– which Homey and firmware version
– which Gledopto App and version
– etc.

This seems still to be a bug with the firmware of the Homey Pro (early 2023):

(Source: Homey Pro (Early 2023) Changelog)

A timeout can be a sign of faulty inclusion, but also of a poor or interrupted connection. In Developer Tools → Zigbee you can ping the device and test the connection.

About the other problem, I recommend to contact the app developer. Links are available in the app store.

But afaik, the Gledopto community app isn’t supported anymore.

Gledopto app (official), v1.1.4

Homey Pro (Early 2023), v10.3.4

  • App Version

When I ping the device (connected as RGB) I get a response. Haven’t tried pinging it connected as RGB-CCT.

Do you still receive a timeout error message?
Sometimes it can also take some time for the Zigbee network to re-sort itself when new devices are added.