Fibaro Walli, do they work with Homey?

I tried to add as a roller shutter 3 but it didn’t work. I also tried to setup homey in experimental mode, install CLI and download the GitHub package but looks like the pairing doesn’t work. The Walli flashes green and the app asks for “press the button 3 times” but the pairing times out.

Any ideas?

Quick update - I confirm that Walli roller shutter works with Homey.

I solved the issue I was having by resetting the fibaro Walli roller shutter. Now it works like a charm with Homey experimental + github fibaro package. Also, doing the calibration, enabled position setting.

No need for experimental, it works with new beta version. Walli roller shutter is called roller shutter in the add new device section.

Thank you!

I am running the the experimental version and my dimmers all work well.
Will this version automatically be replaced by the final version?

I have no experience with the way updates work with Homey.

Someone made a nice topic for that!

1 Like


Does someone have the Walli Dimmer? I want to buy this but have a questions about it.

  • Do you need to configure flows to dim the lights? Or can you dim without?


Hi Jeroen, you can dim with the app and in a flow.
You can also set a relative dim level according to how dark/light the room is (Lux value).
They work really nice.

In een flow zijn er deze mogelijkheden:

Yes I had to do the same thing. I had a bug, my homey was saying “Device already added”.
I had to try to remove any of my fibaro device on Homey and start the removal procedure on my walli shutter. Then, reset the walli device and try to add it again.

Hi Hans,

Thank you for the screenshots, this i what i was looking for.
I can buy this now thanks :slight_smile:

Thnx! Very nice dimmers.

Remember, the Walli’s are very new and not all accessories are available yet!
FI, these are not yet available.

At least, mine are still in backorder.

Also, the Walli Controller, a battery powered switch, is also not yet available but should be somewhere in september.…

1 Like

thank you for the reminder, i have gira55 switching material, so i think i need to buy this one

Hi @Jeroen_W,

if you want to use the original Gira55 frame and button instead of the walli frame and button, you need this adapter plate.

For more information please read the manual:

You can even dim it with the Walli itself just by pushing it :wink:

Yup, works same as fibaro dimmer. You could even let the fibaro dimmer 2 (or 1) stay in the ceiling and control it directly from walli dimmer using association.

Has anyone been able to add the Walli Switch to homey yet ?

No in v2.1.41.
I had contact with Athom support and the are working on it.

Dag Nick,
Bedankt voor je bericht en vraag, op het moment zijn wij bezig met de implementatie van de Fibaro Double Switch.
Echter is de werking van de Double Switch vrij gecompliceerd en zijn wij daarom in contact met Fibaro. Wij hopen deze zo snel mogelijk te kunnen implementeren echter kunnen we nog niet zeggen wanneer.
Ik hoop je hiermee voldoende geïnformeerd te hebben voor nu.
Met vriendelijke groet,
Best Regards,
Athom Support

I’m waiting for the Fibaro Walli Double Switch support.

Problem is that the device has 1 main and 2 sub devices , first is main as well as sub device. .1 is almost same as the main and both respond and get double info. The z-wave network stack needs to listen longer due to extra strings which slows down entire zwave network in case they extend time-out period. Sending/receiving need the correct values preceded by correct id and sub-id of the device instead of communication direct via the sub device-id as usual. Probably the problem resides in this and therefor the complete z-wave stack requires to be changed and this might take a while.
Edit: Translated to English per request

I have a walli rollershutter connected to somfy sonnesse 40 wt and set to venetian blind mode, but the created ‘angle’ device doesn’t do anything. Old roller shutter 2 does work ok, but the walli can only handle dimming. Bit of a challenge to push dimmersetting so that it’s set to right angle this way. In the RS2 you can set it to fibaro protocol and it works fine but the walli seems to have a different approach which appears not to work. Hopefully athom fixes this soon. Also walli shutter device gives a reminder about this might change in the near future.
Google home nl is also not able to see the roller shutter. I made a virtual dimmer and a flow with the dim variabele of that virtual dimmer set to dimvalue of the rollershutter. Can now tell Google home to : ‘dim blinds to 50%’. Then it will set blinds to 50% position. 0% completely closed etc. Works ok like this. Virtual knob blinds close/open should also work but i liked the dimming option better. Sounds a bit off though ‘dim blinds’ but ok it works.
Edit: translated to English per request