Fibaro devices doesn't recognised by Athom

Dear Team,
I have few Fibaro flood sensors FGFS_101_v2_1. They are recognised by App as General Z-Wave devices. All of them new ones, correct recognised by Fibaro Home Center (tried to check if something wrong with sensors). Another sensor is Fibaro Smoke detector - same picture. It recognised as General Z-Wave device.
Do you have any tricks or solutions, how should I do to have these sensors in full functional under Athom?

Well the best and only way is to fill in their device request form with the id’s (device ID productTypeId and productID) you’d like to add, you can find these in the generic zwave device’s advanced settings, as they often (99.9% of the time) don’t respond here.

Thanks, Caseda. Will do all requests follow your link.

Just a stupid question.
Did you installed the Fibaro App?
Because, both devices should work with the Fibaro App. Both are listed as supported devices.

Of course, yes. But after I choose the device and follow the instructions (three times push etc.), Athom think very long time and said that there is no special device info and it will be added as General Z-Wave device.

I also have a Fibaro Flood Sensor and it runs without problems. However, I have already installed the sensor with older versions (Homey v3.x; Fibaro App < v2.4.6).
Both devices are definitely supported. Maybe it has something to do with the revision of the Homey FW and/or the Fibaro App.

Did you include the two sensors in very close position to Homey (< 10 cm)? By the way, this has to be done at HC as well.

will try to do in close position.

This must be done with all Z-Wave devices, especially battery powered devices.
If a good working Z-Wave mesh is available, the electrical powered devices might be included directly at the installation position.

Devices are included based on the device’s internal ID’s, with fibaro devices these id’s change when a device is shipped with newer (minor) hardware and/or (major) firmware update, so if he has a newer device it is definitely possible that just his id’s have changed and need to be added into the app.
If the id’s aren’t in the app, a z-wave device will be included as generic z-wave device, distance can’t change this, then it will just fail to include at all.

Well, yes, I know that, but I probably repressed it, sorry.
Thanks for the hint.

How can I check which ID is in the app? The ID in the device shown at advanced settings screen in Homey app. And what to do if I see the other ID?

It isn’t really easy to see, but I can try to explain where you can see it.

You can see which id’s are in the app for each driver by going to this github page, select the driver (a.k.a. Device code name) you want to see the id’s from (as example fgfs-101-plus for the z-wave plus version of the flood sensor), and open the file “driver.compose.json”, there are 3 different id’s in pretty much the middle of the code.

manufacturerId, which is always the same for fibaro

productTypeID Which has 1 id that is currently supported

productId which has currently 4 different id’s it supports

All 3 ID’s are compared to see if they correspond, if only 1 is different for your device, then it will not use that driver for your device.
So if it can’t find any driver in the entire app (and all other z-wave apps on your Homey) with all 3 ID’s it will include it as generic z-wave device.

Just noticed I said previously deviceId, but I meant productTypeId, my bad.

Checked configs:
ManufacturerID - 271 both
ProductTypeId - 2817 both
ProductId - 4098,
12290 - in the driver but 16387 in my “General” device!
Thats it! So what and how I should do to change the driver (add my Id inside)?

If you know how to install apps via cli you can just add it to the back of the list and run/install it from cli.

But judging the ID now (16xxx) seems like you are from another country/region (Russia?) then the currently supported ones, which is I believe 2x European, USA and Australian respectively.
Fibaro also keeps its different regions seperate with their ID’s.

Yes, you are right, I have all devices with Russian Z-Wave frequency, so there are different Ids. Checked for Roller Shutter - same issue:
my ProdictId - 16384 is absent from FGR-222 driver Ids
Will try to install new drivers may be tomorrow and see the results

Thanks for very helpful advises! Now I have a chance to continue using Homey as central hub without additional Fibaro HCL

Yeah, not a lot (only 2 I believe) of fibaro devices have their Russian ID, so if you add more fibaro you’ll probably bump into more devices.