Fibaro Motion Sensor not being recognized

Just tried to add a Fibaro Motion Sensor to Homey but it is not being recognized and thus is added as a “Unknown Z-Wave device”.

I have tried to remove the device from the Z-Wave network, resetting device, Fibaro app and Homey but it all did not make a difference, the pairing process has been done within 0.5 meter of Homey.

So, I am not sure if this might be a new batch that is not supported(?) or this is an issue with the device itself.

Homey Firmware Version: 1.5.12
Fibaro app: tested both the stable and beta apps

Product: FGMS-001 ZW5 3.3
Production date: 02-08-2018


May be of relevance:
I have 2 older versions of this sensor (both different from each other but same driver), and both have a product ID of 4097. Don’t know if that could be the cause, but something definitely changed there.

Is it a EU version of the motion sensor or another (Z-wave) region?

As far as I am aware it is the EU version of the sensor (bought it a store here in NL :slight_smile: ).

I also just read a topic about a garage door opener which also got added as a unknown device although the device itself should have been supported, apparently this was also caused by a different product ID. I suppose I’ll have to submit a request to add the new product ID to the Fibaro app.

The Product ID 4098 is definetly present in both stable and beta Fibaro app.
The issue with the garage door opener was a bit different since that was an Australian frequency unit hence, different Product Id which in that case was not added before.
But yours is an EU version and as per the screenshot, the Product Is is in.

Maybe try choose z-wave instead of Fibaro—> Motion Sensor during the inclusion process.
And please don’t get this as stupid question: Is your Fibaro app Enabled?

Disregard the above post! Somehow I opened the driver for the flood sensor FGFS-101 instead for the motion sensor :roll_eyes: doh
Indeed, yours has a different Product Id.

@TedTolboom is that possible that Fibaro would create a new Product Id for the same frequency sensor?
I looked to their website and could not find any new feature motion sensor. Unless I am missing something.

@Paul89 reported firmware version v3.3 of the device…
that firmware version is not reported on Fibaro’s website (no updated manual), nor on the Z-wave alliance site… The latter could mean that they chose to not have the updated firmware certified…

@danone it could be (speculation mode) that Fibaro added S2 security with this firmware version… which could explain a different productID… but without confirmation, I can’t tell for sure

Thanks for replying.
Yeah, I was reading today a z-wave book and learned about the S2 security.

Just a question @TedTolboom
If let’s say Fibaro has released a new firmware which include S2 security. Would that be possible to include this “new” sensor? Or does Homey needs to support S2 security? Sorry if talk nonsense… if that’s the case I’ll go finish my book first. :grinning:

@danone, the Fibaro app was enabled. :blush:
I also have tried to include it as the “normal” motion sensor, both without success.

@TedTolboom, is there something I can do to help confirm this new version? Because 3.3 version is listed on the package of both the sensors I have. I initially just tested one so in the worst cause I could return the other one…

So, I ended up adding the ProductID manually to the app.json file of the Fibaro app package and manually uploaded it via Homey CLI, so that I can at least use the sensors in the meanwhile. :smiley:

I’ll submit the request for support of the new version in a bit.
Thanks so far guys!

1 Like

Thanks @Paul89 that answers my question above. Glad to hear that you could included it by only adding the product Id.

@Paul89 main question is what the changes are in this firmware version…
I could not find any information about it.
I already pointed @MatthewWaanders (Athom’s Fibaro app developer) to this topic.

@Paul89 Could you let me know if this is the Z-Wave plus version of this motion sensor? You can find out by both the packaging and the sensor itself as they both come with a little Z-Wave logo, if this logo states “plus” in the bottom half of it it’s obviously the plus version.

When I know this information I can add the product ID to the right driver and you’ll be on your way and using your motion sensor again as soon as possible!

@MatthewWaanders, both the packages state it is the Z-Wave plus model (both are also from the same production date):


Just for your info, I had the same issue with one of mine. I bought two and after a lot of trial and error I decided to try the other one, which worked perfectly.
Returned the first one and the store would like to test it, waiting for a reply to see if the sensor is in fact DOA.

@Mostad, did you happen to check the version of the none-functioning motion sensor or the product ID?
It could have been that you also received a motion sensor of the supposedly new ZW5 3.3 batch.

As mentioned above, I ended up manually adding the new product ID to the app.json file of the Fibaro app and then installed the app via Homey CLI.


Haven’t had any problems so far with the two motion sensors I have.

@MatthewWaanders, is there already any indication of when the new product ID will be added to the app? it would be nice if I can switch back to the “normal” Fibaro app. :slight_smile:

Hello guys !

I’ve just bought Fibaro FGMS-001 ZW5 3.3 and I had the message “Unknown Z-wave Device”.

I’ve read your post and it solved my problem ! So I want to thank you and summarize steps to be clear for those who will have same issue :slight_smile:

  • Just download app via Github: Here
  • Edit the file “app.json”.
  • Add "4098’ at lines6800 (or 4097 I don’t remember know, the one is missing :smiley:) like this: 17
  • Install the app via Homey CLI (How to here)
  • Go to Homey and add device -> Fibaro -> Motion sensor (z-wave PLUS)
    It’s DONE !

Thanks you again !!

1 Like

Really struggle with getting the Fibaro motion sensors working right. I know there is an issue with the registration of motion clear and sometimes motion from sensor to Homey. This really needs to be addressed as an priority as I’m sure I’m not the only one with many fibaro sensors.


Yeah, same here.
The old ones I have work perfectly, but the newer models have problems.
I cant turn of the led. The motion sometimes “hangs”. And I’m sure more settings dont update right when I edit them (but are more difficult to test, like sensitivity/delays etc.)
Also the update frequency of lux/temp cant be updated, its always the same.

Hopefully the next fibaro update will fix it as it works on the old ones.

My motion sensors completely broke after the last update. They are not reliable anymore and work for +/-40% of the time. So an update cannot get here soon enough…

Do you only have the “plus” versions?
For me, its the “zwave plus” devices that dont work as the should.