Fibaro app doesn't handle humidity sensor value

I have a Fibaro Smart Implant with a DHT22 temperature and humidity sensor connected to it.

The app reads the temperature value but not the humidity value.

Anyone that has any experience from this.

By the look of it Athom hasn’t allowed for humidity when connecting a DHT22, only temperature

You can make a feature request as per the opening post.

Any news regarding the humidity value back into Homey?

How can I do that?

I have the same issue, only temperature is working

Don’t make me crazy! I just ordered a smart implant and a DHT22 Sensor. I want to build a weather station. (Rain sensor, Wind sensor (0-10v) and DHT22 (temperature & humidity).

Did you guys get any feedback back from Athom after sending a request??

Unfortunately not, didn’t hear anything. It works good with temp sensors, though.
The humidity part would have been a nice fit for garden where 1/the Xiaomi plant sensor will perhaps die if left in the weather and 2/ the garden is out of Homey’s bluetooth reach.

There is a Test version of the Fibaro App available.


Thanks! I haven’t checked it for a while now.
Shall install it and test it this weekend.
Does it say anywhere what exactly has been fixed??


I think a comparison between 2.4.3 and 2.4.4 on Github is about all you’re going to get. The bulk of the changes are whitespace fixes (:scream:), the only relevant changes seem to be an additional product id for the FGT-001 device and a single switch mode fix for the FGWDEU-221 device.

Yes, you are very right. No humidity support, only minor updates. :grimacing:

After figuring out how to separate the Inputs from outputs, the only thing that I still missing is the humidity.
I hope Athom will fix it very soon. It’s only one capability they have to add.

+1 for this feature (humidity) to be added to the fibaro smart implant. Very useful for a wine cellar

hi and good evening, still no luck on the humidity readings via homey?

was hoping it has changed already.

Well I am very lucky today. First figured out that Homey does not yet support the Fibaro Double Smart Module, so I went ahead and tried the Smart Implant with DHT22, now figured out that this is not supported.

So why do you don’t have a look into the App Store before? Every supported device is listed.

By the way, the Smart Implant is supported in the test version of the Fibaro App:

1 Like

yes, how do I put in such a request? I am in need of a humidity readout as well :frowning: