Fibaro Smart Implant sending strange values

Hello all,

I use a Fibaro Smart Implant for some (under water) temperature measurements. This is my setup:

  • Fibaro Smart Implant, located in a closed box
  • 9VDC Power supply
  • 2x DS18B20 sensors with cable length of 3 meter
  • 1x DS18B20 sensor with cable length of 10 meter

Since a few weeks it is sending strange values to Homey. I don’t know where the fault is created, in Homey or in the device it self.

The problem that occures is that my short DS18B20 sensors (so the 3 meter ones) are sending odd values (like readings between -50 and -110 degrees, or above 40 degrees), where I am sure that the water is never below 10 or above 30 degrees.

What makes it even stranger is that it only seems to happen at warm days ( >23 degrees outside), at the warmest point of the day (between 12PM and 7PM). The smart implant is located at a shaded place, in a box near the ground, which is waterproof and light-tight.

Another point is that the internal temperature sensor of the Smart Implant shows a temperature that is normally 10 to 15 degrees higher than the actual outside temperature, and when the problem above occurs, it normally shows a value above 30 degrees.

Around one week ago I replaced one of the short sensors with another one of the same length. The old sensor looked a bit damaged so I guessed that it was the one that may have been causing the trouble. From that point it seemed stable, until yesterday, when the problem occured again.

So my question now is, does anybody recognize this behaviour, or has any clue what might cause this problem?

Here is a screenshot of the last 24 hours. Note that the gap is when I rebooted Homey for other reasons, so this has nothing to do with it, since the problem also occures when I don’t reboot Homey.

The specs of the Fibaro Smart Implant tell us that it can operate up to 40 degrees (Celsius), so a temperature above 30 degrees is getting close to that limit. On the other hand, you don’t mention the sensor hitting 40 degrees and most companies have a bit a leeway in those limits, so it’s unlikely. Have you tried using a different temperature sensor (different brand) to verify the actual temperature inside the box?

Yes, I tested it by leaving the box open in the open air (I did that multiple times already), also in a shaded place. So at that point, the temperature should be the same as the outside temperature, which was not the case, since there was still an offset of the same amount. I therefore think that the offset is constant and the box does not ‘warm up’ by the smart implant.

Could this mean my Smart Implant is broken, because nobody seems to have this problem?

-Edit: there are no other components in the box that could cause any heating of the box-

Didn’t you replace the sensor already, and get the same results? So that would mean you have 2 broken sensors? Possible, but unlikely

That is normal. Finally, the temperature is measured inside the device. Electronics generate heat.

The average internal temperature is in my case somewhere about 32 degrees.

It is quite normal that temperature sensors determine different values, but I am talking about a maximum of 1-2 degrees Celsius and not 10-15 degrees Celsius. Therefore temperature sensors for scientific purposes have to be checked and calibrated again and again.

@Osorkon has already given an explanation for the clearly too high internal temperature, which is plausible.
But then I have to ask myself about the sense of the internal temperature sensor. Especially because it has a measuring range of -55 to +126 degrees Celsius, at an operating temperature of 0 to +40 degrees Celsius!?

Is there any option in the advanced settings to calibrate the internal and external sensors? To set an offset? I have not found anything in the manual.

The low temperature values of the external sensors can actually indicate a defect (e.g. cable break, cold solder joint). Be it on the sensor itself or on the electronics of the SmartImplant.

Maybe you should contact Fibaro support to clarify some points.

I tried to recognize a pattern, and for what I see is that it only occurs at hot days, at the hottest period of the day. The 9VDC power source is plugged into a socket which is not in direct sunlight but in a half-open shed that heats up very quick when there is enough sunshine.

I am not really familiar with power supplies heating up too much, but my guess is that the 9VDC adapter gets too warm and cannot supply enough power to the Smart Implant (can this even be the case?). Unfortunately I am not at home during day time, so I cannot test it right now. My next step would then be to replace the power supply with a 12VDC or higher one, and try to put it in a colder position.

Okay, so yesterday afternoon I did two changes to my setup:

  • Connected a thugger power supply, which is 24VDC and can supply 6 Amps.
  • Shortened the wire of the long DS18B20. It was actually 12 meters (not 10 meters), and I shrunk it to ~7 meters, my idea was that maybe the length of the cable would cause a load that could not be handled by the Smart Implant.

For one hour, all sensors worked fine, the internal temperature sensor still showed a higher value, but let’s ignore that from now…

After that hour, all external sensors showed a value of 0 degrees, while the internal sensor happily keeped showing ‘normal’ values.

It has now been more than 20 hours since I changed this, and still the sensors show 0 degrees. I checked for loose wires, since I know that the Smart Implant will sent none of the values when one of the sensors is not reachable, but this was not the case. I’m getting a bit frustrated by the behaviour and still I don’t know the source of the problem…

I’ve the same problem. Did connect 2 external temperature sensors to the fibaro smart implant. Had first to exclude from Homey and then reconnect again so the Fibaro will recognise the new sensors.
For about 2 hours Homey reports the correct temperatures.
After that reporting freezes and the last reported temperatures are not changing any more.
The Fibaro INT1 and INT2 are still working correctly and are reporting the correct state.

I think it’s a Fibaro app bug.

Hoe did you connect the sensors? 1-wire is a serial bus. It means you have to wire the master to the first sensor, the first sensor to the second sensor, the 2nd to the 3rd and so on. If you put them in parallel, problems will occur sooner or later.
Another thing is the pull-up on the data line. Some masters have an internal pull-up, but most of them require an external pull-up resistor.

If you read the manual, then the temperature sensors should definitely be connected parallel, without any resistors.

Electrically yes, but the arrangement should be such that the sensors connect to the master on a single wire.

Hello. i’ve the same problem.
For any minute, the temperature external is Ok, but after that the value is freezing for the last value.
i’ve connect the external temperature directly in the fibaro smart implant, witch 60cm cable.

Any Solution?


Hi DieJan,

I have a similar problem. I have 6 smart implants installed, most of them with 1 sensor attached. (at genrerally 3 meters of cable) 3 smart implants started giving negative values (-40, -90…) from their DS18b20 sensors after working well for a while. (This happened at a cold day). Internal temperature is measured properly. Since then no normal output values anymore.
I’ve used a whole batch of DS18b20 sensor (about 60) of which 42 are connected to a Raspberry pi, no failures from there, so don’t expect it’s a sensor issue.

Where you able to solve your problem by now? If so please tell me how.