Fibaro Smart Implant and Dallas DS180B20 cant find it


Been struggling with 2 brand new implants trying to connect 1 new Dallas DS180B20 and 1 older sensor to those
But it dosent report back the temp from the dallas sensor at all .

Ive exclude it and including it with dallas sensor connected to the implant
Even tried with 2 brand new implants , and 2 dallas sensors but failing to get the temp from the sensor .
Only internal temp is showing on both the implants

Running it with a homey 2023 Pro 10.0.3

Should the setup take so much time before its been added ?

Or there is a problem between the implant/ homey ?

Homey is placed 1 meter away from the implant.

If i measure the + to the implant its getting 12.32 volts
measure the dallas sensor its 3.31 volts

Any ideas ?

Are the sensors connected correctly? Can you post a screenshot?

Here is a pictur of it , but perhaps hard to see

Red on sensor is power and connected to implant brown

Yellow on the sensor is data connected to white implant

Ground black sensor is connected to blue implant

Don’t see any picture, sorry.

Did get the advice to use the code 00000 instead , then it suddenly kicked in and reporting temps , very wierd . But up and running

Sorry for late reply!

Interesting, with the code 00000 the device will be included unsecured instead of S2 Authenticated.
However, this shouldn’t be the reason why the sensors are not detected. From whom did you get the hint? From a user or Athom Support?


Did get that info from a retailer who im bought the smart implant from .

They said perhaps there is a bug in the homey 2023 , its very wierd i agree
But ive been on this implant like 4 days including/excluding , been checking the connection cables etc etc measuring ± data on the sensor.

Perhaps an issue with the dallas sensor /homey ?

Hm, if the dallas sensor works now after including the SI unsecured (code 00000), then I guess the sensor is ok.
Even if it works now my recommendation is to inform Athom about this problem. Maybe it’s really a bug in the Homey firmware.

Ive mailed the support about the issue

I justed installe the Fibaro Implant and DS18B20 and it works. I takes a little time, a few seconds, before any value shows up. I use HP2023 and software 10.0.8. So maybe you upgrade too.

Which firmware does you Smart Implant have? I read that firmware 5.1 does not detect the temperature sensors. There is an update 5.2 available, but you can only install it by using a Fibaro Home Center.
Can you let us know if you have the 5.1 or 5.2 firmware? (can be checked when added to HP)
Thanks !

Firmware 5.2 I had to connect the temperature sensor to the Fibaro Implant before pairing to Homey.

Rmb, that confirms my findings, cause firmware 5.1 is not able to detect the connected DS18B20’s (the used sensors do work on a Fibaro Universal Binary Sensor, but then I’m limited to max 4 sensors)
Thanks for your fast reply Rmb, saves me a lot of time !

I bought a new Smart Implant with Firmware 5.2 and connected to the existing circuits. Added to Homey and ALL temperature sensors (4) were detected at once. Sensors are spread along a (shielded) cable of approx. 12m long, all by using a watertight connector.

1 Like