Denon AVR not connecting

I get the following error message when trying to connect to my Denon AVR-191.

Does anyone know what this error means and what I need to do to resolve it.

It means the app cannot connect to your device. The IP-address,, doesn’t seem right to me, so make sure it’s correct.

Thanks, yes, I turned DHCP on and now have an IP address of

I can now access the device from my browser connected to the network using that IP address.

Now I get this error.

So I can control the Denon from my browser but can’t connect with Homey App.

Do you have a separate IoT network perhaps? I assume Homey is on the same network (10.0.0.*) as the Denon device? And network control is enabled, like the message says?

Aah, yes, that could be the problem. I have two routers. The second is connected by Ethernet cable which runs out to the AV cabinet. The Denon AVR is connected to the second and Homey is connected to my primary router.
I could connect Homey to the same router but what else might I break in the process.
What other devices need to be connected to the same router as Homey? All Wifi, or just hard wired?

It doesn’t really matter, what matters is that devices from one router/network should be able to reach the devices from the other router/network. Including, for some types of devices, the ability to pass multicast/broadcast.

Why do you have that second router? Can’t you configure it as a switch instead, so the devices become part of your primary network? Using two routers, which each their own network, is a recipe for problems.

Thanks @robertklep, I had the router in my AV room because I had a number of devices that had no wireless capability. I’m sure setting it up as a bridge would have solved the problem, but as I now only have one device needing Ethernet cable I have got rid of the router and plugged the cable directly into the Denon. All works now.