Lost all Wifi devices

I have lost connection with all wifi devices in Homey (Smartphone in virtual devices, all chromecast devices, all shelly plugs).

Homey has internet connection and all of the devices are connected to and have internet connection in the router.

Homey firmware 4.2.0

I have restarted both the router and Homey. Need help troubleshooting

Did you accidently activate wireless isolation for your wifi?
Do you have a vlan configuration?
Do you have any firewalls of internet filtering gateways on your network?
Are you using fixed IPs and changed the dhcp settings recently?
Maybe someone changes the wifi credentials?
Installed any large metal things like mirrors around your AP?
In general it makes sense to let the dhcp always assign the same IP to your IoT devices.

Shakesbeard, thank you for replying.

I haven´t changed anything in the router, don´t even think I have the wireless isolation option in the router (D-Link Dir 868L).

vlan configuration - No. (don´t really know what you mean)

Only firewall is in the router and have port forwarding for everything needed (havent changed anything)

I use dhcp reservation in the router. (Haven´t changed anything)

All devices function properly outside of homey and all have active connections in the router.

Hmm… maybe you received a new router firmware and there are settings activate by default which you don’t really want to have. Double check for that, just in case.
Otherwise, your issue seems rather weird. If you have a spare device try to pair it with homey. Just to check if it works in general.
Another router setting which might interfer with some devices is DNS Rewrite protection (or whatever it is called). You might want to check on that too maybe.

I´ve gone through all the settings in the router and can´t find anything out of the ordinary. Automatic firmware of the router is disabled and I haven´t updated the firmware in years.

I tried to remove the phone and re-add it with smart presence but no connection. I have to go to work but I´ll try to remove another device and re-add it later.

Just seems strange that Homey lost all wifi devices but I can still use the devices - just not through homey. I can use all chromecast devices through phone and through google home. And I can use the Shelly devices through the Shelly app on the phone and on the shelly cloud.

Maybe try a pull the plug (PTP) from Homey for at least 15 minutes…?

Thanks for your advice… I have tried it already. Pulled the plug for 45 minutes.

Can you ping homey and your Shelly devices from a computer connected to your WiFi network?

Ok this is really strange. I tried to ping Homey from my laptop and Homey was unreachable.
So I tried to ping all my wifi devices that Homey lost and the router, and all responded.
So then I tried to ping Homey again and this time it responded. So now everything is working again.

Homey had internet all the time and the phone app was working the whole time, it just lost all wifi devices.

What the hell happened?

Glitches , don’t worry, don’t rely on homey to keep your heart pumping.

1 Like

Can you define “lost” a bit more specifically?

“lost” as in lost connection with.

So all those devices are showing a red triangle in Homey?

Yes that is correct, even though they are up and running outside of Homey. But somehow me pinging homey jump-started it. Can’t really figure out what was the issue and what fixed it. After two days of trouble shooting the only thing that fixed it was pinging homey a couple of times.

It’s been a well-known secret that Homey’s networking suffers from issues, where the Homey app says Homey is offline, but it’s still up and running, or Homey losing connection to WiFi devices (@Phuturist has experience with this with his Shelly app) for no apparent reason.

I think that the default reply to users with these issues is that it’s their WiFi’s fault (when the rest of their WiFi devices work just fine and it’s just Homey experiencing problems).

1 Like

I’m not a network specialist but to me it appears as issues with ARP tables. But lets face it, homey is great but not perfect glitch free solution. I’m still very happy with my Homey for 4 years now :wink:

That would be a challenge indeed :wink: