Problems finding devices

Hi all, couldn’t find the exact topic, so I figured i’d make a new one. So I’ve noticed a lot of times if I want to control, for example, a lightbulb though the WiZ app, it works, though in Homey it says it’s offline. How is that possible and how do I fix that? Believe it or not, I’ve never had a flow work for longer than a day. The next day it has trouble connecting to/ finding certain devices. I tried giving the devices a static IP, though that doesn’t seem to do anything (maybe I did something wrong there?) I just used the standard ip adresses of the devices, didn’t change anything, just “reserved” them from within the router/modem. Anybody has an idea on how to get it to work each & everytime instead of sometimes yes & sometimes no? All help is much appreciated!

I have no experience with WiZ, but I find wifi devices not particularly reliable.

How did you apply a static ip? Most routers have a feature to bind an ip address to a device while using dhcp.

Exactly, I used the DHCP., didn’t change any of the ip adresses though. I read somewhere there’s a certain range in which the ip adresses have to fall for them to work properly, no clue what that range would be though. Also, do you know if there’s a way to set more then 32 ip adresses? That’s the maximum as far as I can tell

Which Homey are you using? Because it’s a big difference if you’re using a Homey Bridge or a Homey Pro.
Did you checked if the Homey WiZ app is maybe crashed?
Some users are currently experiencing problems with the HP23 losing its connection to the network. Have you checked this?

I use some bleBox devices (WiFi) with my HP23 (connected via WLAN) and I have no problems at all.
The Shelly App (mainly WiFi devices) is stated on place 4 in the category Appliances. So a large number of users must therefore use WiFi devices.

I have a Wiz lamp and everything else hue. I had the same problems with the Wiz lamp at the beginning. The cause was ultimately the wifi coverage, although I have x-other wifi devices (shelly, Reolink, Netatmo) in operation, some of which were up to 5 meters away and worked.
I would not buy any more Wiz lamps, my own opinion…

I don’t use WiZ devices myself, so I haven’t had any personal experience with them. I also have hardly any experience with LAN/WLAN networks.
What I don’t understand about such problems with WiFi devices is why they work without any problems with the manufacturer’s own app, but (can) cause problems in combination with Homey.