Connection outside the owners country?

I installed a brandnew Homey on a friends network in the Netherlands. When Homey was installed :

  • It did not recognize the local IP ethernet but connects to Could HTTPS instead of Local Secure HTTPS
  • Time displays wrong in Advanced Flows (AM/PM) instead of 23:00u
  • Zigbee devices do not connect at all. (wrong region ??)
  • When setting a sunrise or sunset this triggers a total different time.
    Settings like language timezone etc look okay. Could it be that this device is bound to location somewhere else (USA ??) based upon the external IP address supplied by his Dutch providor?

I took this device to my home and reinstalled again and it works okay. Time is okay Zigbee works.
Has anyone noticed something similar?

Set the location manually.

1 Like

The location used and shown is correct (NL) and did not change behavior after setting manually.

Homey doesn’t always get the location (and thus the timezone) right when it’s used for the 1st time, or after factory reset.
→ Force the time zone to be updated by moving your location pointer to another timezone.
After a minute, move it back to your location.

No, the time zone is determined by the location found / the location you entered manually

From what I know it takes a while to jump to local access

AFAIK this is a browser setting. Check what the preferred language is, set it to Dutch.

Zigbee has no region limitations. Did you tune the wifi and zigbee channels?

Peter Thanks for the info.

Today I solved the problems:

  • the Cloud HTTPs to Local Secure HTTPS was caused by a setting in the router to the internet.
    Set the DNS in the router to (google) or something well known. The DNS of the (fiber) internet provider blocked this or was not compatible with what was designed for Homey. The local address was correct.
  • the AM/PM setting in Homey is dependent on the setting of Windows 11 language host setting when setting to dutch the problem disolved. The browser setting had no effect. When tired to an English Windows host you have to live with this.
  • Zigbee now works, I have no clue what caused the problem. We did a complete factory reset and reinstall.
  • Sunrise and subset still have to be tested.
    But works well on my own system. I guess this will be same on this system.
1 Like

Kinda like to know which dutch isp this is as if they are doing what your saying that’s illegal.

My first thought, ask and double check the router for any VPN’s or active VPN’s on the phone/pc using to do the initial install. If your exit point of VPN’s is somewhere in the states this might do funky stuff. Not entirely sure but likely Athom uses something that is called anycast dns which will point to the same ip addresses but different datacenters globally.

Like google does with

Hello Jepke,
The internet providor (Caiway) is one of larger providers in NL. Their default connection is not a VPN and the location is visible in the NL Amsterdam. I guess something goes somewhere wrong with the name to IP resolve. But that is out of my scope and can be resolved by setting the DNS to At my home I use Quad9 and google as second DNS which also works well.

It’s probably DNS rebinding protection, which is commonly enabled in home router and (probably) not illegal to implement on an ISP level because it’s a security measure.

Paradoxically, to be able to use a TLS connection to Homey over a local connection (more secure), Athom requires these security measures to either be disabled completely (much less secure) or to at least disable them for the Homey-specific DNS requests.

@bergw I do have them too they’re not blocking anything, i however dont use their provided router so likely what @robertklep says. Some security settings in the router or functions. Which in that case is not illegal, if they block alter things in their network it is. Unless they explicitly tell you they do, but give you the option to disable it through a portal or customer service call. Work for a bigger whitelabel operator in the netherlands so well aware on what we can and cannot enforce legally.

If you do use the provided router by the ISP its worth digging through options you’re allowed to enable/disable. If the homey is connected over wifi there might be options that restrict certain types of traffic from wifi → lan or the other way arround. Alternative would be to try a different router.

1 Like