Zigbee low range


Today I received my first Homey, the Homey Pro (2023 model). I was excited to start using the Homey, but unfortunately I cannot seem to connect any Zigbee devices that are further away than ~3 meters, tested without any obstructions in place. I tried physically placing the Homey Pro as close to an outdoor light as possible. The signal cannot reach the outdoor light, which is at less than 2 meters + wall.

I then paired the bulb using a fixture closer to the Homey Pro, so the problem is not that it does not recognize it. After placing the bulb back into the outdoor light, I am only receiving timeouts in the app.

Other than that I have had multiple connection issues, which I found weird considering the Homey Pro is connected via ethernet. However, looking at my home network I found that the Homey Pro is still using the wireless connection instead of the wired one.

Hoping someone can help me out here as my experience so far has been disappointing to say the least. Is there any chance removing the plastic film from the top of the Homey Pro improves the range? At this point I am seriously considering returning my unit so I haven’t removed it yet.

The Zogbee range is for sure not a problem - can you share more - you did migrate from HP19? From backup or from scratch? Have you done PTP? Can you share your Zigbee view from Developer interface? Have you done maintenance - repair on migrated devices?

What have you answered during setup? Does you HP23 got two IPs or one? If one, have you connected Ethernet adapter correctly?

1 Like

Transparent one? You can remove it , it does nothing however

This will not influence your right to return it

Also you’d know it’s antennas are at the bottom side of Homey. Avoid metal surfaces, nearby speakers etc.
Also don’t forget to tune your wifi and zigbee channels!


Go to setup mode to disable the wifi radio. Note: Like Sharkys alr mentioned: when Ethernet doesn’t work, check if you connected the long USB cable to Homey, NOT the short one.
Note2: The ethernet dongle has been reported to be DOA by some users. Check the connection with a laptop or something to check it.

Also, there seems to be some (individual?) issues with the USB-C cable(s); so grab another one from a well known brand, and try again.

1 Like

Thank you for your reply Peter! Changing the USB-C cable worked, the device now has a wired connection.

As for tuning the WiFi and Zigbee channels, this is the channel interference for 2.4 GHz:

Unfortunately all but a few of these are my neighbours’, would this be a problem? I found an older post (April 2021) of you stating the following:

Only if you RESET zigbee (and lose all paired devices) it scans for a quiet channel by itself and selects the best channel number. Otherwise only you can change the channel manually.
And maybe it changes the channel after a factory reset. Many Homey’s seem to be on ch.11, sort of default channel (I assume)
You guessed right. Channel is permanent once after it’s selected, except when (factory)resets of zigbee or Homey itself are performed
Not all zigbee devices support channels 22 to 26 (I guess Athom didn’t want lots of questions and complaints)
No, when performing a factory reset, I assume zigbee channel is 11 again, but not sure. Restoring a backup does not influence the current zigbee channel (I’m almost sure, but it is an assumption)
You can change the channel, but you could lose some paired devices. Most of the time they’ll adapt to the new channel in a certain amount of time.
*NOTE: This is different from a zigbee RESET - This will lose all connections forever, and all your zigbee devices have to be paired again after this.

If this still applies I assume the Homey Pro selected the best Zigbee channel by default? As in: tuning the Zigbee channels myself would not net better results?

Thank you for your replies Sharkys. To answer your questions:

  1. This is a fresh install as this is my first time using Homey. I have not done anything other than the basic steps the set-up wizard takes you through.
  2. The Homey Pro now has two IPs. Changing the USB-C cable worked :slight_smile:
  3. If removing the transparent plastic film does nothing I will leave it on for now

When looking at the Zigbee Channel in the Developer Tools it states Channel 25. This has quite a bit of overlap with WiFi, see:

It’s sideband interference, still it shouldn’t result in such catastrophic loos of range.

Btw also interesting reading - interference between zigbee and wifi frequency 2.4ghz - Haade.fr

Can you share view from Homey Developer Tools ?
Also you are on most recent fw, right ?

If nothing helps, perform backup, try to do factory reset via USB, upgrade to the most recent FW and restore backup … but first share the Zigbee view, just in case.

You’re welcome!

Please report to Athom, there’s something odd with some USB cables

1 Like

Thanks again for your reply.

When looking in the mobile app under Settings, The Homey version says 10.0.0. There are no updates available.
Looking at the link you send:

The Zigbee lights I tested are 1 and 2.

Is there anything wrong in the image above that would be solved with a factory reset?

Thank you for the link, I have reported the issue to Athom Support!

Anything looks normal, those routers really shouldn’t have connectivity problems… have you tried Zigbee reset and adding them again ?
Factory reset might (not sure) even reset Zigbee chip data but it’s theory only.

I will try to do a factory reset later today but I might not have time. If not today I will do this tomorrow

I used this guide to reset the Homey Pro. Now I’ve been sitting here staring at a breathing red ring for over an hour. Is there anything I can do to speed up this process?

How the Zigbee reset ended up, I wrote about in first place?

The factory reset, red led should not take an hour - better next time follow this - https://support.homey.app/hc/en-us/articles/7263435817116-Connecting-Homey-Pro-Early-2023-to-a-PC-Mac-with-USB (you can make backup first atc )

Try to uplug it and start via USB…

The Zigbee option “reset network” did not noticeably improve the range. It did change the channel from 25 to 20.

Using your guide I was able to reset the device- which was extremely quick. Unfortunately, after setting going through the same setup as before, the range has not improved at all. I can still not reach the outdoor light.

Is there anything else I can try?

This is REALLY weird… based on your description, the distance shouldn’t be problem at all, unless you have some metallic/shielded walls :wink:

Try to add some other device to rule out specific issue with those bulbs you have, or do you have just those two bulbs ?

The best/cheapest last try would be to add some additional light/Zigbee **non-**battery powered device, which would act as router, just to see if situation improves. One of the cheapest routers are for example IKEA Tradfri - Signal repeater, TRĂ…DFRI - IKEA - not sure if you are close to any such such but ANY power socket, Zigbee, will do the job basically as well.

Also please contact Athom, I believe this range issues are not normal - describe all what you have tried and provide them with system diag log.

Btw, those _TZ3210_it1u8ahz, what are those btw ? Tuya GU10 bulbs, connected via Tuya app ? Are you on Tuya test or stable ? Somehow can’t find them even in the source code…

Hello Sulema,

Just to be sure if I understand your situation correctly:

Did you import an existing hue network (with bridge) into your homey? Do you have the Zigbee only version of the hue lamps or the Bluetooth enabled version?

Since Hue uses a mesh setup, it supposedly should just connect through closer fixtures to further away fixtures when connected through ZigBee…

I imported my exiting hue network through the hue bridge into my homey2023 and everything works fine. Try factory reset and re-install connecting to the bridge first (it asks you to pair through pressing the button on top of the bridge).