Connecting Homey to wired ethernet with USB dongle or something?

Can it be done?

My Homey randomly goes “offline”, which makes all IP-integrations fail, WAF consequently dropping through the floor.

Randomly = multiple days in a week, but sometimes no issues for weeks too.

Before you ask, my wifi coverage is fine: Great coverage with 3x Unifi APs throughout my home. Homey is the only device which randomly loses the connection, no other device has issues. In fact, when Homey Android reports it as “offline”, it is listed as “online” with good signal strength in the Unify admin app. It comes comes back online (homey app + IP integrations works) after I “re-connect” it from the Unifi admin app.

Sick and tired of troubleshooting this, it should work always, so I would like to wire it up to my ethernet and forget about the whole wifi issue.

I found a 7 year old post asking the same thing, yet no conclusion: WIRED Ethernet network support — Athom Forum Archive


1 Like

There are several topics around the usb ethernet adapter but it is still not posible as there are no drivers available for that

You have to find a solution for the network instability
Have you tried to isolate the issue fe by disabling apps on Homey. If the issue is in the network stack in Homey a wired adapter probably experience the same issue.

It’s not just a matter of drivers, it’s also a matter of Homey being powered through USB, which won’t be possible with an Ethernet dongle.

I only experience the offline issue when the memory really runs out.
In Insights you can track the memory usage of ‘ever growing’ apps. Then you can decide to remove those, or schedule an app restart every x hrs, so it’s memory use is ‘back to normal’ for the time being.
In my case it’s an “app too much” most of the time.

Non-pro with 34 apps & running fine:

But, +1 for an ethernet connection.
Even an RPi and Chromecast have one🙏

1 Like

Just being curious, Robert. You think this isn’t possible?
Device is usb powered, the ethernet connection is located in the power adapter.

I have done that with an y-cable.
My report once in the aatp channel that Homey did not correctly restart was answered by Athom with the question to remove the usb2ethernet cable that showed up in the bootlog.

But imho different drivers, cables, possibly instable power supply (even due to questionable cables) and support for a multihomed Homey probably was enough not to implement the driver although openly discussed as a hacky Friday option.


I use my chromecast in this way, with this Y cable with built in LAN adapter, and it work 100% perfectly stable on a chromecast.

Using this adapter with a micro usb to mini usb adapter like this would really be a solution imho Micro USB to Mini USB Adapter F/M - Micro USB Cables | Belgium

only the homey firmware need to support it, and if read correctly here it doesn’t ?

Correct, it doesn’t and won’t

1 Like