Can't find any IO motors with the Somfy Tahoma app


I’m a new user of the homey system.
I can add everything to my homey except for my somfy IO motors.

I have the Tahoma box and the app installed. Logged in, in the app to add my motors.
When searching the app says “no new devices found” and the only thing i can do is close the app.

Could someone help me to connect the motors to my homey?


I am trying to continue the work of the original developer and have published a new update to the Tahoma app in the community store
You could try that version to see if it finds your motors.
If not then could you capture the transactions as per the instructions found here: and I will do my best to add support.


As a workaround for now: install the ifttt ap, make the desired scenarios in the tahoma box controlling your Screens. Go to ifttt make a scenario; at the IF part choose Homey, at the THAT part choose Somfy Tahoma and choose your scenario. Give this scenario a name

In Homey, IF …THEN ifttt name off the ifttt scenario

1 Like

Hey Adrian,

First of all thanks for trying to add these motors to the app. Unfortunately the update didn’t help me find the motors on the app.
I’ve created a new issue on the github page.

There was just one part i didn’t quite get. That was the last part. You had to click on the somfy website on “my screen” but i didn’t saw any adres pop up, just a lot of fetches.

So I lowered my screens and then i did get a certain adress to pop up. That’s what i pasted on the github page.

That looks like the information I need. I will add them in as soon as I can and let you know when it’s ready.

Thank you very much! Just a random question here that has not much to do with the homey.
I wasn’t present at the time they installed everything but they said it’s only possible to move the screens up or down. Is that correct?
Even in the somfy app i can’t seem to tilt my screens.

There is no command in the data you postedt to suggest they can be tilted si I guess that is correct.

I have published a new version in the Community Store. Hopefully it will now find your blinds and control them.
Let me know how it goes.

Thank you very much! everything works great.

1 Like

If you are working on Somfy IO.
Can you please make the IO sun sensor working?
Thanks in advance!

1 Like

Fyi the IO Sunis sensor is working fIne for me… @Adrian_Rockall please do not break it for me :wink:

I also have an IO Thermis sensor that is working fine.

My IO Sunis can be found but i don’t get any readings like some other users.
So if you know how to get the readings in Homey, please tell!

I have paired them 2.5 years ago and they have been working flawlessly ever since. So maybe Somfy changed the Sunis hard-/software in the mean time which makes Sunis sensors produced after a certain date incompatible with the Tahoma app???

That could be.
In insight i don’t see my Sunis IO and in Homey’s page i only see:

I see… well I hope Adrian can fix the problem (and in the process does not break mine :wink:).

I have heard many reports of it not working but it has always worked fine for me. I use it to open and close my curtains and blinds and switch lights on and off via flows in Homey.
I seem to remember someone saying it worked until they add their io shutters. Unfortunately I don’t have any of them.
I will investigate adding some sort of logging to the app so someone that is having problems can record the data to see if gives a clue.

Did sell the io sensor because it stopped reporting lux, but did still work in the tahoma box. Tried everything. The original developer tried to get it right but this didn’t work for me.
Strangely it still works for many others, and for some doesn’t.

There is a new version of the app in the HCS that logs the data collected from Tahoma. Could you try that and send me the log so I can see if the information is coming back?


I just installed v1.6.15 from HCS and now my Sunis.IO is working correct in Homey!
Thank you!

1 Like

Sorry Adrian if i contact you unjustified, i am new in this community. I have a somfy horizontal Sun screen and tahoma calls it sunea io. I did not succeed to connect it with your tahoma app e.g. With pergola. I send you a log this morning.
Thanks for your help. B.r. Jan