Homey Community Forum

Bricked homey after update to 2.0?

Just updated to version 2.0, after that I got a red ring. Trying to get it in recovery mode, but won’t get into that (no countdown). Someone a solution or is mine bricked now?

Start with pulling the plug (ptp) for minimum 30 minutes and then try again, a 30 min ptpt and recovery might be needed if this does not help.

Tried that already. Got it unplugged for like an hour or so. Still the same result. Tried also to turn it after 3-5 seconds after plugging in, then i got first a red ring for a few seconds, followed by a purple turning ring. But it wont get out of that either (like after a hour).

If you manage to get it to purple but nothing happens then try turning it off, place it correct and then turn it on again. Purple is udating…

Yeah, i know. But how long would updating take? Can it take some hours if I’ve bad luck? And if I unplug it and turn it on again on normal way, i will get that red ring again after the start-up procedure.

Could take some hours indeed. Took an hour for me.

Hm, ok. Gonna try this the whole evening and maybe night and day for it and let you know the result. Thanks for the help so far.

2 hours running now and still purple.

Probably bricked. Just sent an email to Athom support. I had the same issue when updating to 2.0 experimental. My homey needed to be reflashed in Enschede.

Running purple means it’s still running… Red might be sign of bricked Homey…

1 Like

Purple can also mean " homey started upside down"
See https://www.athom.com/nl/ondersteuning/KB000009/

Even while running the 1.x version software I always got a red ring on every update. Just pulling the plug several times over a few hours solved the booting problem eventually, and the red ring despaired and the yellow ring came up. Homey worked fine again after that.

My experience is the red ring appears when Homey runs out of memory. I solved it by disabling some apps before updating…

Good to now. I’ll try that next time. Thanks :+1:

If you run out of things to try, you could always try changing yout power adapter plug.

That is a good one too…

Did you get any further on this topic? I’m having the same issue

For people with a red ring after waiting half an hour (both leaving Homey unpowered half an hour and keeping the red ring half an hour), after exchanging the power-adapter and after re-trying multiple times : please send a mail to support@athom.com and tell what you already tried…

Update:

I’ve contacted support by mail and they said i have to send the Homey to Athom, where they’ll have a look at it. I expect it will arrive tomorrow, so i’ve to wait for the result

1 Like

Ok, keep me updated, I’ve emailed support as well