Bold (Smart lock) integration in Homey not working

Hi All,

I’m new to Homey and love it so far! Unfortunately I also ran into a problem regarding the integration functionality. I want to integrate the Bold Smart Lock app into homey and use my Homey Pro as Hub (Bold connect) to control my Bold Smart Locks via Bluetooth when I’m not at home. So give access from another location via internet.

So far I installed the Bold app on my Homey Pro and added the Smart Locks and linked my Bold account with my Homey account. So far so good. However, Bold does not appear in my integration section on Homey pro. It is showing that the integration was successful in my Bold App, but it is not visible in Homey.

I uninstalled and installed the apps, restarted my Homey Pro and linked my Bold and Homey account multiple times. So I ran out of options and hope that this great active community is able to support me solving this issue.

You have to understand that there is a very agitated wife at home that suffers from my automation and smart home impulsiveness :blush:

Thanks in advance!


Integrations on Homey are third party assistant integrations, like Google Home and Alexa.

The Bold lock should appear in the list of devices in the Homey app.

Thanks for the quick reply Robert.

Good to know, but that does not explain why I’m not able to control the Bold Locks via Homey. It keeps saying unable to establish connection. Eventhough I was able to add these succesfully in the Homey Devices.

Any thoughts? I did see multiple topics on this same issue, but no solution.

Update: Also tried to activate via a flow via the web app, just rule out any mobile app related issues.
Same problem (See screenshot).
2023-11-23 09_49_22-Homey Pro van Guido

Same problem here, adding the lock does work. However, operating it via Homey Pro 2023 does not work. It either prompts me a connection error or busy error…The homey is just 2,5 meters away.


So maybe you should contact the developper under

Thanks for the advice, but it looks like it is a Homey related issue. All Bold app and device installations were successful. Only the Bluetooth signal from Homey Pro is not communicating with the locks. I’ve contacted the homey customer service, will let you know the outcome!

They will refer you back to the developer of the (Homey) app, which is :man_shrugging:t3:

1 Like

Update 04-12-2023: Issue resolved!

The Bold and Homey customer support weren’t able to help and referred to eachother for support. However the issue has been resolved!
I connected the Homey Pro via the (optional) ethernet adapter and that solved the issue. Not sure if this was the main reason, since it is not listed as mandatory for Bold to enable the remote lock/unlock function, but it did the trick.

So I hope others that are experiencing the same issue can confirm if this solved the issue for them as well!

Hmmm makes me think…
So, am I right when I’m saying Homey’s own wifi signal is jamming it’s own Ble signal?
(I know both use the same 2.4GHz frequency band)

In the mean time Bold support also replied to my feedback. According to them, it should also work if Homey Pro is only connected via WIFI. So no idea what was the reason it suddenly worked after I connected via the ethernet adapter. Nevertheless, I’m glad it finally works for me!