Belkin wemo support stopped?

I cannot seem to find Belkin Wemo app anymore. Has support for them stopped or what is going on?
Who can you contact from Athom to get an answer to that?

Try the regular contact form:

Have you gotten an answer?

That would be really fast, wouldn’t it? Maybe someone could install

through the CLI and see if it works?

I have the app installed (from ages ago) it was still working last time I checked.

Admittedly mine is hooked up to a electric bed warmer and its the middle of summer here.

1 Like

I wrote to support, but haven’t heard anything yet. Nothing was working on my Homey this morning (exclamation mark on all devices) and an error was shown when i tried to restart the apps saying something like “Spawn error Enomem” or something like that.

I tried to restart Homey from the app, without luck, so I uninstalled the original Wemo app that I had, and pulled the power plug on the Homey and restarted it that way.
That seemed to make my Homey work again with the other devices, but for now I have no support for my 5 wemo switches.

I don’t know how to sideload apps from Github onto my Homey. How does that work? I’d love to test the app from Github :slight_smile:

1 Like

Reply from Athom regarding Wemo support:


Thank you for your e-mail.

We have removed the Belkin WeMo app from our Appstore due to the fact that there were multiple issues with this integration and this app had a low install count (these issues were caused by a change on the side of Belkin).

This is why we have decided to not support Belkin WeMo for now. This could change in the future, but right now our priorities withhold us from supporting these products.

Let me know if you have any other questions.

Best Regards,


Athom Support

So looks like I’ll have to try the Github thingy :pensive:

Luckily I have the app installed from before, but I would not have purchased the homey if I didn’t see all my devices in the app store before purchasing.

They should be adding stuff, not removing stuff.

I have a wemo insight, which is still working correctly.

Mine is crashing quite often


An insight? Do you have a model number?

I have 2 belkin sockets an it would be nice if i can use the app again. However every couple of hours the app crashes. Does anyone has a solution for this? Is it for example a solution to rewrite the github version so we can use it again?

Was this not an @Athom app? Not sure why it’s died

I’m pretty sure it was yeah:man_shrugging:

Just a follow up on this topic. I sideloaded the wemo app and it works again. Thank you for your help :+1::grin:

Mine crashes every day :frowning:

I haven’t had any trouble with mine

Mine has been working until the recent couple of weeks.
Now crashes and locks up the Homey. When I disable it,
Homey behaves. When I enable it, Homey is no longer available,
and I have to restart him to get control again, enough time to
disable the app. I tried side loading again, but same results.
Any new news?

Do you have any instructions on how to do this?