[Abandoned] deCONZ

As I am super unhappy with athom (and @Emile in person) I decided to stop any work on this app and removed it from the store. Sorry folks, if you wan’t to disuss this you can do so with athom, I won’t be available for any homey related support.


Hi! I found this addon allready in the appstore…

Currently, I’m using this one: https://github.com/fantomnotabene/HomeyCONZ

Is there a way to migrate my devices and flows to this new app?

Hey @Marcel_Visser

Unfortunately this is not possible as there is quiet a lot that has changed. But it is guaranteed that further updates do not break your installation. Regard this app as an entirely different app than the previous one that is not in the store

Allright thanks!

In that case, it’s a one time lot of work… But I think it’s worth it👍

1 Like

Allright. In 21 minutes, I added all of my 70 zigbee devices to the new app. :+1:

Now… Fixing all my flows…

I think it will take a bit more time than 21 minutes… :stuck_out_tongue_winking_eye::stuck_out_tongue_winking_eye:

Hope it’s worth it!

Hmmmm, the app keeps crashing! I’m not able to control any single light bulb :confused:

So, something is going wrong… Any idea what to do?

I will try to make a bug report…

EDIT: When I restart the app, and I’m trying to turn on a bulb the app crashes immediately.

And than the message accours: driver_unavailible. Any idea?

Motion and contact sensors are working fine… (before the app is crashing)

EDIT2: I started the app using CLI using “Athom app run” and this is what I’m getting as soon as I’m trying to turn on a bulb or power socket. Before that everything looks fine:

callback(null, data)

TypeError: callback is not a function
at IncomingMessage. (/nbhttp.js:88:4)
at IncomingMessage.emit (events.js:323:22)
at endReadableNT (_stream_readable.js:1204:12)
at processTicksAndRejections (internal/process/task_queues.js:84:21)

— INFO: de.dresden-elektronik.deconz has been killed —

Uff, to bad sorry!

But I’ve got you, I found the bug and fixed it, and update for the app already has been submitted. If you are in an urge, the latest version in my repo also contains the fix.

Hope that resolves your problem
Edit: you might also install it directly from here: https://homey.app/de-ch/app/de.dresden-elektronik.deconz/deCONZ/test/

1 Like

Great! Thanks for the quick fix! Working fine! :+1::grinning:

Glad it works! :wink:

I can’t seem to add my devices in Homey which are available in de deCONZ interface. When I search for my motion sensor or temperature/humidity sensor, it times out.

The devices are connected to deCONZ, and I can see them in a HomeAssistant interface working as well. I would love to have them working in Homey, any clues on how to solve this?

Can you please check the following:

  • do you have the latest deconz installed?
  • in the homey app, go to the configuration, click “show advanced” and verify that all entries are correct
  • ensure that homey can access your deconz
  • if all that does not work, try to call this in the browser: http://[ip adress]:[port]/api/[access token]/ -> does this give a response?
  • Yes, I am running latest version of deCONZ (in HomeAssistant) 5.3.2
  • In the Homey app, the entries are correct
  • How do I test this? (it was able to find the deCONZ host by using discover)
  • In my browser and in Postman, I get normal response on the suggested call.

I found that v1.3.1 of the Homey app solved it. (That one would only install after 3 tries, no idea why). Thanks!

If I select discover and authenticate, DeConz on my Home Assistant platform is recognised. When trying to add the devices I have in DeConz, I find none and am required to configure the App settings.

The IP shown in the configuration page is not the one I would expect.

What am I doing wrong?

Running v1. 3.0

Not entering the correct IP address on the configuration page?

This was solved when I installed v1.3.1

Just to be sure, where can I download the latest version for a CLI?
(here I see 1.3.0 only)

Thank you!

Not sure what you are asking Robert

In HA and the DeConz setting I start “authenticate app”.
In Homey DeConz configuration the discover and authenticate returns with “succesfully authenticated gateway”. But when I look at the IP in advanced setting, I do not see the IP adres of my HA install. A ‘whois’ shows a adres in California…

And you can’t change the IP-address to the one of your HA install? When you open https://phoscon.de/discover in a regular browser, what do you get back?