Beacon - An app for presence detection using BLE beacons

Test version + 30/30 sec + verificationoutsiderange = 15 seems to do the trick. No false detections inside/outside range in 18 hrs.
Thanks for the swift action.
Regards,
Paul

2 Likes

@Koktail @Piero_F Is there any chance that Apple’s new Airtags are going to work with the Beacon app in the (near) future?

I use a flow with an doorsensor on a timer:

1 Like

Hello @Nox,
What you ask for does not depend on our will or our ability. To use Airtags that advertises an encrypted ID, Apple must provide developers with a resolver service (a cloud service that takes as input the encrypted content of the Bluetooth advertisement and returns the ID of a registered Airtag). Does Apple offer this service? I don’t think so. What I understand is that Apple currently offer a cloud service for tracking your stuff (Same as Tile®).
Anyway, I’m currently testing a beacon device with similar features (size, shape, case protection degree). I’ll let you know within 10 days.

2 Likes

30, 30,1,11 gave a few false positives the last 2 days. So confirmed

Hi @Piero_F, I fully realised upfront this wasn’t depending on your will or ability. I asked mainly because I didn’t know if the AirTag provided (sends out) the necessary information for you guys to get it working. The only thing I see (with my n00b eyes) is that it is a similar device to Tile Pro which does work. I thought that the AirTag would send out some BLE signal (so it can be found with iPhone when close enough) that Beacon app could pick up and that it “only” needed to be added to the app as ‘compatible device’ to get this working. But obviously there is more to it than that. I will crawl back I’m my n00b cave so you can continue your work :rofl: :+1:

I have installed the Itag bluetooth tracker and am testing it. 1st day went well. setting: 30,30,1.15

1 Like

After a PTP and fresh batteries for both my beacons, I am now at 32,25,1,6 without false aways.

1 Like

Thx! I copied your settings, I still had a few false positives, even when 1 beacon lies next to Homey

No false positive for 4 days in a row. works fine

Same here, it’s literally 10 centimetres away from homey. Many false away notifications. Any recommendations? Maybe PTP? Different settings?

There is bug in the BLE binding: BLE discovery gives 0 advertisements · Issue #202 · athombv/homey-apps-sdk-issues · GitHub

2 Likes

@ my place my beacons aren’t detected anymore with your settings…
I’m getting the idea the update interval can’t be higher than 29, maybe 30s

I just adjusted it to 29,28,1,6 and all beacons were detected immediately.

Strange, I would say using an interval shorter than the 30s timeout would result in 1 in every 2 auto searches to be empty?

Because of the new BLE 30s cache, you mean?
That seems logical. I don’t see why detection stops when using intervals > 30s.
But that has to be connected with the reported bug.
BUT, the bug is the other way round🤔

Same here with 2018 Tile Pro for my presence detection. Every hour or so i will be sitting in the dark for a few seconds because the boss (me) has left the building according Homey. A few seconds later lights atre switched back on, very annpying

@El_Maestro You could add a condition to prevent “false positives”: the push acknowledgement card.
It sends a push message to a user.
It will ask for a confirmation if you want to set your home to ‘Away’ or not.

Thank Peter for your solution, but i find it not so convenient to work this way. I installed 601 firmware yesterday to find out my Tile Pro is going crazy. Today about 20 notifications (home/away) in 16 hours.
I think it is better to deactivate the app and (un)check the checkbox “Home” manually under my avatar in the homey-app on my phone.
Ofcourse it is a temporary solution until the problems are solved in the homey firmware/beacon app.
It worked perfectly before 601, i was detected by homey at a range of 80 meters from my house on arrival (walking/bicycle)

My thoughts exactly. Really looking forward to seeing a fix. Used to work fine. Now getting false alarms several times a day.

Try complaining on the GitHub issue that is the source of this behaviour.

1 Like