Assoziationen zwischen Z-Wave Geräten einrichten

Der Ein oder Andere fragt sich vielleicht was Assoziationen sind.

Mit Assoziationen lassen sich Z-Wave Geräte gegenseitig steuern und zwar auch dann wenn die Zentrale (also Homey) streikt. Damit lassen sich z.B. folgende Sachen realisieren.

  • Bewegungsmelder Schaltet einen Plug oder UP-Modul
  • Fibaro Dimmer Schalter an S2 schaltet Plug oder ein UP-Modul S1 oder S2
  • Z-Wave Fernbedienungen schalten Plugs, UP-Module
  • KeyFob als Fernbedienung fürs Garagentor
  • etc.

Diese Kommunikation ist meistens schneller, da der Umweg über das Gateway entfällt.

Wie werden Assoziationen eingerichtet.

Jedes Gerät hat so genannte Gruppen an welch er den Status sendet, bei den meisten Geräten ist die Gruppe 1 die so genannte Lifeline. Und eben weitere wie hier am Bsp. eines Fibaro Double Switches 2

Möchten wir nun z.B. beim betätigen des Schalters angeschlossen an S2 einen Z-Wave Plug schalten,
müssen wir die Gruppe 4 bearbeiten.

Die Zuweisung der Assoziationen erfolgt über die Node-ID, der Plug soll die Node-Id 20 haben,
Somit tragen wir in die Gruppe 4, 20 ein und speichern.

Sollen dagegen einzelne Instanzen angesteuert werden, wie z.B. der S2 eines Double Switches, muss die Eingabe folgendermassen ansehen: 22.2 (22 = Node ID, 2 = 2’te Instanz also S2) für S1 dementsprechend 22.1 (edit: komischerweise muss hier anstatt 22.1 nur 22 eingegeben werden)

Um Assoziationen auf einzelne Instanzen legen zu können muss das Gerät Multichannel unterstützen.
Ob ein Gerät Multichannel unterstützt erkennt ihr daran ob nach Eingabe und Speicher von x.y die Zahl nach dem Punkt übernommen wurde oder nicht. Oder ihr könnt es auch der Geräte-Anleitung entnehmen.

Achten sollte man noch darauf wie die Geräte Inkludiert wurden Secure oder Unsecure.
Standardmäßig kommunizieren Secure Inkludierte Geräte auch Secure mit den Assoziatierten Geräten.
sollte das zu steuernde Gerät aber unsecure Inkludiert worden sein muss die Kommunikation auch unsecure erfolgen. Am Bsp. Fibaro Double Switch 2, muss der Parameter 27 auf 0 gestellt werden.

Edit: Setzt ihr Assoziationen bei batteriebetriebenen Geräten, wie z.B. KeyFob, Wallmote, Wallc-s, Bewegungsmeldern, Tür/Fensterkontakte, etc. müssen die Geräte manuell aufgeweckt werden damit die Assoziationen im Gerät auch gespeichert werden können.

17 Likes

Danke für diese Ausführliche und gute Erklärung, echt super.

1 Like

Super! Mit diesem Thema wollte ich mich eh schon mal auseinandersetzen. Habe es immer wieder verschoben. Jetzt ist mir einiges klar, danke!

1 Like

Danke für die ausführliche Erklärung @Osorkon!
Top!

1 Like

Kann man beim inkludieren zwischen Secure undx Unsecure wählen?

. Es gibt aber Geräte die man Secure oder Unsecure inkludieren kann, das kannst der Geräteanleitung entnehmen.
Dann gibt es noch Geräte die nur Unsecure inkludiert werden können weil Secure nicht unterstützt wird. Bei Fibaro sind es z.B. Die Gen3 Modelle.

Edit:
Geräte Unsecure Inkludieren geht doch! :grinning:

Danke @Osorkon. Jetzt laufen die Assoziationen bei mir. :grinning:

2 Likes

Das mit den Assoziationen hab ich noch nie auf die Reihe bekommen :neutral_face: …habe nun wieder einen Anlauf genommen und bin wieder gescheitert :stuck_out_tongue:

Ganz simpel: Habe einen Aeotec Multisensor 6, der soll eine Lampe anmachen (Fibaro Switch 2 - ID39). Der Multisensor hat nur eine Assoziationsgruppe (1, Lifeline). So habe ich das Fibaro Switch Modul dort hinzugefügt (1, 39). Der Multisensor ist am Strom, muss also nicht aufgeweckt werden. Funktioniert trotzdem nicht.

Was mache ich falsch? Oder gehts mit dem Multisensor 6 einfach nicht? Danke

Sind beide Geräte Secure oder Unsecure inkludiert?!

multisensor = unsecure
fibaro switch = secure

Soweit ich weiß, müssen beide gleich inkludiert sein. Also entweder Secure oder beide unsecure.

Bin mir aber nicht sicher. @Osorkon?

Da wird wohl das Problem sein. Ein Unsecure Gerät versucht ein Secure Gerät zu schalten!!
Secure zu Unsecure geht , wenn Mann die Kommunikation (Assoziationen) am Secure Gerät auf Unsecure per Parameter ändert.

Entweder versuchen den Fibaro Double Switch Unsecure anzumelden (leider kann man am homey nicht wählen ob Secure oder Unsecure)

Oder einen BM verwenden der Secure unterstützt.

Edit: Kann man doch! :grinning:

2 Likes

Danke - werde das mal versuchen. Also denkt ihr dass es sonst gehen müsste mit dem Multisensor obwohl dieser nur eine Assoziationsgruppe hat (Lifeline)?

Sagt mal, wo finde ich denn diese Einstellungen :slightly_smiling_face:

in den erweiterten Geräteeinstellungen

Dann habe ich das Falsche gesucht, wollte das Thema, wo man ZWAVE Geräten sagen konnte, das sie über dieses Gerät zum Homey gehen sollen.

Hallo Community,

mal eine vermutlich unnötige Frage aber kann ich in den Assoziationen auch ZigbeeNodesIDs ansprechen? Die Antwort ist anzunehmenderweise “nein”, ich hätte da dennoch die Hoffnung, dass Homey zwischen den Protokollen vermittelt und einen Befehl aus einer ONOFF Assoziation es Zwave Protokolls als ONOFF Befehl an Zigbee weitergibt.

Danke euch fürs Schlauer machen.
Andreas

Das hast aus richtig erkannt.

Das geht dann über Flows und hat nichts mit Assoziationen zu tun. ZigBee BM steuert eine Zwave Plug/UM usw. Somit kann jedes Gerät unabhängig vom Protokoll ein anderes Steuern/Schalten der Vermittler zwischen den Geräten ist dann der homey.

1 Like

Hallo an die ZWave Assoziation-Profis,

ich dachte ja, dass ich verstanden habe wie das mit den Assoziationen funktioniert, ich gebe auch zu, dass ich Teile meiner Geräte auf diese Art und Weise erfolgreich miteinander sprechen lasse, aber es gibt aktuell eine Konstellation die mich zum Verzweifeln bringt.

Ich bekomme es nicht hin, dass ein Fibaro MotionSensor mit einem Fibaro WallPlug spricht.
Zugegeben, der Sensor ist naturgemäß als Unsecure an Homey angemeldet, während der WallPlug Secure läuft. Das die Konstellation in die Hose geht habe ich auch gelernt. Aber in den Parametern des Motionsensors lässt sich einstellen, dass die Werte der Gruppen 2 und/oder 3 als Secure übermittelt werden, das ist in meinem Fall auch so eingestellt. Und trotzdem schaltet mein Plug nicht bei Bewegung.

Dank der überaus aktiven Community rund um Homey, habe ich auch herausgefunden, dass man ein Secure-Gerät über den Parameter 27 auf Unsecure umstellen kann. Also habe ich meinem Plug über den Roh-Konfigurationsparamter erklärt, dass ich den Parameter 27, mit der länge von 1byte auf den Wert 0 stellen will und 27,1,0 gespeichert. Abgesehen davon, dass unter “Sicher” immer noch ein Haken angezeigt wird, hatte der Versuch auch keinen Erfolg gebracht.

Und eine Assoziation über die Gruppe 4 hatte bislang auch nicht den gewünschten Effekt.

Könnt ihr mir erklären was ich übersehe oder falsch mache?

Danke euch schon jetzt vielmals für eure Hilfe.
Andreas

Das einfachste wäre es Deinen Plug unsecure zu inkludieren. Das erreichst Du, in dem Du beim inkludieren den Walli Switch als Gerät auswählst anstatt den Wall Plug.

Ich bekomme es auch nicht hin einen Dimmer 2 per Assoziationen zu schalten, solange dieser Secure inkludiert ist. Sobald ich diesen Unsecure inkludiere läuft alles wie geschmiert. :grinning: