Aqara temp sensors and Google Home

Out of ideas here.

Adding sensors to Homey works fine, not working asking Google home
Adding sensors to Aqara Hub M2 and then to Google home. Works asking about temp, no show in Homey

I want the temp sensors showing in the homey app but also be possible to ask Google home the temperature

I created virtual temperature sensors for that, then they’ll show up in Ghome.

This way I “feed” them with the original temperature sensor values:

Ghome:

Just creating av virtual temp device that one should show up in GHome after update right?

I never finds it

Is it a sensor device? Did you also add it to your favorites? And did you then do a Synchronize?

Mm a virtual device.
Have only device and mode to choose from when creating.

Not added in favorites but tried to sync i GHome multiple times

Better use the App Virtual Devices App for Homey | Homey
Create a temperature sensor device, and add it to your favorites.

I’m not sure if a temperature sensor does the trick.
Try a virtual thermostat instead; That should show up in Ghome

2 Likes

Ok adding a termostat instead adds it in Google.

But Icannot get the flow working.

I did this:
Added tje virtual button as per Peter_Kawa nice description above.

Added flow like this
The aqara sensor and “when temp change”

Then……

First tag Temperatur is the virtual sensors temp value the second tag Temperatur is the aqara sensors temperatur tag.

Guess I am doing it wrong somewhere.

Compare this:
image

With this:

2 Likes

I knew I did something wrong :grinning:

Tnx now its working.
Aqara temp in Homey and I can ask Google Home

2 Likes

Hello

Sorry to bother you, but when you ask to Google Home, it tells you the current temperature ?
I managed to add it (with difficulties, since the sensors can’t be added to Google Home and I can just add the thermostat) and when I ask the temperature, it tells me “Temperature (device) is in heating mode”. I can see the value on the screen on Google home, but Google Home doesn’t tell me what’s the temperature

Yes, it tells the current temperature.

Virtual thermostat:

The question and answer:


“Het is nu 2 graden” means “it is 2 degrees now”

.

That’s odd, can’t you turn heating mode off somehow?

Hello,
Thank you for your answer :slight_smile:

I retry just after testing the flow, and it says the temperature (but it’s the default one, not the one updated)
After the update (I write the message when I try to test) I have the message :

“The heater is configured on 23.5 degrees with a current temp of 27.5 degrees”.
So, the temperature is now said by Google, but I would like to avoid it says “The heater is configured on 23.5 degrees”
I followed your screen above to set up that, by checking Thermostat + target temperature and Measure temperature (I just put a higher maximum given the current temperatures here) and the command is the same (If I don’t check the “target temperature” I can’t have the device in Google Home anyway)

For reference I send you the shared

I retried to create the exact same with the same flow and all and I’m still struck to heating mode… I did another one by adding the auto/heating/cold/off check and when I select the “Disable” for the thermostat it says ““Device” is turned off and the current temperature is XX degrees”

My comment is a bit fuzzy since I did the test while I write, sorry :slight_smile:

Hi Anders,
I ended up the same way as you with two temperature tags. I don’t understand robertkleps solution. Which one of the tags did you remove? Currently I’m stuck at the “Then” screen and can’t figure out in which field I should type, “sensor” or “value”.

It seems as it’s not possible to save the flow card without filling in both of these fields.

@ Sensor: enter the sensor’s capability yourself: in your case it is most probably measure_temperature
@ Value: Select the tag which holds the temperature value you want to use.

Screenshot from 2022-09-20 19-15-28

Thanks Peter_Kawa for quick reply. So now my flow card looks like below. The temperature tag is from my Aqara sensor. Unfortunately this doesn’t work. The Aqara app in Homey reports correctly, but the Virtual Devices app gets no values. I must be missing something.

You probably/maybe have to round by 0.5 like this:
{{round([Temperatur]*2)/2}}

Also, maybe the sensor is called target_temperature
How does your virtual device look?
The ring is target_temperature, and ‘current temperature’ is measure_temperature

Thanks Peter_Kawa for your patience. I tried your latest suggestions in different combinations and I’m sorry to say that neither one worked. My virtual device is set exactly the same as suggested in your post #7.

However - before I nearly gave up, I deleted and reinstalled both the Aqara and the Virtual Device app, and then reconnected my Aqara sensor again with the previous recommended settings. And voila – without explanation, now it works! At least “Current Temperature” is showing in Virtual Device App and reporting to GH. I don’t know if it’s possible to get the Target Temperature ring to follow, or this is just for settings when using a thermostat.

At the moment my target setting ring can only be controlled manually and must be set to 0 or lowest value, if I wish Google Home to report current temperature with voice. Otherwise GH will just report that sensor (“Thermostat”) is heating or cooling to reach target temperature.

This solution works ok for me, but if there is a way to get the ring to show current temperature it would be nice.

YW. I’m sorry, the target temperature is a separate card “set the temperatuere”
This one holds only 0.5 rounded values, so we need a logic variable as in between step
I hope this screenvid solves all issues:
Peek 2022-09-21 22-18

It seems as the card “The target temperature changed” is not listed under my Aqara sensor. Neither do I understand how to create the Logic card. Since I am new to Homey, I think I need to learn more about how to create these cards. I wish there were more step-by-step tutorials somewhere. This was probably too advanced for a beginner :blush: