Aqara temp not changing

I’ve got one behind a glass door fridge as you can see from the two flat-lines. It can loose its connection for days … then be fine again for a couple of weeks.

For their price thought they are hard to beat.

Same problem here, two sensors out for 3 days now.

@TedTolboom Maybelline something changed in the last update of the app?

Did you press the button once on them?

For me the issue is not solved yet… I reinstalled them (had to be close to Homey)… but still some of them are not updating…

1 Like

After reading this topic I went to check if my sensors were working correctly. The sensors in house are working just fine, also the one in the fridge. I did have a sensor outside in the chicken coop which apparently lost its connection since 12 days. I pressed the button on the sensor and it reconnected again.

As you can see in the image the work fine at first… then they drop out… the only working one is placed in the room above the Homey unit… then the others are placed in other rooms on the same floor… about 4-6m between them!


In my case the sensor is located less then 8 meters away with only a glass door in a open field. Only thing i can imaging of rangeissue is the interference of the wifi modem. :frowning: for me its useless this way

Perhaps there should be a way to downgrade version?

I get the same issues with mine,
I have two next to each other… about 10 cm apart, one on the end of its range maybe 8m from Homey, works ok ish, about 90% of the time. the other routing through a power switch unit 3m away, updates once every few days.
beyond frustrating as i want to set up rules for cooling, heating and fan control but with junk data in, there is no point.

I now have the problem that all temperature sensors no longer update data. A window contact also does not report anything.

1 Like

Tip: no need unstick the sensor, rotate for pull apart the sensor. Don’t waste tape.


Somebody found a fix for this? Mine just updates when i push the button?

It doesn’t seem to exist a fix for that. The issue is well known since many months.

Something new here? I have the same problem with two devices, which are newly installed.

I experienced this. Then moved the sensor. Then it worked fine. It was probably in a dead-spot.

Any news on this issue?? In still having this problem with all my aqara sensors. Even when i put Them Next to Homey. All my other zigbee devices (IKEA lamps) work great, even the ones on the furthest room on the 1st floor.

In my case it was a dead spot. The same sensor is now further away in a different building and works fine. Maybe move the sensor?

Have you replaced the battery (even though it might seem full)?

I had the same problem and didn’t think of the battery first because it showed as full in Homey. Even checking with a multimeter showed it still delivered 2.8V.

But after replacing the battery the problems were gone…

I had this a while back, first I tried pushing the button to update. After that failed I tried removing them and re-adding them but that messed up my flows.
Now I just add the device again while not removed first.
It says its a duplicate device but is somehow waken up with the flows still intact.

1 Like

I’m also having this problem. Last time two sensors seemed to start working again when I pushed the “interview” button on the homey-dev zigbee page. Doens’t help now.
Now I have one again not reporting, it’s 30cm away from Homey. Pressing the button fixed it this time.