[App] Secuyou Smart Lock

Thanks for quick reply.

Good idea. Though, I turned off BT and tried the flow that locks the door 10 sec after handle is closed but it didn’t work.

OK. We will try to test the flow and revert back to you soon.

We have added a new trigger flow card ‘Handle was closed’ to the Homey app. Add this trigger and the lock will lock every time you closed the handle.
New app version is called 2.0.3.

Thank you, saw you answer now. I will try this asap.

Hm, didn’t manage to try. Now when changing batteries no flows are working anymore.

The Secuyou lock is working for me - but only partially, unfortunately. When I use the handle or lock/unlock on the lock itself, I’m able to see the lock and handle status updates in real time in the Homey app. I also see the yellow lock icon in Homey.

When I click the lock and unlock buttons in the Homey app they change as if they’re locked/unlocked (as you would expected if it was actually locking/unlocking), but nothing happens on the lock itself.

I’ve tried restarting Homey, resetting the lock, removing and re-adding the lock to the Secuyou app and Homey, but no luck (!), unfortunately.

Any ideas on how this can be resolved?

Bonus info: Firmware version 6, lock hardware version 2.1
Also, even with the handle sensor option disabled in the Secuyou app, I still get handle status updates in the Homey app.

We can see from your test report that the HOMEY never finishes the initial discovery of Bluetooth characteristics and after a while Bluetooth times out.
Could you please tell us what you did to make it NOT work?

Hi Aandersen,
Also we can see from the report that you have forwarded per mail that the LOCK goes into BLOCKING mode. You will likely see a blinking red LED on the LOCK. This is because the pin code is wrong.
If you take out the batteries from the LOCK and re-insert the batteries then the LOCK exits BLOCKING mode and is ready to be used again.
In this case you should delete the LOCK from the HOMEY app and add again with the correct pin code.
Also please check that the Secuyou Smart Lock app works with the pin code.

ATTENTION to all Secuyou Homey users:
The Secuyou HOMEY App is not storing the pin code correctly. We are about to make corrections to the Homey app.

We apologize for the inconvience!

Until we have fixed the issue you need to delete the lock from the Homey and add it again when HOMEY Pro is power cycled.

HOMEY APP has now been updated.

Now the HOMEY APP is storing the pin code correctly.

New version is No 2.0.4.

We have just released a new version 2.0.5.
This new version has no new features and it does not improve functionality.
So if you are still running verison 2.0.4 you will still experience a fine working app.

After the latest update (which fixes the pin being stored incorrectly), I’m now finally able to use the lock in Homey for both viewing the current state as well as locking and unlocking - thanks for getting that resolved!

1 Like

We have just released a new version 2.1.0.

This version enables an attempt to lock when handle sensor is off.
So in case the handle sensor is turned off then HOMEY will attempt to lock.
If the handle is open then HOMEY will report back an UNLOCKED position, which you can use in your automation to test if command succeeds.
When you close the handle then Secuyou Smart Lock will go to unlocked position. One more locking command will lock the Secuyou Smart Lock.

Remember that turning off the handle sensor cannot be done through the HOMEY app. Please use the Secuyou Smart Lock app.

So, I got my Secuyou lock today.
Had some issue with updating firmware but didnt work from ios but Android device.
Everything works fine from the SecuYou mobile app, but the Homey integration is not working.

Firmware version on lock is 6 and hw version 22.
Homey version is 8.0.3

I can connect the lock to Homey as device from the Homey mobile app, not the Homey web app (Network time out when searching).

The device is added but it wont change any status nor does it work to send commands lock/unlock.

So far I tried:

  • Moving Homey close to the lock, 2m
  • Reinstallaing the Homey Secuyou app
  • Reset lock
  • And multiple reboots of Homey.

Any ideas what I can do more?
The Homey integration is the reason why I bought this lock and it seems to work fine for others


Hi Anders,

You should try to rename your lock to something else than ‘Secuyou Smart Lock’. For example rename it to ‘Altandor’.
Then search for the device in Homey app. You should connect to ‘Altandor’ and enter the correct pin code.

All the best

yepp did that too. It will connect in Homey and all seems fine but it feels that it doesnt have any communication after that.

Hi Anders,
send us a report and we will take a look at it.
Thank you in advance.
Best regards

Hi Anders,
I have same issue. The lock works sometime and sometimes not. The App has to be restarted sometimes, due to a triangle red symbol - shows up in the icon.
Home Pro sends signals, and I get respond from the lock, but almost everytime, nothing happens.
Hopefully this is a software issue, or incompatibility with other apps on my Homey (63 apps)


Please send us a diagnostic report and we will have a look at it and revert to you.
All the best
Secuyou support

Hei jeg har installert SecuYou sin app på 3 telefoner og alle er satt til Homelock av

Jeg har to flow som stenger eller åpner døren.

Begge flow låser opp eller låser, for deretter å gå tilbake til låst eller opplåst - dette tar bare 1 sek.

Hvis jeg åpner døren når det lyser grønt, forblir den åpen til jeg låser den.

Dette virker noe underlig.

Mulig dette er feilen:

Når jeg betjener icon og velger unlock (hvis døren er låst) så låser den opp. Når jeg trykker en gang til på unlock så låser den.

Disse knappene kan ikke være toggle, men kun on og off.

Ta kontakt hvis det er noe jeg kan bistå med.

Mvh. Helge