Nuki 3.0 Pro does not work within Homey?

Hi all,
I’ve just got my hands on the new Nuki 3.0 Pro; wit build in WiFi. Of course I immediately tied to include the Nuki in Homey, using the dedicated Nuki app.

Unfortunately the new 3.0 version does not seem to work (yet). The app has been updated 5 months ago, while the new Nuki just has been released.

Could anyone help me out with making this smart lock even smarter with Homey? Thanks!


1 Like

Contact the app developer.

There’s an alternative Nuki direct app also. (Developer) info here:

You need the test version of the app:


Thanks so much for your reply! I’ve tested the experimental app. And it really is, experimental :nerd_face::sweat_smile:. At first, everything seems to be working like it should. But after a certain amount of time, the Nikki app isn’t able to find the device anymore. Error: Token cannot be refreshed. When I try, try to fix, Homey leads me to the Nuki web app to log me in again. Then it works again, for a while.

I tried to reach out to the developers, but it seems hard to contact them. Anybody here who could help me out or reach out to the developers?

Thanks, and all the best for 2022!

On this side is explained how to get in contact with Athom (developer of the app):

How did you knew there was a beta app? :smiley:
Can’t wait for the official app, I also want to add the Nuki 3.0

When someone writes that a “new” device is not supported, the first place I look is the app store. To check if there is a test version, you just have to type /test after the URL. In this case, however, I read it on Slack.

A very comfortable solution is to use the App Version Checker app from @Adrian_Rockall (thanks for that). This app checks once a day if there is a new app version (final and test) available from the apps you have installed on Homey. But this app is only available in the community app store.

1 Like

I’m wondering why you ask this question and why you opened this thread. Wasn’t it you who was already in contact with Athom (Emile) on Slack?

Maybe it is because of the holidays why Emile has not reported back. Still, I would make an official request (as mentioned above), since Slack is probably not the official way to track bugs.

Hmm no, bot even familiar with Slack. Never heard of… But I can see that others experience the same issues, so it will probably will be addressed soon. This thread can be closed. Thanks all!

Okay, so it wasn’t you, sorry… :joy:

1 Like

Hoe did you get the 3.0 Pro.
I can’t fine Him.

Actually sold out.


Met vriendelijke groet,
Marcel Markes

Hello Yann,

Because this is a different topic and the original thread has already been solved, I suggest opening a new thread.

Hi Fantross,
Ok i’m gonna do this.


Hmm almost a year later and the Nuki app hasn’t updated yet. The experimental version does not work outside of my WiFi network anymore.

The test app as mentioned above seems not available anymore?

Did you try the community app alr? It also uses local connection instead of cloud

Correct. When the test app passes the tests, it’ll become the stable version.
When you enter /test after the app url, and test version does not appear —> no test version available.

I have installed the official Nuki app from Athom (version 2.4.0). The Nuki 3.0 Pro does exactly what it should. However, the Nuki Bridge is still needed. But this is not dependent on Athom, but on Nuki itself.

It always worked without a bridge. The pro has WiFi build in, so there is no need for a bridge…?