[APP][Pro] Xiaomi Miija (Temperature and Humidity)

@robertklep Hi Robert, I have two of those devices (LYWSD03MMC) which I flashed to the ZB firmware (one using the Git guidance, 2nd one using your link provided above). None of them however connects to my 2019 Homey Pro, not only via the app but it simply looks like Homey simply does not see the device (as it would be added as a unknown ZB device, otherwise). So it does not give any message, just stays on the discovery page looking out for available device(s).

Both however connect just fine to the Home Assistant (with the SkyConnect stick), which I pilot next to my Homey environment. So I believe that kinda confirms I did all the steps well, the device is on ZB firmware, was in the pairing mode (after shorting the contacts).

Do you have any idea what may be the reason Homey Pro does not see/connect these, please? I was hoping for that to work, as my primary smart home still runs on Homey and I was planning using those at my parents too (also with Homey Pro).

Sounds like an issue with your Homey. You can try adding it as a generic Zigbee device to see if you can pair it via that route (when the device gets paired it will automatically be assigned to the correct app).

@robertklep I already tried that yesterday, as I was thinking it might not link that to the correct device id within the app, but neither that worked. Are you aware of anyone pairing this device successfully on Homey Pro 2019, or have you only had a chance to test with 2023 HP? Just thinking if that (for whatever odd reason) might be the cause.

I can (and will) potentially test that with the 2nd Homey Pro (as well 2019, once I visit my parents).

Just tried with mine:

One thing that may help is to remove the battery for 5 seconds or so, insert it again, then short the GND and Reset pins.

I must say it become one of the most reliable temperature / humidity sensor in my smart home.
Well done Robert !

I guess Homey can have reliable Zigbee, at least with some devices :stuck_out_tongue_winking_eye:

1 Like

My Temperature sensor is only added as generic zugbee device, also when i add it via the Miija App, please help

What does it look like at Homey Developer Tools? Specifically “Manufacturer” and “ModelID”.

Xiaomi LYWSD03MMC-z

Is the “-z” really a part of the ModelID? Because if it is, the Miija app won’t recognise it.

Which version of firmware is it running?

IT is called Xiaomi LYWSD0MMC-z

Tank You for Your help

it is the ZIGBEE firmware from the Telink Flasher website

Can you provide a link to the specific firmware file that you used?

unfortunally Telink is ot finding it anymore (think because it is now Zigbee). Firmware should be GitHub - pvvx/ZigbeeTLc: Custom firmware for Zigbee 3.0 IoT devices on the TLSR825x chip

I issued a pull request to add support for this firmware (which assumes the cluster definition is still the same, at the moment I can’t flash my own device to test).


Hi! I flashed my lywsd03mmc to the ZigBee firmware. Afterwards, I am not able to use the TelinkMiFlasher to connect to the thermometer again. Is this correct? I have yet to receive my Homey, so I can’t add it to Homey yet :slight_smile:

Yes, the flasher works over BLE, and by flashing the Zigbee firmware the BLE-part gets removed.

There are ways to revert back to BLE, either by Zigbee OTA flashing (not supported by Homey, but most other Zigbee implementations do) or by TTL flashing (soldering wires to the sensor’s PCB and using a USB-to-serial device).

There’s also an experimental Zigbee+BLE (combined) firmware: GitHub - pvvx/BZdevice: Custom firmware for devices on the TLSR825x chip operating simultaneously in Zigbee 3 and Bluetooth LE

1 Like

Thanks, that does make sense. I am having some trouble choosing firmware though; there are so many!

For example, I have found these:

Which one should I choose for the Homey app?

@Fisk, in this link you shall find all what you need.

Mine are running the devbis firmware. I assume that the pvvx firmware (which is easier to install because it doesn’t require an intermediate firmware) has the same Zigbee configuration, so should be fine too.