[APP][Pro] Xiaomi Miija (Temperature and Humidity)


Currently, it supports the Xiaomi Mijia (LYWSD03MMC) (BLE + Zigbee), with the ATC441 protocol, flashed with a custom firmware. The custom firmware can be flashed from here GitHub - pvvx/ATC_MiThermometer: Custom firmware for the Xiaomi Thermometers and Telink Flasher .

Second sensor - Xiaomi MJ_HT LYWSDCGQ/01ZM - shall be working out of the box (Bluetooth only).

Please note that Bluetooth on Homey 2023 is far from ideal state, mostly due to the limited range. So if device works in close distance but do not work from 3-4m, it’s not this app fault - please keep contacting Athom.

Key credits still to ZsR, original developer of this app.
Also thank you to robertklep for code contribution and some consultancies :wink:

If you would like to appreciate the effort behind, feel free for use Contribute section on https://homey.app/en-cz/app/hu.corenet.mitemp/Xiaomi-Miija/test/

Thanks for adding this. I do have an issue with reading the correct values in Homey.
After flashing the firmware, all looks well in the Telink Flasher app:

These values are also shown on the display.

However, the values in Homey are totally off:

Does anyone have an idea on how to fix this?

Hello DGalama,

Can you check if the advertising format is atc441?

1 Like

Awesome, that did the trick!

I’m happy that it worked! :slight_smile:
Enjoy your smart home! :slight_smile:

Could you please help me wih adding a LYWSD03MMC to my Homey Pro 2019 using your app? I have succesfilly flashed the sensor:
Status: Hardware Version: LYWSD03MMC B1.4, Software Version: 4.3
Vbat: 2745 mV , Temp: 28.20°C, Humi: 55.85%, ID: 190, Reed switch counter: 0, flg: 0x04:r0/t0

I set it to advertising type ATC1441, but Homey / the app can’t find the sensor while sarching for it. “No new devices found”. Do I need to pair it first with Homey? Or am I missing something else?

Thanks for your help!

I need to test it on my 2019 Homey Pro, but it should work. Sometimes you need to wait a few minutes until it is discovered.
I’ll test it and I will get back to you.

Thanks! Already any idea? I can wait but it keeps returning no devices found. Do I have to do something with the sensor? There is no button on it. Thanks again.

How much distance is there between Homey and the sensor? Since it uses BLE, range is limited.

Thanks for highlighting this issue! It looks like that the uuid is reported differently on the Homey Pro 2019 and on the new Homey Pro.
I have just corrected this and and the new version 1.1.3 is already out! Please update to the latest version, and then it shold be working now.

Hi Robert,

Yeah, the BLE range is quite limited, but in the custom firmware there is a possibility to raise the transmitting dB, that could help.
I live in a 3 storey building, the homey is in the middle. It receives sensor data from all storeys. I think the range can be defined around 20m in buildings…

Probably not on HP23, right :frowning:

I’m on HP23 currently. In our house, it is working quite well. (10-15m distances, through walls) Of course, I need to place the HP23 in the middle. But a satellite Homey Bridge that could repeat the BLE would also be helpful.

Yes, after the update I can add the monitor without any problems. Thank you! :smiley:

Hoe often do the readings update? Can I adjust these values?

Hi there!

I have a Xiaomi Miija and flashed it using the provided link (see screenshot) and it seems to work correctly on the web app, but when adding it to Homey Pro it says no device found…

Any idea and suggestion to make it work?

The thermometer is 2 meters away from the Homey, so range shouldn’t be an issue.

App version is v1.1.3

Have you enabled ATC441 protocol ?

1 Like

As @Sharkys asked, I think the protocol is not set correctly. Please check it. :slight_smile:

Actually, I did! :grin:

ATC1441, right?

And just to be sure, you also closed this browser page, to ensure it’s disconnected.
In case you have tried multiple times and it still do not work, I would suggest to restart your Homey…