[APP][Pro] Xiaomi Mi Home App

Thanks for looking into it @Phuturist :smiley:
Report:
82648baa-b80e-4880-b5f1-d6135edf5435

How can I clean different rooms with a flow ?

Hello all!

I have a problem, suddenly all my zigbee devices associated with my 3 gateways have stopped working on homey. In the xiaomi home app and home assistant they work perfectly. I have tried everything imaginable, restarting homey, reinstalling the Mi Home app… but I can’t get my devices to appear. I manage to add the 3 gateways with mac and pass and IP and token, but I can’t add the sensors, it doesn’t find any.

Has this happened to anyone else and managed to solve it?

@Phuturist Any ideas? My house is not working!! :rofl:


Nope. The ZigBee gateway and sub devices functionality of the Xiaomi app wasn’t developed by me. I have little knowledge on how it works. The library that is used for this functionally isn’t being maintained for years now as well. This whole part of the app is supplied as is

Having said that, nothing changed either and I don’t see other users with this issue. So I guess it still works. Are Homey and the gateways on the same LAN?

Homey and all iot devices are on the same network and the same access point. I can add the gateways and interact with them (Turn on led, sound…), but it cannot find any of the zigbee devices added to the gateways (about 37).

I recently changed the access point from a ubiquiti U AC Pro to a U7 Pro, but after this it worked for a few days.

Any idea what’s wrong @Phuturist? The Xiaomi Smart Air Purifier 4 Compact constantly jumps between these two screen since the installation:
afbeelding

afbeelding
Mostly staying on this schreen :arrow_up:
keeps giving error: “Cannot read properties of undefined (reading ‘toString’)”

Looks like its is trying to read data that does nog exists?
(Report: 82648baa-b80e-4880-b5f1-d6135edf5435 )

I did not receive this diagnostic report, could you send another.

Does this one work?:
2be79b67-5ce2-4b95-ae30-b9865aee4b72

Turns out I already fixed that issue locally. Havent found to time to publish it though.

1 Like

Awesome! I shall wait for the update :slightly_smiling_face: :+1:

An update launched today for the U7 Pro has solved the problem. I don’t understand why it didn’t work only in homey but at least everything works again. Mysteries of computing.