Homey Community Forum

[APP][PRO] VThermo

No.

Try restarting the app.

Settings → Apps → VThermo → Settings-wheel → Restart

I have similar issues. Specially if power is lost, and Homey started again. Vthermo then has a wrong temperature value instesd of the value from the temp sensor. A proper restart og Homey seems to solve the problem

Hello @balmli,

I’m trying to use VThermo to send a demand for heating to my central heating boiler by triggering Fibaro switches relays when the temperature in zone falls short of the target temperature set by Markus Kling’s Scheduler App, and sent to my Popp Thermostatic Radiator Valves.

I’m having trouble understanding the VThermo triggers, actions and conditions. In particular:

Is this referring to the set point of the VThermo or one of the devices in the zone/sub-zone that the VThermo monitors?

What does it mean when a thermostat is off or on? Does this mean that the VThermo is enabled/disabled? Or one of the real thermostats in the zone/sub-zone that the VThermo monitors has power or not? Or something else?

“Target temperature has changed” → same as other thermostats. This means that the set point of the VThermo was changed.

“The thermostat turned off” → means that the VThermo stopped “heating”

“The thermostat turned on” → means that the VThermo started “heating”

“The thermostat is on / off” → heating or not…

Thanks @balmli , that’s helpul. So If I understand correctly, a flow like this should turn on the Fibaro relay that demands heat from my boiler:
image
…which compares the current measured temperature from the devices in the zone and compares iit with the radiator TRV set temperature…

…provided I have:

  1. The option for Heaters ticked in the VThermo device settings:
    image

  2. The Fibaro switch/relay in the same zone as the VThermo device

  3. The Fibaro switch/relay designated as “Heater” under “What’s plugged in?” in the phone version of the device settings (which doesn’t seem to be available in the web version of the device settings)… so that VThermo knows it’s a heater

image

Is that right?

If so, is there any advantage for using VThermo vs a flow like this?:
image

If understand correctly from reading above, I can tick the option in the VThermo device settings so that the heating is turned off if a window open (contact alarm) in the same zone is active and back on again if the window is closed, without other flows, but in my case the “turning off” would presumably just turn off the boiler heat demand, rather than the turn off / reduce the radiator set temperature - is that right?

…is there any advantage for using VThermo vs a flow like this?:

Can anybody else explain, if I’m missing something here. Do I actually need VThermo to make this work, or should I stick to regular flows and save memory by having one fewer apps installed.

Thanks

The purpose of VThermo is to automatically turn heaters on / off based on a temp sensor in the same zone… without flows.

The option “Heaters” you mentioned is for controlling heaters in sub zones on / off. So you don’t need to check that one… as long as the heater is in the same zone.

And yes, the Fibaro switch/relay must be marked as a “heater”.

You might need flows to set the target temperature for the VThermo… but not for checking the temperature and switching on / off.

I have not tested VThermo with the “Heating Scheduler” app, so I don’t know if that works OK.

@balmli hi, it happened twice in the last 20 days that the app stopped to work. Unfortunately you recognize it only if you go in the app or because you see that your temperature is below the set point the vthermo is correctly orange but the heater is stopped. I have created a flow to autosolve the problem, but I still don’t know if it works.

Can you check the memory consumption of the app ? It’s visible in Insights

@balmli Thanks for your fast feedback. For your info I generally restart all apps once per day with a flow, since I have many and I saw that memory consumption increase with time. So also your app restarts every day, so in the graph you will see this.


You can see in the first graph the last 24 h and the second the last 7 days. What I saw today is that, despite the app did not show any unexpected stop, at least two Vthermos in my house were “sleeping” .

I manage another homey of my neighbor, he has just two vthermos and they work perfectly.

My configuration is for sure much more complex and it is the following:

  1. one indipendent at first floor
  2. one in the living area and three in other three subzones
  3. one in the ground floor and two in other two subzones.

It seems that some have this issue other not. I’ve tried to cancel one that has the problem and to add a new one but it behaves at the same way. It doesn’t switch automatically.

Further update: it seems that Vthermo stand alone, not in subzone works. Those in subzones not. In particular it seems that despite hysteresis is set to zero, the system consider 0.7 before switching the state (in both direction)

Thanks @balmli

I’ve tried to set it up that way, but I must have something wrong in the settings because the relay isn’t being switched by VThermo in the same zone. What is wrong in the following settings?

Looks like you have turned the VThermo off.

Looks like you have turned the VThermo off

Ah that’s actually just now when trying to long press to get the settings.

In fact it’s been active for the last 3 days until now.

…but it isn’t turning on the Switch for some reason

image

Hi @balmli, great app, love it, saves me a lot of work.
I have a few Neo Coolcam motion sensors with temperature capability. Once in a blue moon a temperature of 0 degrees Celsius is reported.
Not sure if it is Homey, the Neo Coolcam app, or the sensors themselves, but the null values cause massive overshoots.
Can you include a zero-value filter to VThermo devices? Before average-min-max and perhaps an option switch in the settings pane?
I did some damage control with a few extra flows, but it kind of defeats the purpose of your app.
Thanks in advance!

Hi,

I will consider this for the next release of the app.

But, have you checked the battery of the Coolcam device ?

Thanks for considering.
As for the Neo’s, I have 6 of that type and a few newer ones. Only two report 0°C about 5 times in a week. Only temperature values are affected, luminance and battery levels show no glitches. The others have the same hw and fw version. Batteries are all good. I have 61 devices in a rock-solid zwave network. None of my Fibaro’s have this issue.
A bit of a mystery so far. Would be nice if filtering the bogus values overcomes the problem, even though the real issue hides somewhere else.
Thanks again

Yes, I will add this for the next release.

V. 1.8.0, with the following changes are ready for testing_

  • Added option to validate temperatures
  • Stability improvements
  • Migrated to SDK3

Click on this link to get access to and install the test-version:

cc: @Lammy

I tried the test-version and it works perfectly. Elegant solution, by the way.
Thanks!

1 Like

V. 1.8.2 with a new feature:

  • Added option to control physical thermostats

With the “control physical thermostats” - option, you can use other temperature sensors than the physical thermostat has, eg. an Aqara temperature sensor with a Heatit Z-TRM3.

Click on this link to get access to and install the test-version:

Please test! :slight_smile: