VThermo app

I use the VThermo app and it’s great!

However for my kitchen I’d like to exclude one temperature sensor: the one in the refrigerator.

Is there any way to do this?

Create another zone in your kitchen with just the devices you need?

The update just installed. It now has a setting to use the “temperature from thermostat” in the vthermostat.

Could someone please explain a use case.

You can use the “temperature from thermostat” if you want to control other heaters based on the temperature measured from thermostats in the same zone.

Had a small issue with double notifications. Cause was most probably the Vthermo App.
Reported it to @balmli and the issue was immediately investigated and fixed!

What a great service. You rock man!

1 Like


I’ve noticed a small issue. One of my thermostats keeps turning off. When I turn it on again it will turn off after a (random?) intervall. I’ve not tried to remove and recreate the thermostat.

What is the purpose of turning thermostats on/off anyway, is it to disable heat control?



By turning the VThermo device off the heating turns off, and the VThermo device does not control the heating.

That’s what I thought.

What about the one thermostat that turns off (randomly?) by it self?

Well, have you tried to delete and add the VThermo device again?

The device should not turn on / off by itself.

I have a Heatit Z-water and a Vthermo in the same room, along with a temp sensor from Aqara. The Heatit z-water channel for this room is set as heating and I can switch it on/off manually. The VThermo does not “see” the heater and VThermo only shows temperature in the room, cant set temperature… Is there something I have forgot to do?

No, you haven’t forgotten anything… :slight_smile:

The VThermo switches devices with class or virtual class “heater”.

But it looks like the Z-water is of type “socket”.

This is something I can fix in the next release.

Thanks. When is it scheduled?

I checked the Z-water and it says: Class: socket (Virtual: heater), I can see the same on the Fibaro wall plug (z-wave plus)

If the class OR virtualClass is ‘heater’ it should work. The device must also have an ‘onoff’ capability.

I guess you have checked your Z-water from https://developer.athom.com/tools/devices ?



false (but i can of course change it to true)

So this should work?

Property Value
ID dc9baa75-b2a7-4658-a2e2-51ee5bc50273
Class socket (Virtual: heater)
Driver homey:app:no.thermofloor — Z-Water
Ready Yes
Available Yes
Warning No
Custom icon No
Capability Type Value Edit value Last Updated
onoff boolean false 4 hours ago
measure_temperature.input1 number -34.94 5 days ago
measure_temperature.input2 number -33.75 5 days ago
measure_temperature.input3 number null 4 days ago
measure_temperature.input4 number -35.03 5 days ago

You can get more information about your devices from this link:


With this command:

Homey.devices.getDevices({ online: true });

and press “Run”

Then you can search for the device in the response, and check the “class” and “virtualClass” properties.

It already shows that on the device page of the developer pages (as on the screenshot he shows)

OK. But I don’t understand why the Z-water does not respond …

But, I think if you include socket it would work anyway… My Fibaro wallplug also shows up with the same class socket and virtual heater. This does not work either…