Homey Community Forum

[APP][Pro] Ubiquiti UniFi Protect

Use your UniFi Protect cameras as motion alert sensors.
Monitor your UniFi Cloud Key’s health in a dedicated, new UniFi Cloud Key device.

Supported device models:

  • UniFi® Protect (Network Video Recorder):
    • UniFi® Cloud Key v2 Pro
    • UniFi® Dream Machine Pro (UnifiOs)
    • UniFi® Protect Network Video Recorder (UnifiOs)
  • UniFi® Video Camera G3 series:
    • UVC-G3
    • UVC-G3-AF
    • UVC-G3-DOME
    • UVC-G3-FLEX
    • UVC-G3-MICRO
    • UVC-G3-PRO
  • UniFi® Video Camera G4 series:
    • UVC-G4-PRO

Note: if you are upgrading from a previous (beta) version, please re-add your devices.

Getting started:

  1. Create a local access user in the UniFi Protect web interface (used only for Homey.
  2. Install this UniFi Protect app on your Homey.
  3. Go to the UniFi Protect app’s settings page.
  4. You will be prompted to enter the credentials of the UniFi Video user you created in step 2 and some network information.
  5. Start the ‘add device wizard’ in Homey, search for your UniFi Cloud Key and/or cameras and add them to your devices.
  6. If the user credentials changed in UniFi Protect, they can be updated on the UniFi Protect app’s settings page.


  • A flow can be triggered when motion detection on a camera starts or ends.
  • A flow can be triggered when a snapshot is created on a camera. This card supplies the name of the camera that created the snapshot and the snapshot image itself.
  • A flow action card can be used to create a snapshot, which is is saved to an Image tag.
  • A flow action card is available to set a camera’s recording mode, being one of ‘Don’t record’, ‘Always record’ or ‘Record only motion’.

In a beta version of Unifi Protect, all information about the NVR itself has been removed. We have made the NVR itself deprecated as a device and will be removed in the next version.
Remove the NVR from your devices. The NVR is also no longer obliged to install it first.

Troubleshooting / FAQ:

  • I am using UniFi® Dream Machine Pro and can’t connect.

    • You must select ‘UnifiOs’ in the Application Settings.
  • I get a lot of false motion alerts. Is there anything to do about that?

    • Turn off ‘Enable Auto Rotate’ and rotate the camera manually.
    • Remove the default motion zone and create a motion zone with only the zone what you want to detect motions.
    • Set ‘Minimum seconds of motion to trigger event’ on 1 second or higher
  • Do you have more tips? let me know!

  • I am using a UnifiOS device, I don’t see any storage information.

    • UnifiOS device does not release storage information through the API.

Would it be possible to have a flow card with “Smart detection triggered” and the ability to choose between Person and Vehicle?

1 Like

No, Unifi Protect Websockets does not give an signal with an smart detection property, only motion…

I’ve got the g4 Doorbell. I’ve made a flow trying to catch the doorbell ring and then play a sound on my sonos but it doesn’t work. Someone else having this problem?

Thanks for a great app. I had it working in an earlier version but now i can not get it to login anymore. :slight_smile:

Running on a Cloud Key v2 Pro i guess the port should be 7443 right? Now i get ‘Request failed’ and 401 against /api/auth/login.

I tried logging in manually to protect web page with the same local Unifi Protect account created for the homey and it work fine.

Any advice on something to try is highly appreciated!

1 Like

please use UnifiOS option when you have updated your controller. Port is 443

Reinstalled the homey-app, recreated the local user after the cloudkey/protext update and now it works fine :slight_smile: Thanks for your help and a great app!

1 Like

I have a Dream Machine Pro and i can’t connect it to my Homey Pro. I think it is the problem with the Two-Factor Authentitation token. Can you tel me how to do.

Can you create an local account ?

Same issue here! Resolved by re-installing the app. But now homey cannot read snapshots. I get “invalid_image_buffer” when it tries to display it.

Do you have restarted the app already after setting al settings ?

Thanks for a great app. I’ve recently started to use it. I have several cameras and the app works fine for sending a notice when detections are happening, and also for capturing snapshots on events. However I can’t change the recording mode on any of my devices.
When capturing a snapshot I can see a couple of rows in the log in the app config page, but when the change recoding mode is triggered nothing is shown in the log so I’m assuming that there is no request beeing sent to Unifi then?

Using my local user to login locally into my Dream Machine I have verified that my user has the correct rights to change recording mode on the cameras.

Is there anything else I need to do in order to get homey to change the recording mode?

Using the Unifi Protect G3 instant camera ( UVC-G3-INS) here with the app, and it also works! So you can add that one to the list.

1 Like

In EU we are waiting for this for a month now! :smiley:

All commands to change data or take actions have had an API security update from UniFi which stops it working.

I haven’t had time to check this out yet and am first busy rebuilding the UniFi Network app in my scarce spare time.

I develop the three apps that I develop in my spare time without receiving any real compensation or help from others who can help with programming.

1 Like

Hi @ObelixNL, Thank you for your time and dedication you put into your app(s)!

I was wondering about the following, In the App settings I see the status

Realtime updates Status: Unexpected server response: 200

It’s probably nothing serious. is it? :slight_smile:

hey @Daniel_Johnson any luck with getting catching the doorbell Ring? @ObelixNL Is this an option, I just added the doorbell, but do not see a flow option yet to catch the doorbell ringing. Quite new to this so maybe I missed it.


Hey folks,
I’ve got the app running for a while now. Since yesterday I’ve installed the G4 doorbell and ever since I created a flow for it, the app stopped as in, it shows the PAUSE icon on the apps list and devices are unavailable.


Quite annoying as we depend upon Homey to ring when the button is pushed.

Also remarkable is that when this happens, the settings screen looks like above.

However, once you reboot the app, it behaves as expected. The thing is, today alone I rebooted the app 4 times or more, I lost count.

Does anyone have a tip? Or should I just go and ask the developer?

1 Like

This is fixed in the last test version today: https://homey.app/a/com.ubnt.unifiprotect/test/

1 Like

thanks for the test version. I can also change the record mode again.