[APP][PRO] Plugwise Smile P1 - Dutch and Belgian Smart Meter Reader

v4.2.1 was just released in the app store

  • Fix flow start before capabilities update.
  • Log tarrif change.

v4.2.2 has been released earlier this week.

  • Changed internal FLOW code.
  • Fix flow AND card for tariff sometimes incorrect.

Hi! I’ve been searching everywhere and can’t find an answer. My Plugwise Smile P1 (V3) doesn’t seem to want to connect to my smart meter. It’s a Landis + Gyr E360. Any ideas on what I can try? Thnx!

When I google on the smart meter you have I do find multiple reports that the P1 output is very problematic.

I suppose you already contacted Plugwise about this. What did they say?

Haven’t received a reply yet. Will let you know as soon as I have :slight_smile:

I got a reply from Plugwise. Apparently the meter I have has a P1 port that isn’t “pure” enough. The data that it’s passing isn’t “low” or “high”, so it’s seen as corrupt and is therefore unreadable for the Smile P1.

They also said that this problem of “unpure” P1 port persist with most of the newest smart meters. They give two options to mitigate it:

  1. Contacting the installation company to install a different meter (i.e. I think an older model smart meter with a pure P1 port.

  2. Using an Active P1 Port Splitter, which “purifies” the data so that the Smile P1 can read it. With an extra benefit that you then have an extra P1 port in case this is needed. They recommend using this one: https://www.tech4ushop.nl/p1h-005.html. They also said that it’ll work.

(This is translated from Dutch to English)

The first option is very time consuming. So I’ve ordered this splitter (though I’m a bit salty that I need to spend extra cash (not just for the splitter, the power and cable you have to purchase separately. Plus it’s an extra socket I need to use in the utility closet). Once my order has arrived and I’ve installed it, I’ll post an update. Fair warning, the webshop doesn’t offer the smoothest shopping experience.

I did send Plugwise an email back stating that I hope they do something to their firmware, since it’s ridiculous that I have to by an add-on product from a third party to make their device work as advertised.

From what I understand, some smart meters (including the one you have) need a pull-up resistor to be able to work properly (it’ll make the signal more decisively high/low).

It’s a (very cheap) hardware modification that Plugwise could have added to their device.

Sorry for the late update. I’ve installed the splitter and the data comes in on the Plugwise App. I still need to figure out how to make this work in the Homey App, since it doesn’t seem to find the device. But honestly, I’m very underwhelmed. Not worth the money.

Hi Robin,

When I would like to see ‘Low tariff = YES’ in my Homey screen, what advanced setting should I activate?

Mmh. Maybe I did not implement that in the Smile app :grimacing::sweat_smile:

In that case you could delete the device and select the right options during re-pairing.
But you will lose all your history/insights and it will break existing flows…