[APP][Pro] Nuki Direct

Hello @Rens_Hoekema ,

Any Nuki user can suggest a new feature by submitting a request in the dedicated section of the Nuki Developer Forum.

I, as a Nuki user, am not very interested in the feature you suggest (in my opinion every Homey app related to a device should be focused on the integration of such device into the home automation routines and shouldn’t duplicate the configuration tools provided by the device manufacturer).

But you, as a Nuki user, can submit your request to the Nuki Team.

If your request is accepted by the Nuki Team, I, as Nuki Direct developer, will integrate the new feature as soon as it is made available through the Nuki Bridge HTTP API.

Hello @fantross,
Your tests show that there is a network problem (neither Homey restart nor Nuki Bridge restart resolve the problem; just a network device restart resolve the problem).
Nuki Direct interacts with Nuki Bridge exclusively through HTTP transactions. The HTTP transaction support and the underlying network layer support is provided by Homey. I cannot rule out that there is a bug in the HTTP transaction support or in the network layer.

You can create a diagnostic report. This requires you to sideload this app with a CLI install (as Homey Community Store doesn’t provide this functionality yet, if I’m not mistaken). However, the diagnostic report collects several information about the application logic; it does not gather information about the network errors but we already know that the network error is EHOSTUNREACH.

I suggest you the following test when the error appears again:

  • Connect your notebook (or your smartphone) to the same WLAN router your Homey is connected to.
  • Open a web browser.
  • Enter in the address bar a HTTP request for the Nuki Bridge. For example:
    (you do not need to enter the correct token, as we are just interested in checking the network connectivity with Nuki Bridge).

If your browser runs into the same error as Nuki Direct, we can state that there is a problem in the WLAN router.
If your browser receives a response (a simple text that represents a JSON object) from Nuki Bridge, the problem may originate from the Homey side.

Hello @Piero_F,
Thank you again for your excellent support. I will give you the needed information the next time.

But just for information, I didn’t restart Homey this time.

Hi all,

I am trying to figure out can I use nuki opener + nuki direct to working with homey without the need to purchase the nuki bridge. Is that possible with this app?

Sorry in advance if my question sounds obvious. I am not too sure this, this I am asking :sweat_smile:

Was hoping or wondering if some1 found a way to obmit the bridge.:sweat_smile:

Will Nuki direct work on V4 or only V5

Nuki Direct v1.4 is written with Homey Apps SDK v2 (Homey 4.x). Nuki Direct v3.0.6 has been developed with Homey Apps SDK v3 that requires the upcoming Homey 5.0.0. Both Nuki Direct versions are available on GitHub and on Homey Community Store.

I have the app installed and works but the door status update is not updated

So when I open the door the app don’t say it’s open the status wil update later is that right ?

Yes there some delay in the doorsensor and thus also reporting back to the app. It is not “real-time”.

Sometimes one of my nuki lost the connection and is not responding on Homey
In the nuki app self it works very wel

What is the problem ?
I have 2 nukis on one bridge and connection is great

Please start reading at post #182.
Maybe it should help.

Don’t get that message

Hello @Mark1541,

Please note that the connection path of the Nuki app for smartphone (Bluetooth or network connection towards Nuki Servers on cloud) differs from connection path between Homey and Nuki Bridge (wireless local area network). This implies that also the connection status may differ.

For example: if you and your smartphone are at home but your Bridge is out of order, Nuki app for smartphone still control the Smart Lock thorough Bluetooth whereas Homey is unable to control all the Nuki devices connected to that Bridge.

In order to answer your question some information are needed.

How do you detect that Homey is not connected to the Bridge?

  1. Nuki devices are marked as unavailable in Homey app for smartphone.
  2. A command (for example: Unlock) sent to a Nuki device by Homey app failed.
  3. Other.

Case 1: Please go to procedure for pairing a new Nuki device and take note of the error reported by the pairing procedure.
Case 2: Please take note of the error reported by Homey app (red popup) when the command fails.
Case 3: Could you kindly explain how the error is acknowledged?

How do you fix the problem?

  1. The problem is temporary and after a while Homey reconnects to the Bridge without your intervention.
  2. An explicit action is required (Restart Homey? Restart Bridge? Restart WLAN access point or another network device? Re-pair Nuki devices in Homey? Other?)

Thank you in advance for your answers.

1 Like

I’m also having now a red exclamation mark with my 2 nuki,s

I entered the op and my I’d

Have a lot of text pairing true wififirmwire uptime serverconnected true

When I restart deco router it’s up and running…l

Hello @Mark1541,
Sorry but I do not recognize “pairing true wififirmwire uptime serverconnected true” as an error string generated by Nuki Direct. Are you using Nuki Direct v3.0.6?

When you execute the pairing procedure in Nuki Direct v3.0.6 in a “not-connected” status, I do expect you briefly see a picture of a globe (connection to Nuki servers). The Nuki servers return the info of your unique Bridge to Nuki Direct. Then Nuki Direct should shortly show a picture of a Nuki Bridge with the message “Press the button on your Nuki Bridge within N seconds.” ("Druk binnen N seconden op de knop van je Nuki Bridge. "). Then, probably, an error message should appear.

Again, I kindly ask you: After the problem occurs, how is it solved?

  1. The problem is temporary and after a while Homey reconnects to the Bridge without your intervention.
  2. An explicit action is required (Restart Homey? Restart Bridge? Restart WLAN access point or another network device? Re-pair Nuki devices in Homey? Other?)

When I add them again get the message econrefushed and when I restart my tp link deco they are working again I see a red exclamation mark on the locks in homey

I’ve installed the official athom Nuki app

On that app I’ve also problems
It’s not updating the state so when o manually open the door homey nuki app say locked but door is open
Is it an problem with my bridge or WiFi ?

Hello @Mark1541,

I try to summarize your support request.

You recently installed Nuki Direct v3.0.6.

Since the first time you installed it, you experienced occasional disconnections of Homey from Nuki Bridge (red exclamation mark for each Nuki device in Homey app for smartphone). The red exclamation mark does not provide any diagnostic information therefore you performed a pairing operation. The pairing operation briefly (< 1 sec) showed a picture of a globe, then it briefly (<1 sec) showed a picture of a Nuki Bridge and, finally, an ECONNREFUSED error message.

Thereafter Nuki Direct remains permanently in this disconnected state. The only way for connecting it again to Nuki Bridge is to restart your router/access point.

Well, my suggestion is to check the configuration of your router/WiFI access point (TP-Link?) which, from time to time, refuses the connection of Homey to Nuki Bridge.

Hope this helps. Anyway, I kindly ask you to send any further messages related to this problem privately. Thank you!

I don’t know but I have to recharge my batteries more often than before, normally every 3 months now every 1,5 month that is an use decrease of battery live.

I understand that now we are at home the whole day it takes more battery live but twice as much ?

Hello @ChrisBoer,

The Nuki apps for Homey (Nuki Direct and Nuki app by Athom) communicate only with the Bridges, so they cannot drain the battery.

Maybe your battery drain is caused by other reason, lower temperature, lack of mechanical lubrication, …

The Nuki app for smartphone reports very detailed information about the battery usage for lock/unlock operations.

There you can check if the consumption for an operation is too high and/or if a proper cleaning//lubrication of the mechanical parts may decrease the load on the SmartLock motor.

1 Like