[APP][Pro] Insight Trends [Abandoned]

No the app is abandoned atm, so when you know anyone who likes to take over, ánd if Madmonkey wants to transfer it…
Madmonkey broke with Athom, it’s mentioned in post #1


Could @Gruijter be persuaided to continue this app development? :thinking: Small relation with the archive insights app…

Such a pity, mostly when you can still support the Community, eg. by sharing your work in the Community store, yet instead you pulled off both your app and sources on GitHub. While I understand @MadMonkey you may have same disagreement with Athom, I don’t understand why you have punished also us, users :frowning:

Anyway, thank you what you have done, Insight trends was kind of master piece… now I can hope that my Homey will not need to be reinstalled.

1 Like


1 Like

Maybe you are probably right, thank you

1 Like

Unfortunately I already have a lot of apps to maintain. So sorry, but no (unless I’m persuaded in a way that I never have to work again and can fully focus on Homey apps :kissing_heart:)


Sorry to read that you stopped developing this great app. :cry: I read that it is available on GitHub. Can another programmer take over from you?

I think @MadMonkey will not respond anymore when I read his first post. I also hope someone will take over this great app.

Here is how to install using CLI: [HOW TO] CLI install method - Tutorials - Homey Community Forum
App can be found on GitHub: GitHub - MadMonkey87/Homey.InsightTrends at sdk-upgrade

Edit: changed the link to GitHub to the latest version

1 Like

I agree with you and I will really miss this app if it will stop working!

1 Like

Did you manage to install it? I can’t, too many errors…

Yes I managed to install the app. I downloaded the zip file on GitHub and installed that using the cli.
it is version v.2.2.0.



I have version 3.0.0 installed from the apps.homey site when it was still available there. Can’t find that version on GitHub. :slightly_frowning_face:
I don’t know if it’s possible to give you my version?

I found version 3.0.0 on GitHub


When i try to install this update/version I recieve the error “× Homey App did not validate against level debug:”

How can I fix this?

I am very curious what you’ve downloaded and installed.
Whatever I try, it’s full of errors and won’t validate / run or install
My Homey is on v.8.0.3 btw.

My Homey version is 8.03 as well. Did you follow this cli manual

then unzip the app you downladed from GitHub, extract it. go to the extrated directory and then to this this directory ch.philippewechsler.trends

start the node cli login in the cli go to this diretory ch.philippewechsler.trends
the give the command Athom app install

thats it

Thanks Henk,
Sometimes reading the error msgs a bit closer helps :wink:
It said:
errors may be fixed by running npm install in your app

So I ran npm install and after that npm audit fix --force
After that I pasted the contents of the Homey.InsightTrends-sdk-upgrade.zip file into the Homey.InsightTrends-main folder and ran the last 2 commands again.

Now it works :partying_face: , it’s still v2.2.0 but I don’t care for now.

1 Like

Hi Peter,

I did the same! Copy the upgrade to the main dir. applying the two commands then run the install…Yes! Now I have version V3.0.0! :partying_face:



Lucky you, I was still on v2.2.0 :upside_down_face:
So I tried this: I ran both commands in the Homey.InsightTrends-sdk-upgrade folder, and then I ran homey app install et voilà! v3.0.0 it is!
(I now did not use the .main folder)