[APP][Pro] Homewizard

I have almost the same issue as @Arnold_vd_Linden. When opening the Homey app the Energylink has the exclamation mark and after a few seconds it is gone.
Wile waiting a time then the exclamation mark gomes back and after 2 seconds it is gone.
Before the update this was never an issue.
I also didn’t change anything with the location of the router or other hardware.

Is het noodzakelijk dat de time-out zo drastisch is verlaagd?

This has been adjusted to 13sec in test version 2.1.9 which is still pending approval. Polling is every 15 seconds to Homewizard and as of 7.4.0 the app log is trashed with errors so I need to do something about catching the real problems from the slow Homewizard that are unable process within a acceptable time. But if you have better suggestions?

Thx.
I have no suggestions. Just trying to understand the issue.
Because I was very happy with this app and the use of my old EnergyLink.

The issue is that Homewizard (legacy) so the old unit, has a crappy wifi chip. And with the introduction of Honey firmware 7.4.0-RC22 recently I see a massive amount of crash messages. Some due to bad coding of me (sorry am just a hobbyist and not a coder) and lack nodejs knowledge or some advanced coding sometimes required to do Promise,rejects,catch etc stuff. I also see a lot of timeout and connection errors from users that clog the log inside the app. Which is related to bad wifi network of people using the old Homewizard.
I mean still even after 15seconds some users Homewizards fail to respond or finish the respons on a query poll that is needed every 15/20 seconds. Now that is my pain to manage and nobody cares even. I am keep getting complaints that it is not working and suggest to improve the connectivity of their Homewizard. Now I changed the timeout to get rid of other errors but by doing that I get unhappy users because the polling fails. That is what frustrates me the most.
I am at a point that I don’t care anymore and bump the crap back to 20 or maybe 30;seconds and poll less, but then others will complain it doesnt gather recent information (motion sensors or whatever smokedetector).

Wow… that’s a struggle. And first of all I appreciate your effort!

So as I understand it has tot do with the old hardware and newly hardware of Homewizard.
Is it an option to make separate apps for them?
The old hardware is out of support and there will not be much updates needed. With the newly created app for new Homewizard devices you can focus pure on that development.

Its policy to have all same vendor stuff in one app. Inside the app are drivers per hardware. This is how I can control different support per hardware. Yet the old hardware like your Energylink is not supported by the vendor anymore but still expected to be perfect in my app?
All communication for the Energylink, Windmeter, sensors, rainmeter goes through the main unit which is the core of the problem. That device is more than 10 years old, using wifi tech of that time. Prone to wifi connection issues with newer wifi accesspoint hardware. Slow, dropping traffic etc. This app keeps growing in memory when connection issues occur and store those errors in the memory.
So hence I tried to lower the timeout and getting better memory management inside in the app as it will give different smaller errors rather than the full list of lines that fail.

But I had enough people complaining so I will drop my goal and increase timeout more and poll less, don’t really care it will be less accurate.

1 Like

That is a good explanation, as far as I understand it.
I have one more question.
My Energylink gives that red exclamation mark every x seconds. But as far as I understand has that something to do with the polling time, but it does not affect the functionality of the Energylink.
It is only not as accurate as before, that’s all?
Am I correct?

Yes and no. Red marker means it has communication issues with the device via Homewizard.
So it keeps trying till it does get a successful update within the polling cycle and will update and remove the red marker. But when it fails it will put up the red marker again.

But I am fed up with this and will turn this the other way round. I will increase the polling time and timeout as I am only getting unhappy users that don’t tend to see and understand the core problem.

Test version:

2.1.10

  • Increased Homewizard Legacy polling to 20s and timetout to 18s due to slower devices that have local wifi issues with app users.

Halo @Jeroen_Tebbens
Don’t know if test versions are automatically updated but mine is automatically updated to 2.1.10. It is no problem and never noticed it that a test version is updated. Even when automatic updates is on.
But is is no problem for me.
I have checked it in the app and every 20 seconds the energy values are updated and every minute I get the red exclamation mark for not even a second.
For me that is no problem. I only want to tell you this.
Thanks for trying things out.

Perhaps unplug your Homewizard main unit for just a few seconds. It has a bad habbit of overloaded and not closing the ports soon enough. Let me know if that improves the Energylink behavior.

I have unpluged my Homewizard and after the restart it has not changed anything.
Between the 2 times popping up the exclamation marks the energy value changes
2 times.
So there is a connexion.
And maybe it is only me at this moment. So let’s wait if there are more people with the same problem.

That is strange as I have not touched the Energylink polling as that one is every 60s.

Is that polling the time between the measurement of the energy or the time between looking if the Energylink is still connected.
Every 60 seconds there is for a short time the exclamation mark and an updated value of the energy, and then after 20 seconds an update of the energy, 20 seconds later another update of the energy and than 20 seconds later the exclamation mark, with the new energy value.

20s is on watt measire. The 60s is on getting the T1 &T2 from the P1 port.
It will always be a red marker when you start the app, then it should update when it gets its first valid polling.

When I open the Energylink tile and I watch the values then every 60 seconds it says the Energylink is unreachable. But every 20 seconds the real energy is updating. That is what I see.

Energylink fix in 2.1.11 (test)

2 Likes

I have tried version 2.1.11. Watched it for 5 minutes and every 20 seconds an energy update and no red exclamation marks.
Thank you.
And did buy you a beer.

1 Like

Thank you!
For me there is no exclamation mark anymore with version 2.1.11.