[APP][Pro] < group > (3.2.4 - Stable)

Hi @Jamie , Is there a way to retrieve the IDs of individual components within a group using Homeyscript? In previous versions, this was possible, but now the new groups work with a different driver, and I can no longer do it

The app has started to hang lately. In the last three days I’ve had to restart it (the app) twice in order to get devices to work.

Anyone else had this problem on 3.2.4? It’s on a 2019, but if customs can get their act together I should be on 2023 son.

I also have the same problem. I own an HP2019 and version 3.2.4. Every time I restart Homey, I have to wait a few minutes and restart the app because it doesn’t work properly. The groups are stuck and don’t change their state based on the connected devices. Usually, restarting the app once resolves the issue. Just to be thorough, I recreated ALL the groups using the latest version of the driver (hopefully, I won’t have to do it ever again in my entire life :sweat_smile:), but it doesn’t change anything.

@Tiwas @RogoGames , I assume you have sent diag. report while the app is stuck to the developer, correct ?

To be honest, I haven’t done that. The next time I restart Homey, I will send a report. Actually, I’m having some issues with Homey’s RAM, and I thought the app was freezing due to this problem.

Nope. First, I asked if it was a known problem. The last time it happened was around 3am while I was up to pee. So, I restarted the app to get light in the toilet and nothing else :wink:

Are you able to reproduce the error?

@Jamie There are no errors. I tried setting up an advanced flow to handle errors when sending commands, but nothing happened. I didn’t receive a timeout or anything else, so the flow just continued like all was well. If you tell me what you need (and preferable how to produce it) I will post next time I notice.

First, thanks for adding this essential feature to Homey. I was switching from homee, where groups where supported natively and was shocked not to see it here.

I have one feature suggestion: Would it be possible to optionally view all devices from a group after clicking on it? This would be really useful for getting an detailed overview on your temperature sensors or lights etc.

Thanks again and keep up the good work!

pfff is have the same issue.
Replace 3 bulbs, (3 different groups, want to add the new buld to the group, error.

Is there no way to debug this?
i will make 3 new groups now, but its a lot of (unnecessary) work

which also means that I have to recreate my flows every time

There is script you can use to fix all relevant flows

1 Like

thanks for youre reply


And i will check the link you send


I’m going to need more information the. “Went to add new bulb to group, error.”

What type of error, when, where, how, screenshot? What was the name of the group and device? What type of homey do you have? What version of the app are you using? What version of the group app? What version was the group added in? What type of group is it? Other? Light? One of the advance ones? Etc etc.

Using a HPE2023, running 10.0.0.rc105 using version of the app (iOS).

I am running version 3.2.4 of the group app.

I have a light group which was added on version 3.1.3, it uses the capabilities turned on, dim, light mode, hue, saturation, temperature.

All capabilities are set to “average value” except on/off which is set to “any”.

There are four devices in the group, and when I attempt to add or remove a device from the group - it works perfectly.

I also confirms, added-removed several device types and always worked fine, including older groups.

Hi Jamie, I’m using an HP2019 and version 3.2.4 of the app. I create 2 virtual lights and a group where I place them. If I delete one of the two virtual lights from Homey without removing it from the group first, I won’t be able to modify the group anymore. On the repair screen, I see the error [device_not_found]. I’ve tried repeating this operation several times (creating new lights and new groups), and sometimes I managed to modify the group only once. I’ve created a report (00413d10-4298-4fd8-a075-d5412fcea72a), hoping it can help you. Let me know if you need any further information :wink:

1 Like

Well you make it sound more special them it is hahaha.

I use the hp2019 with app version 3.2.4, when I try to repare I got the same error, on the same way as pmeester, but with bulbs.
I can’t repair the group because the bulb has been delete.
So I have to delete the complete group en make a new one.

the group is a lamp type. Made in version 2.5.301, maybe that’s the problem. I don’t know if this happen with the New groups

Good morning Jamie, after a Homey restart, some groups fail to synchronize their state with their respective devices.
I’ll try to provide you with as much information as possible to help you understand the problem. I hope everything is clear. I apologize if there are any grammatical errors, but I’m not good at writing in English :smiley:

I have a group of lights called “Faretti Bagno” that contains 4 Philips Hue bulbs [Faretto Bagno 1, Faretto Bagno 2, Faretto Bagno 3, Faretto Bagno 4].
The group is set to “on if any devices are on,” but after the Homey restart, the group stopped synchronizing with some of its devices.

For example, in the last test I performed, if I turn on “Faretto Bagno 1” or “Faretto Bagno 4,” the group that contains them doesn’t change its state. The “Faretti Bagno” group only synchronizes its state with “Faretto Bagno 2” and not with the other devices. It seems as if it has lost the registration for some events.

The issue doesn’t occur for all groups; some of them work perfectly. After that, I restarted the app, and all groups responded correctly to state changes.

Afterward, I conducted another test.
I disabled the Group app and restarted Homey. I waited for all the apps to initialize properly and then launched Group.
In this scenario, all the groups worked correctly, and it was not necessary to restart the app.

I’m using an HP2019 with version 8.1.4.
I’m also using version 3.2.4 of the app, and I recreated all my groups with this latest version.
Before running the test, I made sure that all apps were correctly launched.

I generated a report regarding this issue: 2fec177a-0e6f-4139-a796-01d0b46b5eda

If you need any further information, feel free to ask. Thank you! :wink:

:heart: thank you for the detailed reports, very useful. When I get some time I will use it to help replicate the bug and hopefully fix it.

Thanks again