[APP][Pro] BleBox

Using a flow I can now first turn it on to the prefered standard color, and after 1 second set it to any other color….

Why do you do that? What do you want to achieve?

Well, I have a RGB ledstrip that needs to turn on every day at a specific time in the standard color (the on-value in the settings)
But sometimes it’s need to go on in a completely different color.
The only way I can get it to work is to first turn it on (in the standard color) and then change the color.
Or is there another way?

Could you please show me the screenshots of your flow(-s), that show what do you want to achieve?

Ofcourse it’s in Dutch….

And only “Verander naar kleur <>” without “Zet aan” doesn’t work for you? Because I think it should (or I’ve got a bug there). What happens if you send only this command? What exact LED tape do you have (RGB 3 channel or RGBW 4 channel? In which mode is wLightBox configured in wBox?)? Thanks for all the answers, I’d like to troubleshoot this problem.

No, only “Verander naar kleur” does nothing.
If it’s not on already, I can’t change the color.
It’s a RGBW LED strip and also set as RGBW in the settings

No, only “Verander naar kleur” does nothing.
If it’s not on already, I can’t change the color.
It’s a RGBW LED strip and also set as RGBW in the settings

Let’s make some troubleshooting.
With your browser command: http://wLightBoxIP/api/rgbw/state will throw the state of your wLightBox.
Please do the following and send me all the results of above command:

  1. turn off the wlightbox
  2. issue above command and give me the result
  3. send Verander naar kleur command to it
  4. issue above command and give me the result
  5. send turn on and then Verander naar kleur commands to it
  6. issue above command and give me the result

I will do this when I get home this afternoon….

Hi Piotr,

Here are the results:

When off:


Change color to:


Turn on and change color:


If I just turn it in, I get:


Some extra info:
If I just use : change color to…. I see it turns on for just a second and then turns off

It looks like I have a bug with setting the right color with the flow. I’ll have to investigate it further. I’ll let you know as soon as the patched version is ready for test. It should then work properly with just “Verander naar kleur”.

Personally I don’t see it as a bug…
I think it’s not strange that I first have to turn it on, before I can change the color.

I would prefer to change the way to set the On-value in stead, so it isn’t needed to use HEX anymore.

Something like:

First set the Ledstrip in the preferred color with the RGB sliders or a color-picker.

Then press a button: Use this color as default ON-value.

Just an idea……

Hi @Piotr_Grochowski
I just got my gatebox, i have been over the whole thread, thanks for the effort. I am having the same issue which causes Homey not to discover gatebox on the network. Updated the device to the latest firmware but with no luck.

{“device”:{“deviceName”:“My gateBox”,“type”:“gateBox”,“product”:“gateBox”,“hv”:“0.6”,“fv”:“0.1024”,“universe”:0,“apiLevel”:“20210118”,“iconSet”:0,“categories”:[0],“id”:“5ecf7fb48574”,“ip”:“”,“availableFv”:“0.1024”}}

Connected the gatebox with same network of my homey and then the device appeared in the discovery devices. The access point i connected it with before was mi and the. I connected it with tplink.


Yes, any blebox (which supports auto discovery) has to be on the same network as Homey. So if I get you right, your problem is solved?

Yes the problem solved, but the device was on the same network, only that i doubt the mi access point which the gatebox was connected to.

Some routers/APs need to have broadcasts or mDNS-SD allowed, because they deny this by default (I has such a problem also with Mikrotik routers and Xiaomi/Aqara sensors/gateways. After I allowed this traffic the problem with router was solved.

I am having an issue where i can determine if the gate open or not when using the ble app, while this cant be determined in homey app! Btw i am using magnetic sensor.

A restart of my homey pro solved the problem, now the readings are instant one the gate is moved.

Had to restart the app today to get the reading from the sensors, i was not getting the reading for the last 2 days.

Weird. Did the app hung (|| icon on apps listing) or just the connection broke?